MySQL Problem

Dieses Thema im Forum "Hardware" wurde erstellt von WeBBeR2000, 4. Mai 2002.

  1. WeBBeR2000

    WeBBeR2000 New Member

    (2)

    Habe folgendes versucht (stand bei der FAQ von der MySQL installation):

    Most likely you didn't start up the DB server. Try this:
    cd /usr/local/mysql; sudo ./bin/safe_mysqld --user=mysql &
    Then try to connect again.

    Funktioniert nicht!

    Normal ist die DB immer von alleine gestartet worden, durch das startupitem. Aber gestern, als ich meinen Computer angemacht habe, kam auf einmal dieser Fehler, weiß nicht warum.

    Könnt ihr mir vielleicht helfen???
    Danke

    ciao Web
     
  2. mats

    mats New Member

  3. WeBBeR2000

    WeBBeR2000 New Member

    Da kommt folgendes:

    No match
     
  4. WeBBeR2000

    WeBBeR2000 New Member

    (2)

    Habe folgendes versucht (stand bei der FAQ von der MySQL installation):

    Most likely you didn't start up the DB server. Try this:
    cd /usr/local/mysql; sudo ./bin/safe_mysqld --user=mysql &
    Then try to connect again.

    Funktioniert nicht!

    Normal ist die DB immer von alleine gestartet worden, durch das startupitem. Aber gestern, als ich meinen Computer angemacht habe, kam auf einmal dieser Fehler, weiß nicht warum.

    Könnt ihr mir vielleicht helfen???
    Danke

    ciao Web
     
  5. mats

    mats New Member

  6. WeBBeR2000

    WeBBeR2000 New Member

    Da kommt folgendes:

    No match
     
  7. Maike

    Maike New Member

    Ich habe das gleiche Problem. Wenn ich tue, was empfohlen wurde, gibt es aber keine Rückmeldung, sondern einfach nur eine neue Eingabeaufforderung. Geändert hat sich dadurch aber nichts.

    Maike
     
  8. zwoelf11_

    zwoelf11_ New Member

    mats: das versteh ich nicht. mysqld wird doch als root gestartet, changed dann aber nur um auf den user mysql für die sicherheit. mein komplettes mysql directory gehört root und alles läuft prima.

    web: was steht denn als fehlermeldung da, wenn du <TT>sudo ./bin/safe_mysqld --user=mysql &</TT> startest? lass am besten mal das <TT>&</TT> am ende weg. beenden kannst du dann mit ctrl-c (ctrl, nicht apfel)
    im übrigen: lösch die am besten wieder, und nimm die mysql instalation die auf der Macwelt DVD war (keine ahnug, welche das genau ist). die installiert sich säuberlich nach /Library/mySQL
    deine datenbank kannst ja mitnehmen =)
     
  9. mats

    mats New Member

    Ich kann die man page gerade nicht lesen, weil ich mysql hier nicht installiert hab. Aber wenn man die Option --user=mysql angibt, wird doch der mysql-Dämon vom Benutzer mysql gestartet. Wenn dann aber das Socket mit root als Eigentümer angelegt wird, weil die Installation root gehört, kommt die Verbindung nicht zustande.
    Hach, das ist ein Sch... wenn man nicht genau nachlesen kann...
    Darum das chown. Ich hatte genau dasselbe Problem wie beschrieben nach der Installation eines mysql-Updates.

    Das no match kommt zustande, wenn im angebenen Pfad für die wildcard keine Dateien vorhanden sind.
    Ah - mysql ist nur ein Link (alias) auf das verzeichnis mit der aktuellsten Version. Vielleicht klappt's deshalb bei Web nicht.
     

Diese Seite empfehlen