Nach Mac OS X Drucker drucken von Windows aus

Dieses Thema im Forum "Software" wurde erstellt von franzmane, 31. August 2003.

  1. franzmane

    franzmane New Member

    Hallöchen,

    ich hab da ein Problem mit CUPS. Vielleicht weiß ja jemand des Rätsels Lösung. Ich habe einen Epson Stylus C42UX an meinem Mac angeschlossen. Druckt auch wunderbar dank der Epson Treiber. Auch habe ich es schon geschafft, den Drucker an einen PC zu hängen und von Mac OS X aus auf den am PC angeschlossenen Epson Stylus C42UX zu drucken. Ergänzend zum Macwelt-Artikel für alle Interessierten ein hilfreicher Link zu diesem Thema:
    http://homepage.mac.com/william_white/print_to_windows.html

    Nur der umgekehrte Weg will einfach nicht funzen. Auch hierzu gibt es mehrere Anleitungen im Netz, z.B.
    http://homepage.mac.com/william_white/print_to_samba.html

    Das Problem ist das Device. Wenn ich das CUPS Webinterface aufrufe, um einen neuen Printer zum freigeben einzurichten (add printer usw.), dann soll ich dort im Device-Menü immer mein Printer-Model auswählen, aber ich sehe meinen Drucker nicht in diesem Drop-Down-Menü.

    Überhaupt verhält es sich mit dem Epson recht merkwürdig. Da ich den Drucker ja bereits lokal eingerichtet habe, befindet sich auch ein Eintrag im CUPS Webinterface. Dieser hat folgende Informationen:

    EPSON Stylus C42
    Description: Epson Stylus C42UX (USB)
    Location:
    Printer State: idle, accepting jobs.
    Device URI: file://dev/null

    Will ich den Eintrag modifizieren, so steht der Eintrag Device standardmäßig auf "AppleTalk Printer AccessProtocol (pap)" (erster Eintrag im Drop Down Menü) und auf der nächsten Seite steht in der Device URI dann einfach "pap". Egal wie ichs mache, ob ich nun bei der Device URI file://dev/null eingebe, oder was ich sonst noch probiert habe, ich bekomme am Ende immer folgende Fehlermeldung:

    client-error-not-possible

    Der Befehl

    lpinfo -v

    im Terminal ergibt folgende Ausgabe:

    network pap
    network socket
    network http
    network ipp
    network lpd
    direct usb
    network smb
    network smb
    network mdns


    Weiß jemand Rat wo das Problem liegt ? Was muß ich denn als Device und als Device URI eintragen ?
     

Diese Seite empfehlen