Nach webmin-Install Probleme....

Dieses Thema im Forum "Software" wurde erstellt von macLitzi, 5. März 2002.

  1. macLitzi

    macLitzi New Member

    1. Hab webmin installiert und anfangs ging auch alles glatt. Nur jetzt lä´sst sich das Websharing, also Apache, nicht mehr starten. Wie bekomme ich webmin sauber aus X gelöscht und meinen Apache wieder in den X-Urzustand? Kann jemand helfen?

    2. Angeblich kann X ja Webdav. Doch wie aktivier ich das?

    Dank im Voraus
     
  2. RaMa

    RaMa New Member

    1. webmin??? was das... infos??

    apache urzustand
    websharing off
    terminal-->
    sudo cp /etc/httpd/httpd.conf.default /etc/httpd/httpd.conf

    2. im betreffenden programm....
    brauchst du nicht direkt im osx aktivieren...
    ra.ma.
     
  3. macLitzi

    macLitzi New Member

    webmin gibt's unter www.webmin.com und ist ein webfrontend zur verwaltung aller möglichen Apache und sonstiger Einstellungen.

    Danke für die Antwort, aber die Deafult-Conf ist bei mit schon wieder drauf. Funzt trotzdem nicht.
     
  4. MacGhost

    MacGhost Active Member

    Hi,

    auf welchem Port lief denn Webmin ?
    Wenn Du Port 80 gewählt hast ist das klar, dann kann der Apache nicht mehr starten weil der auch auf Port 80 liegt.

    Joern
     
  5. macLitzi

    macLitzi New Member

    Port 10000, ist default in webmin und hab ich so auch gelassen.
     
  6. MacGhost

    MacGhost Active Member

    Hmmm, das ist komisch.
    Aber in OS X ist einiges anderes als in echten Unixen.
    Ich suche mich gerade nach der "apache.conf" irre.
    Weder find .... noch Sherlock wollen die Datei kennen.
    Wo wird denn diese dämliche Konfiguration hineingeschrieben ??!?!?!?!

    Joern

    PS: Jetzte habe ich sie !
     
  7. macLitzi

    macLitzi New Member

    die conf-datei liegt in /etc/httpd/httpd.conf
     
  8. MacGhost

    MacGhost Active Member

    # Port: The port to which the standalone server listens. For
    # ports < 1023, you will need httpd to be run as root initially.
    #
    Port 80

    Vielleicht hast Du mit Webmin ja die Datei verbogen

    Joern
     
  9. macLitzi

    macLitzi New Member

    nein, die Zeilen stehen exakt so drin, wie du es gepostet hast. welchen mod muss httpd.conf denn haben?
     
  10. macLitzi

    macLitzi New Member

    hab mittlerweile unter /etc/webmin ein shell-script uninstall.sh gefunden und ausgeführt. hat fehlerfrei gefunzt. webmin ist also weg. nur über syst-pref/websharing lässt sich der apache immernoch nicht starten.
     
  11. RaMa

    RaMa New Member

    den default mod...
    -rw-r--r--

    was sagt dir den apache wenn du ihn manuell starten willst???
     
  12. macLitzi

    macLitzi New Member

    wie starte ich apache manuell über das terminal?
     
  13. RaMa

    RaMa New Member

    apache start
    apache stop

    apachectl start
    apachectl stop

    :)

    ra.ma.
     
  14. macLitzi

    macLitzi New Member

    apachectl start sagt folgendes:

    malformed Mach-o file: /usr/sbin/httpd [71]
    httpd could not be started
     
  15. RaMa

    RaMa New Member

    ähja...

    paßt schon :)

    was sagt er wenn du /usr/sbin/apachetcl start machst??

    ra.ma.
     
  16. macLitzi

    macLitzi New Member

    gleiche Fehlermeldung. bin am verzweifeln. ein ll posten? das ist wahnsinning viel. kann ich ll in irgendeine Datei umleiten?
     
  17. MacGhost

    MacGhost Active Member

    Puhh,

    bin völlig ratlos, weiß RaMa denn nichts mehr, das ist doch quasi der Apache Experte.

    Joern
     
  18. MacGhost

    MacGhost Active Member

    Hi,

    ja geht ll > datei.txt

    gibt es denn die Datei httpd noch ?
    Oder hat webmin die weggebügelt ?

    Joern
     
  19. RaMa

    RaMa New Member

    ne weiß auch nixmehr...

    die fehlermeldung is interesant...
    die httpd is da, ansonsten würde das system, file not found hergeben...
    und die fehlermeldung stammt auf jeden fall nicht aus dem apachectl script...
    also is das mal ok...
    die httpd.conf is sollte starten...weil default...

    daraus folgere ich die httpd is beschädigt...

    mehr kann ich auch net sagen :-(

    ra.ma.

     
  20. RaMa

    RaMa New Member

    pps. von EXPERTE bin ich soweit entfernt, wie nur geht...
     

Diese Seite empfehlen