Netzwerkproblem "Collisions-"Fehler

Dieses Thema im Forum "Hardware" wurde erstellt von Volker72, 10. November 2004.

  1. Volker72

    Volker72 New Member

    Hallo zusammen,

    habe plötzlich in meinem Ethernet-Netzwerk (mehrere Macs mit OS X 10.3) Kollisionsfehler, d.h. im D-Link-Hub flackert beim Kopieren übers Netz die Anzeige "Col 100M" und das Kopieren übers Netz dauert auch tatsächlich länger.

    Meine Lösungsversuche:
    1. Habe schon den Hub ausgewechselt. Problem bleibt.
    2. Habe alle Kabel ausgetauscht. Problem bleibt.
    3. Habe nur zwei Macs über einen Hub verbunden. Problem bleibt.

    Also woran kann es denn dann noch liegen? Habe kein neues System upgedatet, habe nichts neues installiert, was das Netzwerk beeinflussen könnte...

    Ich bin total sprach- und ratlos. Wer kennt sich auch? Ich dachte, es würde sich um ein Hardwareproblem handeln, aber nachdem ich diese ausgetauscht habe (natürlich nicht die Netzwerkanschlüsse am Mac)...

    Ach ja, Ping sagt:
    PING 192.168.0.2 (192.168.0.2): 56 data bytes
    64 bytes from 192.168.0.2: icmp_seq=0 ttl=64 time=0.429 ms
    64 bytes from 192.168.0.2: icmp_seq=1 ttl=64 time=0.319 ms
    64 bytes from 192.168.0.2: icmp_seq=2 ttl=64 time=0.296 ms
    64 bytes from 192.168.0.2: icmp_seq=3 ttl=64 time=0.316 ms
    64 bytes from 192.168.0.2: icmp_seq=4 ttl=64 time=0.325 ms
    64 bytes from 192.168.0.2: icmp_seq=5 ttl=64 time=0.347 ms
    64 bytes from 192.168.0.2: icmp_seq=6 ttl=64 time=0.317 ms
    64 bytes from 192.168.0.2: icmp_seq=7 ttl=64 time=0.311 ms
    64 bytes from 192.168.0.2: icmp_seq=8 ttl=64 time=0.318 ms
    64 bytes from 192.168.0.2: icmp_seq=9 ttl=64 time=0.323 ms
    -- 192.168.0.2 ping statistics ---
    10 packets transmitted, 10 packets received, 0% packet loss
    round-trip min/avg/max = 0.296/0.33/0.429 ms

    Bitte helft mir!
    Liebe Grüße
    Volker
     
  2. WoSoft

    WoSoft Debugger

    verbinde mal 2 andere Macs, um auszuschließen, dass ein Ethernet-Chip defekt ist.
     
  3. Ghostuser

    Ghostuser Active Member

    Hallo Volker72

    Wenn du einen "Hub" hast, ist das bei grösserem Verkehrsaufkommen normal, dass es Collisions gibt.

    Ein Hub ist nichts anderes als das gute alte Koaxialkabel, auf das alle Rechner versuchen ihre Ethernet-Packete abzusetzen. Wenn nun zwei Rechner nach abwarten der "Verkehrsfreiheit" gleichzeitig beginnen zu senden, so kommt es unweigerlich zu einer Kollision. Danach warten beide Rechner eine zufällig errechnete Zeit (also für beide Rechner je eine andere) ab, bevor sie von neuem versuchen ihr Ethernet-Packet abzusenden.

    Die einzig sinnvolle Abhilfe ist die Anschaffung eines "Switch".

    Er arbeitet anders. Mit je nur einem Rechner an jedem Port kann der "full duplex mode" verwendet werden. Dieser wird bei den kleinen Switch normalerweise automatisch gewählt, wenn ihn der Rechner auch unterstützt, was ein Mac normalerweise tut. Die Packete werden dann im "eingeschwungenen Zustand" direkt von einem Port zum anderen durchgeschaltet bzw. via Zwischenspeicher an das Ausgangsport weitergeleitet. Damit sind Collisions ausgeschlossen.

    Gruss GU
     
  4. WoSoft

    WoSoft Debugger

    prinzipiell würde ich auch zu einem Switch raten, zumal die heutzutage recht preiswert sind.
    Allerdings solte es bei nur 2 Mac keine Kollisionen geben.
    Könnte aber auch sein, dass AppleTalk dazwischen funkt, das aber nur alle paar Sekunden. Ziemlich löstig hingegen wäre eine Windose, wenn auf der NetBUI aktiviert ist.
     

Diese Seite empfehlen