netzwerkproblem mit 2macs

Dieses Thema im Forum "Software" wurde erstellt von storch, 18. August 2007.

  1. storch

    storch New Member

    hallo alle zusammen!

    ich habe vor zwei tagen nach acht jahren windows mal wieder zwei macs gekauft: einen mini und ein macbook.
    nun gibt es ein netzwerkproblem für das ich weder in diesem forum noch sonstwo hilfe finde: ich kann jeweils nur mit einem rechner ins internet. früher hingen drei windowsrechner an dem netz, zwei über kabel, einer wlan.

    die macs bekommen immer beide dieselbe IP-adresse zugewiesen. wenn ich die IP manuell einstelle komme ich auch nicht ins netz, obwohl er unter den netzwerkverbindungen eine internetverbindung anzeigt. der mini geht über kabel ins LAN, das macbook über airport. wenn einer rechner nicht am netz ist funktioniert der andere.

    hat jemand einen tipp?

    storch
     
  2. dimoe

    dimoe New Member

    Wie gehst Du ins Internet, über einen Router können doch soviele Rechner ins Internet wie man will (bei mir sind es drei)?

    Mit Airport sollten 2 Macs doch kein Problem haben.
    Für ein gemischtes Netz (Apple und Windows) geht es zumindest so:

    Ich habe einen MacMini mit Airport und ein Notebook (Windows) mit WLAN-Karte.
    Am MacMini (am Router) ist in Airport eine Computer zu Computer Verbindung (WES) eingerichtet,
    die DHCP Verbindung ist manuell auf 10.0.2.1 eingestellt (siehe Anhang "Netzwerk Einstellung"), unter Sharing ist unter Internet Internetsharing für Airport aktiviert.
    (Bei mir sind folgende Dienste freigegeben: Personal File Sharing, Windows Sharing, Personal Web Sharing und Printer Sharing)
    Am Notebook ist die TCP Einstellung auf 10.0.2.2 eingestellt und die DNS auf 10.0.2.1 da der MacMini als Server/Router dient.

    Ins Internet und an die Ordner (mit Sharepoint eingerichtet) auf den Rechnern komme ich so.
    Was auf dem Notebook nicht geht, ist Mail abzurufen (wenn dafür jemand eine Lösung hat!?)

    Dirk
     

    Anhänge:

  3. MacS

    MacS Active Member

    Das darf ja schon nicht sein. Jeder Client MUSS eine eindeutige IP haben! Wie lautet die IP? Ich gehe davon aus, alle deine Rechner hängen an einem Router, denn sonst wäre das eh nicht möglich. Dann aber muss die IP aus eine Pool von lokalen IPs stammen, meist ist es 192.168.x.y (@dimoe: nur Apples Airport BaseStations nutzen den Adressraum 10.x.y.z und ich gehe nicht davon aus, das storch eine hat!). Ist diese nicht aus dem Adressraum und kommt aus dem Pool der öffentlichen IPs der Provider, dann ist am Mac bei TCP/IP das Häkchen PPPoE gesetzt. Das aber wird nur für die direkte Verbindung Mac-Provider genutzt, nämlich dann, wenn du nur mit einem Modem ins Netz gehst. Hier aber baut der Router die Verbindung zum ISP auf! Und da du vom Provider immer nur eine IP bekommst, können die anderen Rechner auch nicht mehr auf das Netz zugreifen!

    Eine 2. Möglichkeit: die IP beginnt mit 168.xxxx. Das ist eine Default-IP, die der Mac einstellt, wenn er vom DHCP-Server keine IP bekommen hat. Grund: DHCP-Server im Router hängt, oder darf keine weitere IP vergeben (-> Routereinstellungen kontrollieren! Vorallem WLAN-Einstellungen wegen MAC-Filter usw.).

    Und nochwas: welche IPs haben dein PCs? Diese müssen sich doch im gleichen Adressraum befinden. D.h. die ersten 3 Ziffernblöcke müssen gleich sein, auch am Mac, also z.B. 192.168.1.x. Nur x darf und muss sich unterscheiden!
     
  4. storch

    storch New Member

    die IP ist: 192.168.1.204
    router: 192.168.1.10

    das häkchen bei pppoe ist nicht gesetzt.
    den router schau ich mir mal an, weiss nur gerade nicht wie das geht... der lief die letzten jahre einwandfrei. wenn ich testweise einen windowsrechner dranhänge bekommt er eine andere IP. bei den macs ist immer noch dasselbe prob. wenn der eine ausgeschaltet ist kann ich den anderen online bringen.
    ich muss auch immer einen neustart machen, sonst kriegt er keine IP.

    in den netzwerkeinstellungen steht dann immer, dass AirPort (oder Ethernet) sich eine eigene IP selbst vergeben hat und deshalb nicht ins netz kommt.
    ist halt blöd, dass ich fast keine ahnung mehr von macs habe.
     
  5. John L.

    John L. Active Member

    Ich denk mal, wir haben hier mehrere Probleme:

    - DHCP
    Geh mal davon aus, Dein Router vergibt über DHCP die IPs. Wenn er 2 Geräten die gleiche IP gibt, hast Du ein Problem. Dann macht es auch "Sinn" dass jeweils nur der eine Rechner ins Internet kommt.
    Ich vermute mal, dass Dein Airport Mac die IP Adresse von nem benachbarten WLAN bekommt...anders könnte ich mir das jetzt nicht erklären...oder dein DHCP hat nen Schuss..!

    - Router
    Find mal raus, welche IP Adresse Dein Router hat

    Versuch mal folgende Vorgehensweise:
    Steck mal Deinen Router aus und lass ihn 5 Minuten ohne Strom. Dann wieder einstecken, hochfahren lassen (kann schon 3-5 Minuten dauern), dann alle Rechner neu starten und testen.

    Wenn das nicht läuft, konfigurier mal Deine Macs und PCs folgendermaßen um:

    Angenommen, die Router IP ist 192.168.1.1.
    Ich würd hier mal einfach probeweise den DHCP Server auf dem Router abschalten und die Macs mit fixen IPs konfigurieren.

    1. Rechner (ob Kabel oder Airport ist egal): 192.168.1.11
    2. Rechner (ob Kabel oder Airport ist egal): 192.168.1.12
    3. Rechner (ob Kabel oder Airport ist egal): 192.168.1.13
    ...

    Bei allen Rechnern zusätzlich folgende Einstellungen:
    Subnetzmaske: 255.255.255.0
    Router / Standard Gateway: 192.168.1.1 (muss die IP von Deinem Router sein)
    DNS / Nameserver: 145.253.2.75 (DNS von Arcor, der funzt auf jeden Fall)

    Dann sollte Dein Netz auf jeden Fall laufen und alle Rechner sollten ins Internet kommen...

    Viel Glück..!
    Wenns nicht holft, bräuchte ich mal ne genaue Beschreibung, welche Rechner und Router Du im Netz hast...

    John L.

    @ MacS: Die sog. APIPA Adressen (Adressen, die sich der Rechner (PC, mac, Linux ist dabei egal) selbst zuteilt wenn er keine Antwort von nem DHCP kriegt) liegen im Bereich von 169.254.x.x mit der Subnetzmaske 255.255.0.0, dh. die beiden x können Werte von 0 bis 255 bzw. 254 annehmen. Diese IPs sind allerdings nicht routbar, dh. für ein vernünftiges Netzwerk nicht verwendbar....
     
  6. storch

    storch New Member

    vielen dank. klappt aber immer noch nicht.

    wenn ich die angaben manuell eingebe sagt er mir unter "systemeinstellungen netzwerk", dass eine internetverbindung besteht. aber ich kann keine mails abrufen oder surfen. die programme sagen dann zwar nicht, dass keine verbindung zum netz besteht, aber sie finden keinen server.

    ich verwende:
    1 macbook in einer standard-gravis-konfiguration (allerdings mit erweiterung auf 2GB ram)
    1 mac mini, ebenfalls standard
    1 levelone-router: FBR-1405TX
    1 levelone WAP 0003-wlan adapter
    1 levelone homeplug

    ich könnte für das wlan auch einen airport express verwenden. das hatte allerdings keine unterschiede ergeben.

    leider habe ich keine ahnung, wie man so einen router konfiguriert. gibt es dafür software? in der betriebsanleitung steht, dass nur ein DHCP-server betrieben werden darf. kann es daran liegen?
     
  7. John L.

    John L. Active Member

    Sorry, ich kenn weder die Router Marke noch hab ich so ein Teil schon mal eingerichtet. Ich verwend im Home Bereich ausschließlich LinkSYS (weils ne Tochterfirma von Cisco ist und Cisco definitiv die beste Netzwerk Hardware herstellt).
    Mir ist bis dato noch kein Router untergekommen, auf dem ein DHCP Server betrieben werden muss. Ich denk mal, der Hinweis ist eher dazu da, sicher zu stellen, dass in Deinem LAN nur 1(!) DHCP Server läuft. Wenn da 2 rumstehen, wirst Du ganz sicher massive Natzwerkprobs bekommen.

    Geh mal mit Deinem Browser auf die IP Adresse des Routers, ich denke mal, Du solltest dann ne grafische Oberfläche sehen. Dann suchst Du nach den DHCP Einstellungen und schaltest den DHCP Server aus.

    ich würd auch soweit wie möglich mit Apple Hardware arbeiten. Lass mal den anderen WLAN Adapter einfach in der Schachtel...und konfigurier die Airport Karte...

    Bin mir Ferndiagnose langsam aber sicher am Ende. Ich würd mir nen Bekannten holen, der sowas schon mal eingerichtet hat. Ich komm langsam zu dem Punkt, an dem ich an Deinen Rechnern sitzen müßte...
     
  8. MacS

    MacS Active Member

    Ich vermute mal den Fehler auf der Seite des Routers. Möglicherweise ist die DHCP-Bereich eingegrenzt auf eine max. Anzahl von Clients. Wenn die PCs und ein Mac im Netz hängt, ist die max. Anzahl erreicht. Daher würde ich mal die Router-Konfiguration prüfen. Habe meinen Router so konfiguriert, dass nicht mehr als 5 DHCP-Clients eine IP bekommen.
     
  9. storch

    storch New Member

    es funktioniert. keine ahnung wieso. ich habe nichts gemacht....

    danke an alle!!

    sind computer nicht seltsam?
     

Diese Seite empfehlen