NFS und X

Dieses Thema im Forum "Hardware" wurde erstellt von apoc7, 22. April 2003.

  1. apoc7

    apoc7 New Member

    Hing gestern mit einem Powerbook G4/550 an einem Linux-Server, der nur NFS unterstützte (kein FTP oder SMB).
    Ich ahbe zwar den NFSManager bei Versiontracker gefunden, die Zugriffe klappten auch, aber einzig allein die Geschwindigkeit war enorm gering.

    Tx max 2,2 MB/s und Rx 500 kb/s - weit weg von den 22 MB/s die möglich sein sollten... (theoretisch müsste ja sogar bei einer 100 MB/s Leitung noch mehr drinne sein).

    Kann man nun da noch was parametrieren, oder hat Apple NFS einfach ungenügend in X implementiert?

    Der Linux-Freund war auf jeden Fall entäuscht...
     
  2. MacGhost

    MacGhost Active Member

    Moin,

    kein Problem nutze hier permanent einen Linuxserver und das klappt recht fix.
    Zumindest dafür das es ein 10MBit Karte in einem P1 200 ist.

    Joern
     
  3. Multiuser

    Multiuser New Member

    Ich benötige ab und an mal eine Verbindung zu ner SUN Sparc. Diese benutzt auch NFS. Habe aber dafür kein Tool für den G4 iMac benötigt. In der Sun steckt eine 10 Mbit Netzwerkkarte, die aber nativ ist (egal was das heißen soll). Jedenfalls hat mir ein Techniker vom lokalen Applehändler mir die Sun auf die Netzwerkverbindung eingestellt mit Serverpartition und Mountpoint. Der Mac brauchte gar nix. Wenn ich jetzt Daten hin- oder herschiebe, geht das für 10Mbit sauschnell. Man kanns kaum glauben. Noch schneller wärs natürlich, wenn in der SUN eine 100Mbit Karte drin wäre. Insofern kann Apple das NFS nur sehr gut in X implementiert haben!
     
  4. hofmeyer

    hofmeyer New Member

    Wir haben hier ein paar Macs stehen, die die kompletten Benutzerordner per nfs vom Fileserver ziehen. Geht ratzfatz.

    Friedhelm
     
  5. lemur

    lemur New Member

    ich nutze von einem iMac 1GHz einen linux-fileserver (athlon 1,4 GHz) über 100 Mbit LAN:

    rx: 45 Mbit, systemlast linux: 5%, systemlast mac: 90%
    tx: 7 Mbit, systemlast linux: 5%, systemlast mac: 20%

    sonst ist nix los im netzwerk. die systemlast beim mac ist geringer bei ausgeblendetem fortschrittsbalken in der copybox, auch der datendurchsatz in rx wird dadurch etwas besser. ich wüsste gerne wo hier der flaschenhals ist. in rx ist der mac offensichtlich ausgelastet, in tx sollte aber mehr drin sein.

    ich habs auch mal im terminal versucht:
    rx: 55 Mbit
    tx: 7,5 Mbit
    macht also keinen grossen unterschied

    einen nfs-manager brauchst du übrigens nicht: http://forum.macwelt.de/cgi-bin/mac_forum/topic_show.pl?id=59303
     
  6. apoc7

    apoc7 New Member

    Leute, dass es mit 10 Mbit/s geht glaub ich ja, aber bei 100 sind meine Daten wohl etwas lahm. Wird wohl an den 550 MHz meines G4 liegen... nunja, hauptsache es geht überhaupt. Nur das Senden sollte schneller sein...
     
  7. apoc7

    apoc7 New Member

    ahja, und da ich 50% MHz zu Deinem habe, habe ich auch nur die hälfte Speed, also scheint es hauptsächlich von der Rechenpower abhängen.
    Also doch etwas dürftig implementiert? (zumindest das senden, da ist ja FTP noch schneller)
     
  8. lemur

    lemur New Member

    kann ich bestätigen. ich hatte mal ein ibook 500, das war deutlich langsamer.

    dürftig implementiert? der verdacht liegt nahe. wenn ich mir die belastung der linuxmaschine ansehe: die bemerkt denn NFS-copy kaum, während der mac schwitzt.

    ps: appletalk ist noch langsamer
     
  9. Achmed

    Achmed New Member

    Das hat nix mit mhz zu tun. wenn dann eher mit der plattengeschwindigkeit. für einen fileserver würde auch ein 486 reichen.
    aber egal.

    Ich kann nur als kleinen Tipp geben:
    Trage den Apple Rechner in die /etc/hosts des Linuxrechners ein.
    z.b
    /etc/hosts
    127.0.0.1 localhost
    192.168.0.20 apple g4

    Ich hatte ein ähnliches Phänomen:
    Ich hatte auf einem alten PC Suselinux drauf. Da konnte ich ruckzuck daten rüberschieben.
    Weil Suse nicht mein fall ist kam redhat drauf. Hier war die Verbindung (smb) wirklich saulahm und das auf der gleichen Hardware.
    Nachdem ich den Rechner in die /etc/hosts eingetragen war, war das problem gelöst.

    Also testen und bescheid sagen.
     
  10. MacELCH

    MacELCH New Member

    Vollduplex Halbduplex ?

    Koennte auch noch ein Problem sein, wenn die nicht identisch eingestellt sind.

    Gruss

    MacELCH
     

Diese Seite empfehlen