Ordner nicht löschbar…

Dieses Thema im Forum "Software" wurde erstellt von roggi, 29. August 2004.

  1. roggi

    roggi New Member

    Moin…

    ich habe einen Ordner im Papierkorb mit dem Namen del025e.00d
    In ihm befindet sich ein weiterer Ordner mit dem Namen
    man3
    Dieser enthält zumindest keine weiteren sichtbaren Unterordner oder Dateien.
    Zusammen kommen aber "immerhin" 12kb. Wobei die Dateigröße des ersten, übergeordneten Ordners nicht ermittelt werden kann….
    Ich kann das Packet nicht löschen; nach Neustart befinden sie sich immernoch im Papierkorb.

    Es sind Reste eines Packetes, die ich via OmniDisk Sweeper von der Festplatte in den Papierkorb geschmissen habe, weil sich da ständig die Kopie einer externen, längst nichtmehr angeschlossenen Festplatte aufbaut hatte. Diese konnte ich nur im DiskSweeper erkennen.
    (Dämlicherweise baut sich dieses ungewünschte "Backup" sofort wieder auf, wenn ich die externe Platte anschließe. Dannach mus ich wieder mit dem DiskSweeper ran…)
    Mysteriös!
     
  2. Macziege

    Macziege New Member

    Hast du beim Löschen schon mal die alt-Taste gedrückt?
     
  3. roggi

    roggi New Member

    Ja, hab ich

    Ich habe auch schon versucht im Classic-Modus zu starten. In der Hoffnung den Papierkorb so löschen zu können.
    Hilft leider nix…
     
  4. Macziege

    Macziege New Member

    Dann versuche das einmal, aber mit der nötigen Vorsicht:

    ich denke, bei deinen "Leichen" ist das system immutable flag gesetzt. Diese Dateien kann man nicht so einfach löschen.

    Öffne ein Terminal und gebe folgenden Befehl ein ls -loa und die entsprechende Datei aus dem Papierkorb in das Terminal per Drag & Drop reinziehen, enter. Jetzt müsstest du ein solchen output sehen:

    -rw-r--r-- 1 user staff schg 48282 Nov 29 2002 <Deine Dateileiche>

    Wenn Du hier "schg" siehst, dann ist für diese Datei das system immutable flag gesetzt.

    Jetzt musst Du ganz stark sein!

    - Schreib dir den genauen Path zu den entsprechenden Dateien auf (evtl. ausdrucken)

    - Boote Dein System in den Single User Mode ( Apfel S beim starten drücken)
    Achtung: Im Single User Mode hat man nur die Amerikanische Tastaturbelegung!

    - Nun folgende Befehle eingeben:
    fsck
    mount -uw /
    autodiskmount
    chflags -R noschg <Path zu Deiner Dateileiche>
    rm -R <Path zu Deiner Dateileiche>

    Mit dem Befehl chflags -R noschg <Datei> löschst Du das system immutable flag, das geht leider nur im Single User Mode (man chflags). Wenn Du das gemacht hast, ist Dein Papierkorb wieder Jungfräulich.

    Und poste mal, ob es geklappt hat.
     
  5. roggi

    roggi New Member

    Leider nicht…

    wenn ich das Terminalfenster öffne, den Befehl ls -loa eingebe und dann den "Leichenordner" hineinziehe und entere, dann erscheint:
    ls: illegal option -- /
    usage: ls [-ABCFGHLPRSTWZabcdfghiklnoqrstuvx1] [file ...]

    Wie gesagt, im Papierkorb sehe ich nur Ordner, in denen zunächst keine Dateien zu sehen sind.
    Oder spielt das gar keine Rolle?
     
  6. roggi

    roggi New Member

    Habe gerade per DiskSweeper bemerkt, daß im man3-Ordner noch eine weitere Datei oder Ordner liegt. Er/sie hat den Namen: ctime.3



    ?¿?
     
  7. roggi

    roggi New Member

    Geschaft, der Ordner ist gelöscht.
    Wie?
    Ich habe mit Norton Utilities, Wipe Info im Classic System den Papierkorb gefunden und gelehrt.
    Bin mal gespannt, was jetzt alles nicht mehr so funktioniert…
     
  8. Macziege

    Macziege New Member

    Moin,
    bemühe mal die 'Suche' nach Norten, du wirst feststellen, dass viele negative Erfahrungen gemacht wurden. Also Vorsicht, mit Norten in Verbindung mit OS X.

    Prüfe am besten nochmal mit dem Festplattendienstprogramm.

    Gruß
    Klaus
     
  9. frankwatch

    frankwatch Gast

    @ roggi

    beim nächsten mal gibst du ins terminal ein:

    sudo rm -r denkramhierherziehen, leerschläge beachten !

    return

    paßwort

    gelöscht !

    ausloggen mit "exit", apfel-k, dann apfel-q, dann bist du wieder user !
    __________________

    sudo = do something as superuser (du hast also root-rechte)
    rm = remove
    -r = es wird auf der obersten verzeichnisebene gelöscht
    __________________
    dieses geschreibe von macziege bzgl. löschen vergiß ganz schnell !
    den norten möchtest du bitte in deinem interesse KOMPLETT von der hd löschen, das x braucht den doktor und den antivirus nicht, konfiguriere deine firewall, das reicht, da hat macziege recht ;-)
     

Diese Seite empfehlen