OS 9 des G4 auch auf älteren Macs?

Dieses Thema im Forum "Software" wurde erstellt von heinzelmann, 30. Januar 2001.

  1. heinzelmann

    heinzelmann Member

    Hallo,

    ich habe einen G4/350, auf dem ich von der Original-CD OS 9.0.4 installiert habe. Nun wollte ich dieses System auch auf meinen alten PowerMac 6500/250 (ca. von 1998) aufspielen. Das geht aber nicht, sonder ich erhalte die Meldung: "dieses System ist für den vorliegenden Rechner nicht geeignet" (oder so ähnlich).

    Andererseits läuft aber der 6500/250 unter OS 9.0.4, wenn ich von der System-CD boote. Es steht also, von der Hardwareseite aus gesehen, dem OS 9 nichts entgegen. Weiß jemand, ob es vielleicht zwei verschiedene Systeme 9 gibt, eines für den G4 und eines für den Rest der Mac-Welt?
     
  2. Macfan

    Macfan New Member

  3. oezet

    oezet New Member

    hallo,

    rechner normal starten und g4-system-cd auf zweite partiton installieren. später rechner über kontrollfelder->startvolume os9 auswählen.

    müsste klappen
     
  4. heinzelmann

    heinzelmann Member

    Hallo Thorsten,

    danke für Deinen Hinweis, werde es so versuchen,

    Heinzelmann.
     
  5. heinzelmann

    heinzelmann Member

    Hallo oezet,

    zu Deinem Tipp meine eigene Beobachtung:
    habe den Systemordner der G4-System-CD auf das Iomega-Laufwerk, das am 6500/250 hängt, kopiert und dieses als Startvolume gewählt. Beim Starten kommt die Meldung: "dieses System kann nur von seiner Original-CD benutzt werden, nicht als Kopie".

    Wenn ich dagegen das System 8.5 meines 6500 auf das Iomega-Laufwerk kopiere, dann kann ich von dort booten. Daher habe ich Zeifel an Deinem Tipp. Hast Du das denn selbst schon so gemacht?

    Heinzelmann.
     
  6. MACrama

    MACrama New Member

    das geht so einfach..

    aus dem schnellkurs, unsaubere istallation eines OS9.04 auf einem nicht G4..:

    man starte mit der os cd
    man mounte das systemimage welches auf der os cd ist...
    man kopiere den inhalt des images auf die platte, den alten sysordner einfach überschreiben
    man wähle im kf startvolume die platte
    man neustartet ohne cd
    man hat 9.0 auf jedem beliebigen PPC mac...

    ende des schnellkurses

    das mit dem auf ein extriges volume zu kopieren und dann starten bringt null, da kann ich ja gleich mit der cd hochfahren??????

    ra.ma.
     
  7. oezet

    oezet New Member

    mit zip ist es kein problem:

    system 8.5 auf zip und von dort starten, dann G4 cd einlegen und auf die interne festplatte installieren. du kannst zwar nicht von der cd starten aber auf ein volume installieren, das nicht gemountet ist. das klappt 100%ig

    gruß jan
     
  8. heinzelmann

    heinzelmann Member

    Hallo Jan,

    dein Tipp funktioniert leider nicht. Ich habe mal von der G4-CD und mal mit dem alten System 8.5 vom Zip gestartet, und habe dann in beiden Fällen zwei Methoden versucht, das OS 9 auf den 6500 zu bekommen:

    1. System 9 von G4-CD installieren.

    Das war Dein Tipp. Installieren heisst ja wohl, das Installationsprogramm laufen zu lassen. Das geht aber nicht, denn das Installationsprogramm, das ich also mal unter 8.5, mal unter 9 starte, bringt in beiden Fällen die Meldung: "Dieses Programm kann auf Ihrem Computer nicht benutzt werden."

    2. Systemordner von der G4-CD auf die Festplatte kopieren.

    Die G4-CD enthält auf dem obersten Level einen Systemordner im "Klartext". Den kopiere ich auf meine Festplatte, wo er mit lachendem Gesicht erscheint, d.h. startfähig. Davor mache ich den alten Systemordner des 8.5 unbrauchbar, indem ich den Finder herausnehme. Dadurch verliert er sein lachendes Gesicht. Jetzt
    müsste ich von der Festplatte mit OS 9 starten können. Wenn ich das tue, bekomme
    ich die Meldung: "Die Systemsoftware auf dem Startvolume funktioniert nur auf dem ursprünglichen Medium, aber nicht nach dem Kopieren auf andere Medien - Neustart." - Fazit: geht auch nicht.

    3. Methode von MACrama funktioniert! ("Schnellkurs, unsaubere Installation
    eines OS9.04 auf einem nichtG4", danke an MACrama für seinen Tipp!)

    So ging es schließlich:
    a) Image des Systemordners auf der G4-CD suchen, steht unter Power_Mac_G4_Install/Softewareinstallationen/Systemsoftware /Macintosh_Computer_Software/Macintosh_Computer_SW.img,
    b) Image mounten, egal unter welchem System,
    c) auf die Festplatte kopieren,
    d) von irgendwo anders als von der Festplatte starten,
    e) Systemordner 8.5 unbrauchbar machen,
    f) Systemordner 9 auf Root-Level der FP legen,
    g) von FP starten.

    Leider läuft das so installierte System 9 aber nur ohne Systemerweiterungen. Mit den Sys-Erweiterungen aus dem
    Image-System (sind nur wenige) erhalte ich nach kurzer Zeit die Meldung:
    "Finder braucht InterfaceLib-JindWindow". Hat jemand das schon mal erlebt? Wo soll denn diese Datei stehen? Woher will sie sich der Finder holen? Zu den unsichtbaren Dateien gehört sie jedenfalls nicht. Yahoo meldet über 400 Einträge zum Stichwort InterfaceLib und
    null zu JindWindow. Da fang mal einer an zu suchen!

    Kann es sein, dass es einen Konflikt zwischen verschiedenen Systemerweiterungen des OS 9 auf dem 6500 gibt? Unter ihnen sind ja viele, die mein
    6500 nie braucht, etwa alle ATI-Treiber (habe keinen Graphikbeschleuniger), alle FireWire- und USB-Erweiterungen, Nomad, Security u.s.w. Vielleicht muss man die alle herausnehmen.

    Hat jemand einen Vorschlag? Gruß von

    heinzelmann.
     
  9. heinzelmann

    heinzelmann Member

    Hallo MACrama,

    kannst du was zu meiner Frage sagen, warum der Mac nach der Installation des OS 9 mit deiner Methode einige Systemdateien nicht findet: InterfaceLib und AppleGuideGlueLib. Hast du einen Tipp?

    Heinzelmann
     
  10. MACrama

    MACrama New Member

    hallo

    dein problem ist jenes das du die falsche cd genommen hast, mit dem G4 werden 2 cds ausgeliefert 1.heißt software installtion
    2. software restore

    auf der software restore im verzeichniss KONFIGURATIONEN befindet sich eine cleaninstall-image eines kompletten os.. dieses nehmen und nicht das von der install cd...

    das komplette image von der system restore cd kopieren und dann im erweiterungen ein aus KF alles wie airport, ati treiber, FW support, usb support, rausnehmen...

    dann klappt es wunderbar..

    muß mich entschuldigen bin ein schlechter lehrer.. ;-)

    ra.ma.
     
  11. THE painkiller

    THE painkiller New Member

    also ich hab os 9.0.4 auf meinem alten 8500/120 installiert und läuft ganz gut!
    hab powerbook-cd benutzt und installations programm gecrackt damit es auch auf nicht-powerbooks lief...
    from the mists of madness--painkiller
     
  12. MACrama2

    MACrama2 New Member

    ich brauch dazu keine tricks..:)
     
  13. heinzelmann

    heinzelmann Member

    Hallo MACrama,

    ja, so ging's! OS 9.0.4 ist drauf, ATM und HP-Druckertreiber upgedated.

    Danke für den Tipp,

    he.
     

Diese Seite empfehlen