OS 9 jetzt Windows-kompatibel?

Dieses Thema im Forum "Software" wurde erstellt von Doc Martin, 10. September 2001.

  1. Doc Martin

    Doc Martin New Member

    Humpf,

    ich hatte hier neulich wg OS9.1-Problemen schon mal um Hilfe gerufen, aber leider haben die Ratschläge, die ich damals bekommen habe, nichts geholfen. Jetzt habe ich auf 9.2.1 upgedated habe und die Probleme sind immer noch da.
    Es geht um folgendes (dieselben Probleme auf iMac und Pismo, Wahrscheinlichkeit für einen HW-Defekt also fast gleich Null): Ich installiere auf eine frisch formatierte Platte 9.0.4, upgrade auf 9.1 auf 9.2.1. Starte auf dem jungfräulichen System, auf dem noch keine anderen Systemerweiterungen installiert wurden und auf dem noch kein anderes Programm gelaufen ist, den HelpViewer, HelpViewer läuft problemlos. HelpViewer beenden und ein anderes Programm starten, z.B. iCab oder den Installer von MRJ 2.2.4 (*keine* Installation von Java 224, *nur* den Installer starten und ohne Inst. wieder beenden!) oder sonst ein älteres Programm X. Programm X wieder beenden und HelpViewer erneut starten, HelpViewer bombt mit Fehler 10. Und das tut er auch nach einem Neustart, Desktopneuaufbau, PRAM zappen, mehr Speicher zuweisen, Diskreparatur (war sowieso i.O.), virtuellen Speicher ausschalten. Und alles auf einem taufrischen System! Die Probleme treten aber auch mit anderen Programmen auf, die, nachdem sie vorher gelaufen sind, plötzlich beharrlich mit Fehler 3 abbrechen oder mit 10 bomben. Das Einzige, was hilft, ist eine Neuinstallation oder das Rückspielen eines Backups.
    Offenbar zerstören ältere Programme irgendetwas im System, so daß andere Programme nicht mehr starten können? Daß alte Programme nicht mehr auf einem neuen OS laufen, lasse ich mir ja noch gefallen. Aber daß sie das ganze System zerschießen, habe ich bis jetzt nur von Windoof gekannt (vom Hörensagen :->

    Hat jemand eine Vorstellung davon, was da kaputt gehen könnte? Wie man es wieder repariert? (Wie gesagt: Norton ohne Ergebnis!) Oder muß ich jetzt ein paar hundert alte Programme in den Mülleimer ziehen?

    :-( Martin
     
  2. df

    df New Member

    Probiers doch mal mit Preferences löschen.

    Vielleicht hilft das (von Helpviewer oder das was für Fehler verantwortlich ist)

    Gruss

    df
     
  3. Tom

    Tom New Member

    versuch doch folgendes ! Gib allen Systemerweiterungen im "sauberen" System ein Etikett. Dann kannst Du sobald die Probleme auftauchen nachsehen ob eine Systemerweiterung "nachinstalliert" wurde. Vielleicht hilfts.

    Ansonsten gibt es auch noch Shareware Tools, die einen Systemzustand speichern und anzeigen ob und was geändert wurde (Installer Observer).

    Tom
     
  4. Singer

    Singer Active Member

  5. Doc Martin

    Doc Martin New Member

    nop, das Problem tritt erst nach der Systeminstallation auf. Danach läuft der HelpViewer. Erst, wenn ich danach ein "älteres" Programm starte, treten die Probleme mit dem HV auf. Neue Erweiterungen werden definitiv nicht installiert.
    Ulkigerweise lassen sich genau diese "älteren" Programme *nie wieder* starten (auf ewig Fehler 3), wenn ich versuche sie zu starten, *während* der HelpViewer gerade läuft :-/ Sieht also eher so aus, daß da 2 Programme versuchen, auf dasselbe zuzugreifen. (Gibt es eine email-Adresse bei Apple, bei der man Bugs melden kann?) Noch merkwürdiger ist, daß es alte Schätzchen gibt, die überhaupt keinen Schaden anrichten...

    Martin

    ps: Nach Löschen der Prefs (des HVs) stürzt der Rechner beim Neustart mit Adressfehlern und Trap-nicht-implementiert ab.
     
  6. Doc Martin

    Doc Martin New Member

    Ich will nicht sagen, daß es mich freut, daß andere ähnliche Probleme haben, aber es erleichtert irgendwie ;-)
     
  7. ned

    ned New Member

    Gibt es eigendlich schon eine Lösung?
    Ich habe gerade meinen G4 neu installiert und nun meldet sich Airport mit einem Fehler 3. Hier ist noch kein anderes Programm gelaufen. Zu wenig Speicher ist bei 1GB Speicher schon witzig, stecken wir halt nochman 512 MB rein, dann sollte es doch für Airport reichen, oder.
    Nach einer neuinstallation hat sich leider nichts getan - fehler 3. Recht nichtssagend diese Meldung, fast wie bei... sag ich jetzt doch nicht.
    Aber ich würde jetzt doch ganz gern wieder mit dem Mac ins Netz gehend. Vielleicht kommt doch noch eine Lösung - let´s hope.
    Gruß
    ned
     
  8. Doc Martin

    Doc Martin New Member

    Ich bin wieder auf 9.0.4 zurück und habe die neuesten Version von MRJ, QuickTime und FireWire per Hand nachinstalliert :-/
     
  9. ned

    ned New Member

    Na, die richtige Lösung ist das aber auch nicht - erinnert mich an meinen Win ME Ausflug...
    Leider ist 9.1 die älteste Version die ich habe. Sollte ich nach einer achter Version suchen, ein Bekannter meint ja damals war noch alles in Ordnung.
    Ned
     
  10. Doc Martin

    Doc Martin New Member

    9.2.1 hat leider auch keine Verbesserung gebracht :-(
    Der Knackpunkt ist wohl, daß bestimmte ältere Programme (z.B. auch Installer) irgendwas im System ändern. Ich setze meine Hoffnung auf OSX, weil da ein Classic-Programm nur eine *Kopie* des OS9 lädt, d.h. eine Änderung in irgendeiner Systemdatei hätte keine Auswirkung mehr??? Aber dafür wollte ich noch auf X.1 warten.
     
  11. MacELCH

    MacELCH New Member

    Ich nehme aber schon richtigerweise an, das ihr auch die aktuelle Firmware draufhabt oder ?

    Ansonsten sucht mal bei http://www.versiontracker.com mit dem Stichwort Firmware und schaut was gerade up-to-date für Eure Rechner ist.

    Gruß

    MacELCH

    P.S. für das Pismo ist das 4.18, im System Profiler findest Du unter der Boot Rom Version ein paar Zahlen, die Dir einen Hinweis auf Deine aktuelle Version geben z.B. xxxx4.18f5
     
  12. Doc Martin

    Doc Martin New Member

    Hmm, blöde Frage: Was versteht man genau unter Firmware? Beim Update von 9.2.1 ist auch ein neues ROM aufgespielt worden. Deshalb bin ich davon ausgegangen, daß da die neueste Firmware drauf ist...
     
  13. mackevin

    mackevin Active Member

    s) button must be fully
    depressed or the update will not install.

    DISCUSSION

    Firmware updates require that you press the Interrupt button, identified in Figure 1, while turning the
    computer on. Use a thin, blunt object such as a straightened paper clip or the tip of a pen.

    Note: The Interrupt button on older iMacs is recessed so you will need to use a paper clip.

    The Interrupt button is located on the front panel of the Power Macintosh G3 and Power Mac G4 computers,
    and on the right side of iMac computers. Refer to your Users Guide or Mac Help for the location of the
    Interrupt button on other computers.

    Figure 1. Programmer's or Interrupt button

    For specific firmware update installation instructions, please refer to the Read Me file that comes with the
    update.

    Quelle : Apple support

    Firmware updates gibt es bei Apple auf der support-Seite. Seit einiger Zeit braucht man hier eine Zugangsberechtigung. Die kann man sich aber ohne Probleme einrichten.

    Als die aktuellen firmwares herausgekommen sind, wurde immer wieder davon berichtet, daß RAM-Riegel plötzlich nicht mehr erkannt wurden. "Marken"-Riegel hatten das Problem nicht. Da Speicher im Augeblick aber sehr preiswert ist, würde ich das Risiko eingehen.

    Welches firmware Du gerade benutzt verrät Dir der Systemprofiler.

    Gruß
    mackevin
     
  14. Doc Martin

    Doc Martin New Member

    Danke für den Hinweis, die Firmware war wirklich steinalt :)
    Das eigentliche Problem löst es aber trotzdem nicht :-(
     

Diese Seite empfehlen