Os 9 Os X Os 10????

Dieses Thema im Forum "Hardware" wurde erstellt von leonie84, 13. Oktober 2003.

  1. leonie84

    leonie84 New Member

    hey ihr,
    bin als neue nun echt verwirrt. vielleicht könnt ihr ja licht ins dunkel bringen ;-)
    ich mach mich gerade über alles mögliche bez. mac schlau und ich stoße immer wieder auf die bezeichnung verschiedener betriebssyteme "dieses program geht nur mit OS 9 das andere mit OS X"... welches ist denn nun das älteste der OS? was wird wofür benutzt? und was ist eine classic oberfläche oder wie das heißt?
    bitte klärt mich auf!
    thanx
    leonie
     
  2. leonie84

    leonie84 New Member

  3. oli2000

    oli2000 Rest-Optimist

    Hat deine Mutter dich noch nicht aufgeklärt? Na, egal, dann will ich mal: OS 9 ist natürlich der Vorgänger von OS X (sprich Ten), und alles was unter OS 9 läuft, das läuft auch unter X – entweder nativ mit der Aqua-Oberfläche oder mit Hilfe der Classic-Umgebung. In letzterem Fall, also wenn man ein altes Programm hat, das es noch nicht für X gibt, startet innerhalb von Mac OS X noch ein Mac OS 9, ein System im System. Hört sich kompliziert an, funktioniert aber ganz gut.

    Generell gibt es drei verschiedene Sorten Programme:

    • Classic. Die alten, die nur unter OS 9 oder in OS X in der Classic-Umgebung (= OS 9) laufen.
    • Carbon-Programme, die unter beiden Systemen starten, beispielsweise Photoshop 7. Egal, ob du gerade unter 9 oder unter X bist, Photoshop läuft (unter 9 gibt es dafür eine kleine Zusatzdatei im System namens CarbonLib).
    • Cocoa-Programme, die nur unter X laufen und mit 9 nichts mehr anfangen können. Das sind die, die am optimalsten für X programmiert sind und sich komplett an die GUI-Richtlinien für X halten können.

    Achja, und
    • Alles, was hinten .EXE heißt, kann ignoriert werden.
     
  4. Borbarad

    Borbarad New Member

    Ist ganz einfach:

    OS 9.x = das uralte MacOS. Apple produziert dafür nicht mehr!

    OS X( X=10 und = UniX):
    Jaguar= 10.2.x, entspricht dem aktuellen Mac System
    Panther= 10.3.x Das, was am 24.10 erscheint :D

    Da du dir ein neues 15" Powerbook gekauft hast kommt für dich eh nur 10.3 in Frage. Unter Os9 kannst du nicht mehr starten.

    B
     
  5. oli2000

    oli2000 Rest-Optimist

    Genau, bei den neuen PowerBooks kann man nur noch mit OS X starten. Alles, was noch nicht unter OS X läuft, das läuft dann in der Classic-Umgebung, dem System im System. Die Classic-Umgebung wirst du aber selten oder nie brauchen.

    Mac OS X 10.3 wird klasse!
     
  6. leonie84

    leonie84 New Member

    mensch, ich dank euch!! ist ja doch leichter als ich dachte. ich galube besonders verwirrt hat mich das X (=ten), dachte das wär was ganz anderes ;-) und ein ´system im system---> da muss man auch erst mal hintersteigen...
    da seht ihr mal wie wenig ich weiß. ich bin so was wie ein einsiedler, da niemand in meiner familie oder näheren umgebung (freunde) einen mac hat. ihr seid also meine "insel". danke dafür!!
    leonie
     
  7. oli2000

    oli2000 Rest-Optimist

    Darfst gerne auf der Insel rumtrampeln, Tag und Nacht, über die Wiesen und durchs Gestrüpp.

    Das mit Classic muss man einmal gesehen haben, dann erklärt es sich von selbst. Eine technische Meisterleistung von den fleissigen Apples, und funktioniert prima.
     
  8. leonie84

    leonie84 New Member

    kanns kaum erwarten alles endlich selber zu erkunden. noch hab ich noch nicht einmal die auftragsbestätigung ;(
     
  9. tanzblume

    tanzblume New Member

    Bist wohl noch ein wenig in Deiner alten Windowswelt, wo es 3.1, 95, 98, NT, 2000 XP und bald auch noch Longhorn gibt.

    Willkommen beim großen GenuX!
     
  10. leonie84

    leonie84 New Member

    tja, hier machen zahlen und buchstaben noch sinn ;-)
     
  11. WoSoft

    WoSoft Debugger

    Und etwas vollständiger:

    1.0, 2.0, 2.1, 3,0, 3.1, 95, 98, ME, NT, 2000, XP Home, XP Pro und 2004/2005 auch noch Longhorn.

    cu
    Peter
     

Diese Seite empfehlen