OS X Server, Printservice f. OS9 Clients

Dieses Thema im Forum "Hardware" wurde erstellt von mmaass, 22. Juni 2002.

  1. mmaass

    mmaass New Member

    Hallo OS X Server Fachleute,

    der Umstieg von ASIP 6.3 auf OS X Server klappt bisher (nach massiven Anlaufschwierigkeiten durch defekten Speicher und eine inkompatible SCSI-Karte) ganz gut. FileServices laufen prima, Benutzer, Gruppen und Zugriffsrechte konnte ich so übernehmen. Problem machen mir bisher nur die Druckerwarteschlange. Vielleicht kann jemand helfen:

    Ich benutze OS X Server 10.1.4 (OS X 10.1.5) auf einem G4/533 MHz. Die Clients haben alle bis auf einen OS 9.2.2 laufen. Das muss auch vorerst so bleiben. Am Server ist neben TCP/IP und AppleTalk aktiviert und läuft.

    Die PrintServices am Server laufen, eine Druckerwarteschlange ist eingerichtet. Mit ASIP erschien beim Client in der Auswahl unter LaserWriter dann rechts jede Warteschlange als verfügbarer Drucker. Mit OS X Server ist das nicht mehr so. In der Auswahl taucht nur der "echte" Drucker auf. Keine Spur von den Warteschlangen.

    Im Handbuch steht, ich solle mit dem Drucker Dienstprogramm einen LPR bzw. TCP/IP Drucker anlegen (scheint das gleiche zu sein). Habe ich getan. Mir steht allerdings nur "TCP/IP Drucker" zur Verfügung. LPR heißt es dann wohl in der englischen Variante. Ich richte dann den Drucker ein mit der IP-Nr. des Servers und dem exakten Namen der Warteschlange sowie der richtigen Druckerbeschreibung. Ein Klick auf den Button "Überprüfen" zeigt mir die IP als Ort des Druckers an. Wenn ich aber dann drucke, bekomme ich eine Fehlermeldung -8763. Das ist an allen Clients so. Aus einem Mac OS X Client kann ich ebenfalls nicht drucken.

    Bekommt dieser Schreibtischdrucker die IP des "echten" Druckers, kann ich übrigens drucken. Aber ich möchte die Warteschlange haben. Muss ich eine andere IP als die des Servers (bzw. der Server Netzwerkkarte) verwenden oder irgendetwas noch dahinter schreiben?

    Weiß jemand Rat? Oder fehlen noch wichtige Informationen? Vielen Dank!

    m.maass
     
  2. Bathelt

    Bathelt New Member

    Du bist einen Schritt weiter als ich - bekomme nicht einmal eine Fehlermeldung (habe nur OSX Clients)

    Hast du am Client die TCP/IP des Server eingegeben? Wenn ja ist es - so glaube ich zumindest - nicht einmal nötig die Druckerwarteschlange anzugeben, da am Server ja eine Warteschlange eingerichtet ist.

    Viel glück - wenns dir doch noch gelingt schreib uns wie du es geschafft hast.

    ciao Jörg
     
  3. mmaass

    mmaass New Member

    Hallo Jörg,
    ich habe es hinbekommen und über den PrintSpooler eine Seite ausgedruckt. Wichtig ist, seltsamerweise, dass am Server in den Netzwerkeinstellungen KEINE Routeradresse und kein DNS angegeben ist. Dann kommst Du vom Server aus zwar nicht mehr ins Internet, aber das ist (zumindest bei mir) nicht unbedingt wichtig. Eventuelle Downloads kann ich besser an einem Client machen. Da ich eine Vigor 2200 verwende, wurde mir nämlich an verschiedenen Stellen immer die Domain "igor2200" angezeigt. Das hatte mich schon vorher gewundert.
    Wenn Du also diese Einstellungen am Server herausgenommen hast und mit dem "Druckersymbole Dienstprogramm" einen Schreibtischdrucker anlegst, gib ihm als IP-Nr. die IP-Adresse des Servers. Den Namen der Warteschlange trägst Du darunter ein. Dann den Drucker sichern (vorher noch die richtige PPD zuweisen) und es geht. Wenn nicht, schreib nochmal. Wie Du die Warteschlange am Server anlegst weißt Du ja sicher, oder. Wenn nicht, sag Bescheid.
    Ich werde nochmal probieren, ob es eventuell möglich ist, eine der beiden Netzwerkkarten in meinem Server ohne und die andere mit Router zu konfigurieren. Vielleicht geht es ja dann auch, wenn ich über die Karte ohne Routereinstellungen drucke. Über die andere kann ich dann ins Internet. Ich werde es hier zu diesem Thema schreiben.
    Viele Grüße
    Michael
     
  4. mmaass

    mmaass New Member

    Also das mit der unterschiedlichen Konfiguration für die beiden Ethernet-Karten in meinem Server klappt so auch nicht. Sobald nur eine von beiden einen Router zugewiesen bekommt, klappt das mit dem TCP/IP Drucker nicht mehr. Egal, welcher Karte ich ihn zuweise. Die Alternative heißt also vorerst: PrintServices oder Internet-Verbindung. Macht auch nichts.

    Vielleicht weiß ja jemand ein vernünftige Lösung dafür wie man das mit dem Router umgeht. Den Druckjob über den Router laufen zu lassen wird ja kaum sinnvoll sein. Das kann der glaube ich auch garnicht verpacken.

    Ich bin gespannt, ob jemand was dazu weiß ...

    Michael
     
  5. Bathelt

    Bathelt New Member

    Danke, das werde ich probieren.

    Habe ich das richtig verstanden, du verwendest deinen OSX Server auch als Rooter oder meinst du die Systemeinstellung / Netzwerk / TCP/IP / Router - Einstellung

    ciao Jörg
     

Diese Seite empfehlen