OS_X Netzwerkspeed ist MÜLL!!

Dieses Thema im Forum "Hardware" wurde erstellt von gmiladinov, 7. Dezember 2001.

  1. gmiladinov

    gmiladinov New Member

    So, nach all den tollen Erfahrungen, die hier mit dem neuen, leistungsstarken und perfomanten System OS X allen mitgeteilt wurden, will ich mal meine Erfahrungen mit dem System des neuen Jahrtausends mitteilen.
    Dabei will ich gar nicht auf die tolle Optik und Bedienbarkeit eingehen, nein, viel mehr auf die Funktionalitäten, die ein User erwartet, wenn er sich OS X über den Schnick-Schnack hinaus benutzen will. Sicher, es ist stabiler als das OS 9... aber die Netzwerkfähigkeit, das dieses Mehrbenutzer-System an den Tag legt, ist ein Witz!!!

    Folgendes Netzwerkverbindung soll hergestellt werden:

    Eine WG mit 2 Rechnern (1 PC Athlon 1400 blablabla..., 1 Cube 450 DVD, 448 MB-RAM) soll vernetzt werden. Die neue Funktion Mit Server verbinden... in OS 10.1 soll über das SMB-Protokoll mit dem WIN 2000 Professional Rechner funktionieren. Alles wunderbar........ es funktioniert sogar!
    Auf dem Cube wird eine Umgebung WG-LAN eingerichtet! In Windows werden die Zugriffsrechte vergeben. Die Verbindung funktioniert über das SMB-Protokoll und man bekommt im Finder das freigegebene Laufwerk angezeigt.
    Allerdings ist die Kopiergeschwindigkeit miserabel. Beide Rechner verfügen über 10/100 Mbit Netzwerkkarten. Die durchschnittliche Geschwindigkeit (Cross-Overkabel) beträgt bei einer Datei von 50 MB gerade mal 700 k/s. Das ist ein miserabler Wert! D. h. ein Div/X Film mit 670 MB braucht fast 10 min Kopierzeit!

    Dabei ist zu erwähnen, dass die Prozessorauslastung fast 100 % beträgt. Durch den Kopiervorgang werden so viele Ressourcen gebunden, dass z. B. iTunes des öfteren Unterbricht (Multitasking J)!
    Versucht man während der Netzwerkverbindung evtl. noch nebenher im Internet zu surfen, ist dies nicht möglich, da OS X nur eine Ip-Adresse verwalten kann oder will! Obwohl das System eine eigene von der Netzwerkkarte hat!!!
    Komisch, ältere UNIX-Derivate sind aber gerade für ihre Leistung im Netzwerkbetrieb bekannt.
    Microsoft hat mit XP oder Win 2000 sicherlich kein Userfreundliches System geschaffen. Wenn ich mir aber überlege, dass diese Funktionalitäten schon auf älteren und langsameren Rechnern kein Problem darstellen, frage ich mich, was hat Apple da eigentlich zusammenprogrammiert?
    O. k. vielleicht läuft es unter Mac zu Mac Verbindung besser und schneller, aber wenn ich schon eine Schnittstelle zur anderen Welt schaffe, sollte die nicht gerade im Schneckentempo sein.
    Dies sind für mich elementare Funktionen, die allein schon durch den UNIX-Kern machbar sind.
    Bald wird wohl nur noch die Optik das Kaufargument für mich sein, wenn es wieder heisst: MAC oder PC??? Vielleicht schafft es ja mal Sony, einen ansprechenden Rechner zu gestalten.
    Mir ist ehrlich gesagt, langsam die Lust/Argumentation vergangen. Vor allen Dingen bekommt man diese Erfahrungen aus Macwelt und Macup nicht mitgeteilt. Da steht auch nur Werbescheiss drin, der die Leute einheizt zu kaufen. Wie bei den Fahrradmagazinen, da ist auch alles schön bunt. Nur das wirklich wesentliche bleibt auf der Strecke!

    Wer weiss, wie dieser Fehler zu beheben ist, möge mir antworten. Vielleicht sitzt der Fehler ja auch vor dem Rechner!
    Schönes Wochenende
    G. M.
     
  2. volkerr

    volkerr New Member

    Hi,

    habe bei mir am Institut mehrere Macs und PCs. Netzwerk meist 100 MBit. Ist rasend schnell. Kann Deine Probleme nicht nachvollziehen. Habt Ihr u.U. schlechte Kabel oder Netzwerkkarten, welche Dienste laufen? Gerade die MS Netzdienste knallen oft das Netz zu...

    ist den sicher, dass sich beide rechner auf 100 MBit geeinigt haben? Das autosensing der meisten Netzwerkkarten kannste nämlich in die Tonne treten!

    Naja und zum Thema multitasking: präemptiv ja, d.h. aber auch bei single-prozessor maschinen, das sich die cpu geteilt werden muss. Zeige mir ein einziges System, das bei single-proz und hohen bus transfers nicht probleme macht.

    Volker
     
  3. Thomas Treyer

    Thomas Treyer New Member

    Ich glaube nicht, dass das Problem vor dem Bildschirrm sitzt. Die von dir beschriebene konfig sollte funktionieren. Vielleicht ist ja tatsächlich der Wurm im Kabel oder die Autonegotiation ist schiefgelaufen (Das müsste man irgenwo sehen können).

    Noch eine Anmerkung: Netzwerkkarten haben keine IP-Adresse im Auslieferungszustand (definitiv), das wäre auch völlig sinnlos, da IP-Adressen immer zum lokalen Netzwerk passen müssen. Wenn du gleichzeitig Filetransfer im lokalen Netzwerk und surfen willst, braucht du einen Router. Dies ist prinzipiell so in der IP-Welt und funktioniert wunderbar (z.B. bei mir zuhause).

    Thomas
     
  4. MacGhost

    MacGhost Active Member

    Moin,

    gan einfach eine zu finden.
    Z.B. meine SGI in der Arbeit, egal ob Indy oder Indigo2 oder O2.
    Da kannst Du Daten schieben und arbeiten.
    So sollte es am Mac auch sein da er keine Unterbrecher (IRQs) wie ein PC hat.
    Aber selbst auf dem WinPC klappt das teilweise besser als unter OS X .
    Habe hier selbst ein Win/Linux/MacOS Netz mit 100MBit laufen und muß sagen das die Macs am langsamsten sind.
    Besonders OS X, aber nicht so unbedingt beim kopieren sondern eher beim verbinden.
    Selbst ein smbmount unter Linux ist da schneller, egal ob mit der Shell oder via GUI wie LinNeighbourHood.
    Das kopieren geht so, wenn man allerdings überlegt das die Applekarte sauteuer ist und die PC Karten supergünstig waren, dann ist das eine Unverschämtheit.

    Joern
     
  5. gmiladinov

    gmiladinov New Member

    Hey....
    wenigstens ist das anderen auch aufgefallen! ich hab im Systemprofiler geschaut. Dort ha tmeine Karte eine Ip-Adresse von Werk aus. Unser Netzadmin hat mir gesagt, dass diese Nr. einmalig auf der Welt ist für jede Karte.

    Egal, auf jeden Fall ist es bei dem PC von meinem Kollega hier so, dass er sowohl surfen, als auch Dateien vom Netz ziehen kann! Ich meine da ist ne feste IP für die NW-Karte und eine die dir der Provider gibt! Also wo ist dann da der Wurm bei mir?

    Die Kabel sind O. k. ! Allerdings hab ich keine Einstellungsmögihckeit bei OS X gefunden, wo ich die 100 Mbit einstellen kann für die NW!

    Dir erkennen das doch automatisch! Mit dem Router komm auch DSL ins Haus. Dauert aber noch 3 Wochen! Dann bin ich mal gespannt!

    Mir kommt auch so vor, als ob das 56 k vom Mac nicht gerade der Bringer ist! Dass 33.3er Modem von dem Kollegen hier ist fast gleichschnell beim Seitenaufbau u. Laden!

    Trotzdem 700 k/s ist nicht der Bringer! Gibt es sonst noch Einstellungen, die ich berücksichtigen soll? Wenn ja, wo, wie und natürlich was!

    Saludos

    G. M.
     
  6. Thomas Treyer

    Thomas Treyer New Member

    Nochmal zur IP-Adresse: Die fest eingebrannte Nummer in der Netzwerkkarte ist die MAC-Adresse, die hat nichts mit der IP-Adresse zu tun.
    Nochmal zum Router: Es gibt HW-Router (so ein Kasten halt) und SW-Router. SW-Router sind unsichtbar im Betriebssystem versteckt und auch für OS X erhältlich. In Windows ist der SW-Router bereits eingebaut.

    56k Modem und 33k Geschwindigkeit: Nur bei optimaler Leitung können 56k erreicht werden, sehr oft schalten die 56k-Modems automatisch auf 33k zurück, weil zuviel Störungen auf der analogen Leitung sind. Dies ist nicht vom Betriebssystem abhängig.

    Thomas
     

Diese Seite empfehlen