Perlmodul GD installieren schlägt fehl

Dieses Thema im Forum "Software" wurde erstellt von MacTruth, 26. Dezember 2011.

  1. MacTruth

    MacTruth New Member

    Ich müh mich schon Tage und kriegst nicht hin:

    Da ich ein in Perl geschriebenes Programm via Terminal "perl"-befehl ausführen möchte, soll ich (laut Meldung des Programmes) noch zusätzlich das Perlmodul GD installieren.

    Ich mach das im Terminal brav so:
    sudo cpan (verlangt Paßwort)
    cpan[1]> install GD

    Da kommt aber nach einigen Installationsroutinen die Meldung:

    **UNRECOVERABLE ERROR**
    Could not find gdlib-config in the search path. Please install libgd 2.0.28 or higher.

    Gebe ich nun darum Folgendes ein:
    cpan[2]> install libgd
    kommt:
    Warning: Cannot install libgd, don't know what it is.

    Vielleicht gibt es Spezialisten unter euch, die da weiterhelfen können? Wäre super!
     
  2. John L.

    John L. Active Member

  3. MacTruth

    MacTruth New Member

    Danke für die Links. Die Datei von bitbucket hatte ich mir schon runtergeladen. Allerdings … wie damit umgehen, was ich da ins Terminal eingeben muß, das war/ist mir schleierhaft.

    Wenn Du so gut wärst, und mir das kurz skizzieren würdest, wie ich vorgehen muß wenn die gd-libgd nun im Download-ordner liegt und entpackt ist, wohin ich die nun kopieren soll, was ich im Terminal einzugeben habe (sorry, ist halt alles neu für mich) etc.

    Besten Dank im Vorraus!
     
  4. John L.

    John L. Active Member

    Ohne (d)ein BSD System ist das etwas schwer zu "skizzieren"...idR. installiert man mit "make", "make configure" und "make install", das kann aber von Fall zu Fall auch variieren.

    Ich hab hier noch was:
    http://generic-model-organism-syste...lers-for-Mac-OS-X-10-5-and-10-6-td452828.html

    Ansonsten wird Dir Google sicher ein Freund sein. Auch wenns ein wenig nervig erscheint...aber wenn Du Dich Stück für Stück durch das Problem durchkämpfst, hast Du erstens wirklich was gelernt und weißt es beim nächsten Mal auch wieder..! ;)

    John L.
     
  5. MacTruth

    MacTruth New Member

    Danke, der letzte Link hat geholfen. Nun konnte er ohne Probleme GD installieren.

    Nun aber will er das Modul Text/Wrapper

    Die Meldung lautet:
    Can't locate Text/Wrapper.pm in @INC (@INC contains: /Library/Perl/5.12/darwin-thread-multi-2level /Library/Perl/5.12 /Network/Library/Perl/5.12/darwin-thread-multi-2level /Network/Library/Perl/5.12 /Library/Perl/Updates/5.12.3/darwin-thread-multi-2level /Library/Perl/Updates/5.12.3 /System/Library/Perl/5.12/darwin-thread-multi-2level /System/Library/Perl/5.12 /System/Library/Perl/Extras/5.12/darwin-thread-multi-2level /System/Library/Perl/Extras/5.12 .)

    Mit der Installation gibt es wie davor bei GD Schwierigkeiten.

    Ich muß also in solchen Fällen das Modul am besten irgendwo im Internet suchen und runterladen, und dann von Hand installieren (sehe ich das richtig?).

    Und … was meinst Du mit (m)einem BSD System?
     
  6. MacTruth

    MacTruth New Member

    Ok, hat doch geklappt. Ich hatte den falschen Namen eingegeben.

    Man lernt dazu, wie Du gesagt hast!
     
  7. John L.

    John L. Active Member

    Erstmal Glückwunsch zur erfolgreichen Installation..! ;-)

    Mac OS X basiert auf FreeBSD, einem Unix Derivat. Und weil ich das nicht komplett auswendig kenne, wäre es für solches Troubleshooting recht hilfreich, wenn ich vor einem, am besten vor Deinem, FreeBSD (sprich der Shell von OS X) sitzen würde..! ;-)

    http://de.wikipedia.org/wiki/Mac_OS_X
    http://de.wikipedia.org/wiki/Darwin_%28Betriebssystem%29
    http://de.wikipedia.org/wiki/FreeBSD

    John L.
     

Diese Seite empfehlen