personal websharing OSX

Dieses Thema im Forum "Hardware" wurde erstellt von TommiS, 18. Januar 2002.

  1. TommiS

    TommiS New Member

    Hallo,
    wie kann ich auf einen Benutzerordner Sites über ein Netzwerk zugreifen. Ich habe websharing aktiviert und komme auf die Apache Begrüßungseite über die Rechner IP. Leider funktioniert der Benutzerordner Sites nur lokal, wenn ich RechnerIP/~Benutzername angebe. Von außerhalb bekomme ich eine Fehlermeldung im Browser. Muss man das Websharing für einzelne Benutzer zusätzlich freigeben?
    Tommi
     
  2. TommiS

    TommiS New Member

    Bitte, bitte, hat keiner eine Idee?
     
  3. hakru

    hakru New Member

    Läuft auf dem Webserver-Host 'ne Firewall - und wie lautet denn die Fehlermeldung, wenn der externe Rechner im Browser
    "http://serverIP/~username/"
    eingibt?

    hakru
     
  4. TommiS

    TommiS New Member

    Nein es läuft keine Firewall.
    Es steht ungefähr eine Minute Connecting to 127.0.0.1 und dann die Fehlermeldung A connection failure has ocurred. Bei Verbindung ohne ~Benutzername kommt die Es klappt ... Seite.
    Danke schon mal.
    Tommi
     
  5. hakru

    hakru New Member

    Da läuft noch was schief:
    Die IP "127.0.0.1" oder "localhost" stehen für das sogenannte loopback interface, über das ein Rechner MIT SICH SELBST via TCP/IP kommuniziert.

    Wenn also der "externe" Rechner eine URL mit "http://127.0.0.1/..." oder "http://localhost/..." eingibt, spricht er nur mit sich selbst - und da bei ihm kein Server läuft -> "connection failure"! Was hast du denn auf dem Webserver bei Netzwerk -> TCP/IP als IP-Adresse stehen? Bei lokalen/nichtöffentlichen Netzen kann das z.B. 192.168.0.x sein. Diese IP musst du im Browser mit "http://serveriP/~user/" des anderen Rechners eingeben - dann müsst's klappen, wenn alles andere stimmt.

    hakru
     
  6. TommiS

    TommiS New Member

    Vielleicht muss ich die httpd.conf ändern?
     
  7. hakru

    hakru New Member

    Langsam - erst Netzwerk richtig konfigurieren!!

    hakru
     
  8. TommiS

    TommiS New Member

    Also ich habe feste IP-Adessen in einem Airportnetzwerk und habe natürlich von einem externen Rechner die des Servers eingegeben. Der Webserver wird ja gefunden und die Indexseite wird angezeigt, ich habe nur das Problem mit den 16 veschiedenen Benutzern, die ich eingegeben habe. Die funktionieren nicht.
     
  9. TommiS

    TommiS New Member

    Netzwerk ist o.k. Habe es heute auch schon in einem Ethernet-Netzwerk probiert. Komme aber immer nur auf die Library/WebServer/Documents Seite.
     
  10. TommiS

    TommiS New Member

    Per ftp können sich alle Benutzer mit Ihrem home-Ordner verbinden.
     
  11. TommiS

    TommiS New Member

    Es ist beeindruckend, finde ich, wie viele Benutzer gleichzeitig auf das kleine Powerbook mit OSX per ftp zugreifen. Vielen Dank bis hierhin, ich schau morgen früh nochmal rein.
     
  12. hakru

    hakru New Member

    >>"Also ich habe feste IP-Adessen in einem Airportnetzwerk und habe natürlich von einem externen Rechner die des Servers eingegeben"
    Welche denn? "http://127.0.0.1/..."? Wenn das so ist, kann das nix werden!!

    >>"Der Webserver wird ja gefunden und die Indexseite wird angezeigt"
    Wenn das auch ein OSX-Rechner ist, mit Websharing=ON, dann narrt dich eine loopback-Spiegelung und du schaust den lokalen Apache an ...

    hakru
     
  13. TommiS

    TommiS New Member

    Ich habs, bin wieder mal selbst schuld. man darf den abschließenden / nicht vergessen: RechnerIP/~Benutzername/.
     

Diese Seite empfehlen