PHP lief gestern heute aber nicht mehr!

Dieses Thema im Forum "Hardware" wurde erstellt von sylan, 3. Juli 2002.

  1. sylan

    sylan New Member

    Hallo!

    Habe gestern geschafft den apache und alles soweit zum laufen zu bringen dass php angezeigt werden konnte! Heute geht gar nichts mehr!
    das web sharing kann nicht mehr richtig aktiviert werden. was soll ich machen?
     
  2. sylan

    sylan New Member

    das steht dort wenn ich versuche ihn zu starten! kann mir jemand helfen? bitte?

    [Wed Jul 3 08:40:13 2002] [alert] httpd: Could not determine the server's fully qualified domain name, using 127.0.0.1 for ServerName
    /usr/sbin/apachectl graceful: httpd started
     
  3. hakru

    hakru New Member

    Sieht doch eigentlich für den Hausgebrauch okay aus - httpd läuft und müsste als http://localhost/~username bzw. http://127.0.0.1/~username ansprechbar sein.
    Die Meldung besagt lediglich, dass der Server keinen vollgültigen DNS-Namen aufweist - und daher als "localhost" betrieben wird ... ist zuhause normal...

    hakru
     
  4. sylan

    sylan New Member

    die 127.0.0.1 ist aber nicht ansprechbar! was kann der fehler sein?
     
  5. hakru

    hakru New Member

    Könnte am Browser liegen. Der IE mag jedenfalls eine der beiden Möglichkeiten (127.0.0.1 vs. localhost) nicht ... vergesse immer welche, ... und warum weiss ich auch nicht -> Bug!?

    hakru
     
  6. sylan

    sylan New Member

    naja hab beides ausprobiert! nichts hat funktioniert!
     
  7. hakru

    hakru New Member

  8. sylan

    sylan New Member

    wenn ich restart mache erscheint das:

    /usr/sbin/apachectl restart: httpd not running, trying to start
    Processing config directory: /private/etc/httpd/users
    Processing config file: /private/etc/httpd/users/burg.conf
    Processing config file: /private/etc/httpd/users/mysql.conf
    [Wed Jul 3 11:36:42 2002] [alert] httpd: Could not determine the server's fully qualified domain name, using 127.0.0.1 for ServerName
    /usr/sbin/apachectl restart: httpd started

    auf den ordner sites kann ich nicht über den internet explorer zugreifen wenn ich die entsprechende adresse eingebe
     
  9. hakru

    hakru New Member

    ... also dein Server läuft! Wenn Du nämlich jetzt ins Terminal eingibst:
    sudo apachectl start

    ... dann kommt da:
    /usr/sbin/apachectl start: httpd (pid xyz) already running
    ... richtig?

    Wie heisst denn deine html-Testseite in deinem Ordner "Sites" - und was gibst Du GENAU als URL ein ... ??

    hakru
     
  10. sylan

    sylan New Member

    nein, dann kommt:
    Processing config directory: /private/etc/httpd/users
    Processing config file: /private/etc/httpd/users/burg.conf
    Processing config file: /private/etc/httpd/users/mysql.conf
    [Wed Jul 3 11:49:46 2002] [alert] httpd: Could not determine the server's fully qualified domain name, using 127.0.0.1 for ServerName
    /usr/sbin/apachectl start: httpd started

    was müssen wir noch ändern???

    Sylan
     
  11. hakru

    hakru New Member

    Ob ein Prozess namens httpd wirklich läuft, sieht man mit folgendem Befehl im Terminal:
    ps -aux | grep httpd

    ... wenn der Server läuft, wäre sowas zu erwarten:
    root 640 0.0 0.3 3708 1584 ?? Ss 0:00.10 /usr/sbin/httpd
    www 641 0.0 0.1 3708 276 ?? S 0:00.00 /usr/sbin/httpd
    hans 643 0.0 0.0 1112 196 std R+ 0:00.00 grep httpd

    ... wie sieht's bei Dir aus?

    hakru
     
  12. sylan

    sylan New Member

    dann kommt das:

    burg 328 0.0 0.1 1380 316 std U+ 0:00.01 grep httpd

    im websharing versucht er momentan zu starten.
    Ich habe raufgeklickt und nun steht da: server wird aktiviert!!
    Html-seiten gehen auch.

    und?
    sylan
     
  13. hakru

    hakru New Member

    was und?
    Wenn html-Seiten jetzt klappen, wie funktioniert ein php-Testfile?

    hakru
     
  14. sylan

    sylan New Member

    Da tut sich gar nichts. HTML klappt wunderbar, aber bei php gibt es nicht einmal ne fehlereldung.
    Und im websharing steht immernoch: webserver wird aktiviert anstatt er IST aktiviert.

    Hast du noch Ideen???

    Danke, sylan
     

Diese Seite empfehlen