portfreigabe via terminal

Dieses Thema im Forum "Hardware" wurde erstellt von logan5, 24. Dezember 2001.

  1. logan5

    logan5 New Member

    hallo, habe folgendes problem... brickhouse installiert, was mir in der unriegistrierten version nicht die möglichkeit bietet, einzelne port, in meinem fall die fuer carracho, port6000irgendwas) auch kann ich keinen ftp server betreiben, da die ports gespeert sind... wie kann ich diese explizit via terminal programm freigeben?
     
  2. XYMOS

    XYMOS New Member

    hi,

    das kannst du auch mit brickhouse. einfach ne neue filterregel definieren und dann die gewünschten ports öffnen oder schliessen. habe so meine FW konfigurieren können.

    gruss
    xymos
     
  3. logan5

    logan5 New Member

    wenn ich in brickhouse eine rule definieren will und auf tcp klicke, beendet sich das programm habe die b4, werde jetzt mal die b6 ausprobieren, ob das damit geht.... danke, du hattest also keine problem mit brickhouse und 10.1.2 mit brikchouse b6?
     
  4. XYMOS

    XYMOS New Member

    hi,

    ich nutze 1.1b5 ohne probs nur iss mir das teil auch immer abgestürtzt beim erstellen eigener regeln. einfach die internetverbindung beenden und alle offenen programme schliessen, dann geht es ohne probs;-)

    xymos
     
  5. logan5

    logan5 New Member

    habe b5 installiert... selbe problem, wenn ich im quickmodus auf addrule gehe ist das tcp-reiterfeld nur grau unterlegt und nicht auswaehlbar, obwohl ich als admin eingeloggt bin und aendern dard;druecke ich auf das feld beendet sich brickhouse mit fehlermeldung, ist b5 in der unregistrierten version mit 10.1.2. kompatibel? aber eine rule definieren muss doch als sudo oder root auch ueber das terminal gehen, oder etwa nicht so einfach?

    10min. alles noch einmal ausprobiert. fp klappt auch nicht obwohl die rule schon vorgefertigt war, ich sie ausgewaehlt habe, bevor ich brickhouse startete alle anderen programme und die internetverbindung beendet hatte... brickhouse nahm die rule an ich startete neue internetverbindung gab die ip in heftyftp ein als guest anonymos und mit meinem username (wo kann ich das eigetnlich einstellen? 0der koennen nur user die bei mir user reistriert sind via ftp zugreifen, gehe ich richtig in der annahme das die ftp files im public folder in meinem userverzeichnis stehen? ws mache ich falsch?

    genaue beschreibung der ports:

    Is there a way to use programm x behind a firewall/proxy?
    To use programm x through a proxy/firewall ask your system administrator
    to open the ports 6700(TCP) and 6701(TCP) for the server and
    6702(TCP and UDP) for the client. If it is a SOCKS v4 firewall, you
    can enter its address in the Internet control panel (MacOS X doesn't support
    this function yet).
     
  6. RaMa

    RaMa New Member

    >>Is there a way to use programm x behind a firewall/proxy?
    To use programm x through a proxy/firewall ask your system administrator
    to open the ports 6700(TCP) and 6701(TCP) for the server and
    6702(TCP and UDP) for the client. If it is a SOCKS v4 firewall, you
    can enter its address in the Internet control panel (MacOS X doesn't support
    this function yet).

    wenn die ports bei brickhause nicht offen sind, gibts keine chance raus oder reinzukommen...deaktivier brickhaus dann gehts...oder definier die ports... ansonsten über die console... (manual: tippe --> man ipfw )

    zu den usern: ja die user mit name und pw müßen von dir angelegt werden...

    leg einen user an, leg auf der platte einen ordner an, geh in den netinfomanager und im unterordner user klickst du auf den angelegten user und änderst das den pfad von public auf /Volumes/VOLUME/NEUERORDNER/ (großkleinschreibung beachten) oder du killst dieses merkmal und setzt das homeverzeichniss auf diesen ordner.

    hoffe es ist verständlich so...

    ra.ma.
     
  7. logan5

    logan5 New Member

    versuche es gerade mit ftp... wenn ich via terminal die regeln definiere und mit ipfw list alle regeln abrufen erscheinen tatsaechlich:

    54508 allow tcp from any 20 to any out xmit ppp0
    54608 allow tcp from any 21 to any out xmit ppp0

    reicht das aus? kann mich naemlich immer noch nicht via hefty auf meinen rechner einloggen auch nicht ueber verbinden unter (im finder) mit folgender pathangabe:

    ftp://81.90.211.1/Users/user/Public (IP fiktiv)

    was mache ich falsch? danke aber schon einmal fuer den tip? oder, muss ich neu starten, nachdem ich filesharing und ftp ueber preferences aktiviert habe? aber das sollte ja nun nicht so sein...oder muss da noch der rechnername irgendwo stehen?
    cu
     
  8. RaMa

    RaMa New Member

  9. logan5

    logan5 New Member

    passwort@89.81.83.1/'>ftp://user:passwort@89.81.83.1/

    wie alles eingeben? verstehe ich gerade nicht ganz... im terminal oder ueber server verbinden, habe es noch nicht hinbekommen...

    danke fuer deine schnellen antworten...
     
  10. logan5

    logan5 New Member

    habe es immer noch nicht hinbekommen ein ftp server bzw. einen carracho server zum laufen zu bekommen, kann mir in diesem forum wirklich keiner helfen, habe das OSX reference book, das hilft in dieser richtung aber auch nicht weiter, werde bald wahnsinnig... smb funktioniert ebenfalls nicht bei und ich weiss nicht warum, habe die forums beitraege abgegrasst, aber finde nichts gescheites... erstaunlich wie wenig man findet, wenn man nach beiträgen sucht, die ftp beinhalten, funzt das bei euch allen, oder was? ratlos, hilflos, und nervlich in dieser beziehung am ende...

    wer hat ahnung?
     
  11. hakru

    hakru New Member

    von Caracho hab ich null Ahnung.
    Klappt ftp OHNE firewall?

    Deine Regeln

    54508 allow tcp from any 20 to any out xmit ppp0
    54608 allow tcp from any 21 to any out xmit ppp0

    sind nicht okay. Kurz gesagt erlauben sie jedem tcp packet, das aus einem port 20 stammt, via interface ppp0 deinen Rechner zu verlassen. Das interessiert aber wenig, du musst Zugriff von AUSSEN auf die ftp ports erlauben.

    Für einen "klassischen" ftp-Server, der aus dem Internet erreichbar sein soll, brauchst Du aber sowas:

    54508 allow tcp from any to any 21 in setup
    54608 allow tcp from any 20 to any 1024-65535 in setup

    Dies erlaubt fremden Rechnern auf DEINEN port21 (dort lauscht dein ftp server) zuzugreifen, bzw. aus IHREM port 20 mit deinen ports 1024-65535 zu kommunizieren. Die 2 Regeln standen so in dem MacUP-Artikel über OSX Firewall.

    hakru
     
  12. logan5

    logan5 New Member

    werde ich versuchen, kannst du mir die genauen ipfw befehle fuer deine version mitteilen, so fit bin ich da nun auch wieder nicht drin... waere supernett...

    danke
     
  13. hakru

    hakru New Member

    Die Terminalbefehle:
    Die Zahlen nach "add" sind willkürlich, da kannst du auch andere nehmen, musst nur darauf achten, daß in der Liste deiner ipfw-Regeln nicht schon eine "deny"-Regel mit kleinerer Zahl drin ist, die diese Ports verbieten würde.

    "sudo ipfw add 1000 allow tcp from any to any 21 in setup" -> RETURN -> admin-passwd eingeben

    "sudo ipfw add 1010 allow tcp from any 20 to any 1024-65535 in setup" -> RETURN

    Wenn du den passiven ftp-Zugriff auch erlauben willst (was aber nicht zu empfehlen ist), müsste noch dieser Befehl dazu:

    "sudo ipfw add 1020 allow log tcp from any 1024-65535 to any 1024-65535 in setup" -> RETURN

    (Mit dem Zusatz "log" werden durch diese Regel erlaubte Zugriffe in system.log festgehalten)

    hakru
     
  14. logan5

    logan5 New Member

    habe dier regeln hinzugefügt, werde auch angezeigt ueber ipfw list

    ftp und file sharing aktiviert, im Public Ordner ist was drin, versuche mich via hefty einzuwaehlen geht nicht, mit server verbinden nach folgenden schema geht auch nicht: ftp://user:passwort@89.81.83.1/ (IP-fiktiv)

    was mache ich falsch?
     
  15. hakru

    hakru New Member

    Versuchst Du denn, dich local, als von deinem Rechner auf denselben Rechner via ftp zuzugreifen, oder geht es um einen ftp-Zugriff von einem anderen Rechner auf deine Kiste.

    Der lokale Zugriff funktioniert bei mir auch nicht, weder mit "ftp://user:password@localhost" noch mit "ftp://user:password@IPaddresse".

    Was aber problemlos klappt, ist der Zugriff von aussen (Bei meinem Rechner ist natürlich "FTP-Zugriff" in Preferences->Sharing aktiviert). Auf einem anderen Rechner kann ich z.B. "ftp://user:password@IPadresse" in einen Browser eingeben, sehe dann die Files meiner Kiste und kann downloads machen...

    Um sicher zu sein, daß es nicht an irgendwelchen ipfw-Regeln liegt, kannst du die ja mal im Terminal mit "sudo ipfw flush" löschen (die Nachfrage mit y beantworten). Dann müsste der ftp-Zugriff von aussen klappen.

    hakru
     

Diese Seite empfehlen