PowerMac startet nicht mehr... HILFE!!!

Dieses Thema im Forum "Software" wurde erstellt von timur_doumler, 2. Januar 2003.

  1. timur_doumler

    timur_doumler New Member

    Hallo,
    Ich habe ein fürchterliches, dringendes Problem:
    Ich habe einen PowerMac G4 mit OS X 10.2.3. Neulich habe ich in der Einstellung "Startvolume" OS 9 angewählt, weil ich was unter OS 9 ausprobieren wollte. Hat auch wunderbar geklappt, er hat OS 9 gestartet, alles prima. Dann wollte ich wieder auf OS X umstellen. Habe das im Kontrollfeld "Startvolume" gemacht und auf Neustart geklickt. Daraufhin ist der Rechner eingefroren und hat auf nichts mehr reagiert. Musste ihn ausschalten. Nun will er nicht mehr starten: Beim Hochfahren erscheint nur ein blinkendes Fragezeichen. Beim Hochfahren mit gedrückter alt-Taste erscheinen zwei Buttons mit Pfeilen, aber kein Startvolume zum Auswählen, und es passiert auch nichts weiter, wenn man auf die Buttons klickt. Beim Starten mit Apfel-S oder Apfel-X auch nur ein blinkendes Fragezeichen. Habe dann mit Apfel-Alt-P-R den PRAM zurückgesetzt - ergebnislos. Habe dann mit Apfel-C von der OSX-CD gestartet. Daraufhin wollte er OSX neu installieren, sagte aber, daß auf der Festplatte schon ein OSX installiert ist (immerhin!). Hardware-Test und Festplatten-Dienstprogramm sagten, mit der Festplatte sei alles in Ordnung. Daraufhin CD raus - und wieder nur ein blinkendes Fragezeichen. HILFE!!! Wie kann ich meinen Mac wieder starten?
    Danke
    Timur
     
  2. TomPo

    TomPo Active Member

    Guten Morgen und Hallo Newbie,

    hast Du denn schon mal die Firmware überprüft, welche Verison aufgespielt ist?
    Die findest Du im System Profiler unter Boot ROM, müsste beim G4 die v 4.3.3f2 sein.
    Wenn nicht so, dann hast Du etwas "übergangen".
    Oder ist auf der Platte sogar kein HFS+ Datei-Format drauf?

    Im günstigsten Fall mal von der System-CD die Plattentreiber neu installieren.
    Im ungünstigsten Fall OS X neu aufspielen und dabei einen neuen Systemordner erstellen lassen (in den Optionen).
     
  3. timur_doumler

    timur_doumler New Member

    Die Firmware ist aktuell. HFS+ Dateiformat ist natürlich auf der Festplatte drauf - schießlich ist da ja auch ein Mac OS X, was bisher immer funktioniert hat, und alle meine Daten drauf!!! Leider kann ich das mit den Treibern nicht machen, denn die einzige Möglicgkeit, überhaupt irgendwas mit dem Mac zu machen, besteht z.Z. darin, von der OS X CD zu booten, und da gibt's nur das OS X Installationsprogramm und das Festplatten-Dienstprogramm (was übrigens keine Fehler anzeigt). Was soll ich nur tun?
    Timur
     
  4. Stargate

    Stargate New Member

    Was sagt den die "Erste Hilfe" wenn du von der CD gestartet hast?

    Die "Erste Hilfe" lässt sich benutzen BEVOR man irgend etwas neu installiert.
    (Deine Platte hat vermutlich nur einen winzigen defekt im Root)

    Wird das repariert bootet der Rechner davon bzw. er zeigt bei gedrückert ALT Taste ein MacOS 9 und ein X Startvolume an, je nach dem wie es installiert wurde.
     
  5. timur_doumler

    timur_doumler New Member

    Oh Gott! Die Erste Hilfe hat nur so mit hunderten von Fehlermeldungen um sich gespuckt! Eine Kostprobe: "permissions differ on /system/Library/Filesystems/hfs.fs/hfs.util, should be -rwsr-xr-x, they are rwxr-xr-x" oder "group differs on ., should be 80, group is 20" und so weiter... Natürlich verstehe ich nicht im geringsten, was das bedeutet, aber ich hab einfach mal auf Reparieren geklickt. Irgendwann war er dann damit fertig und meinte, alles sei repariert, aber Pustekuchen! Alles ist immer noch genauso. Er findet immer noch kein Startvolume, auch wenn er Festplatte und Volume im Festplattendienstprogramm anzeigt. Immer noch blinkendes Fragezeichen beim Starten. Hat irgendjemand noch eine Idee?
    Timur
     
  6. mikrokokkus

    mikrokokkus New Member

    Hast Du eine 9er-Start-CD, von der Du mal booten könntest?
    Falls ja, sichere auf jeden Fall dann als erstes die Home-Verzeichnisse Deiner X-User raus.
    Dann schau Dir mal den 9er-Sys-Ordner auf der Platte an und versuche von dem zu starten. Wenn das klappt, würd ich versuchen vom 9er aus nochmal X als Startvolume anzugeben.
    Rechte repapiert hast Du offensichtlich. Kannst ja mal als Single User booten (Apfel+S) und "fsck -y" eingeben (Amitastenbelegung!).
    Wenn alles nicht fruchtet, ist es wahrscheinlich am schnellsten, OS X neu zu installieren und die alten User-Ordner dabei zu erhalten.
    (Geht ca. ne halbe Stunde -- wärste jetz schon schneller gewesen ;-))
     
  7. timur_doumler

    timur_doumler New Member

    Falls ich OS X neu installiere, was geht denn dann alles verloren? Die Dateien kann man doch sicher alle erhalten, aber funktionieren die installierten Programme dann noch (Office, Photoshop etc.)? Oder wird gar der ganze Programme-Ordner gelöscht und neu erstellt? Wenn ich nämlich auch noch die Programme neu installieren muß, würde ich lieber nach einer anderen Lösung suchen. Eine OS 9 CD habe ich leider nicht - nur das Software-Paket, was beim PowerMac dabei war (nur Jaguar).
     
  8. danchoice

    danchoice New Member

    Hey timur
    der mikrokukkus hat recht: wenn du dir von irgendwo ne OS9 cd besorgen kannst ist das die beste lösung: von der cd starten und dann mit dem kontrollfeld startvolume wieder zu osX zurückkehren.
    hoffentlich klappts
    gruß daniel
     
  9. mikrokokkus

    mikrokokkus New Member

    Prox müsstest Du auch raussichern, zusätzlich /Library/ApplicationSupport, sonst funken die nachher nicht mehr!
    Die Netzwerkeinstellungen sind übrigens nicht im User-Ordner abgelegt, da sie nicht userspezifisch sind. Ich bin da nicht ganz sicher, glaube aber, dass sie hier sind: /private/var/db/SystemConfiguration/preferences.xml.
    Wenn Du mehrere Partitionen hast, gestaltet sich die ganze Neuinstallation mit Kopieren der Prox, Konfig-Dateien und Userkasumpel etwas einfacher, da Du nichts überschreiben musst.
     
  10. timur_doumler

    timur_doumler New Member

    Wie kann ich denn was "raussichern", wenn ich bis auf das Mac OS X Installationsprogramm nix machen kann?
     
  11. mikrokokkus

    mikrokokkus New Member

    Tja, sorry, aber entweder du bist richtig firm per CLI (SingleUserMode) oder Du musst Dir irgendwo irgendwie eine bootfähige 9er-SysCD besorgen oder selber erstellen (setzt einen funktionierenden Rechner mit Brenner voraus)! Startet eigentlich die Software-Restore-CD, die bei den Quicksilvers beiliegt kein OS 9?
    Hast Du denn mehrere Partitionen oder nur eine? Kannst Du Dir im letzteren Fall eine externe Festplatte leihen?
    Und -- nochmal sorry -- hier siehst Du wunderbar eine alte Wahrheit: Ein Backup erst im Krisenfall zu erstellen, gestaltet sich oft ziemlich schwierig! Hab ich selbst auch schon leidvoll erfahren müssen :-(
     
  12. timur_doumler

    timur_doumler New Member

    Habe mir eine OS 9 CD besorgt. Und tatsächlich gibt es dort ein Kontrollfeld Startvolume. Aber er zeigt keine Festplatte an!!! Was soll ich nun machen?
    Timur
     
  13. mikrokokkus

    mikrokokkus New Member

    Siehst Du denn auf dem Desktop Deine Festplatte?
    Wenn ja, öffne mal den 9er-Systemordner auf dieser und schließ ihn wieder. Wenn er dann ein Findericon gekriegt hat, müsste nach einem weiteren Start von CD das 9 als Startvolume auswählbar sein.
     

Diese Seite empfehlen