Problem mit Classic-Umgebung

Dieses Thema im Forum "Software" wurde erstellt von jojomac, 11. Oktober 2007.

  1. jojomac

    jojomac jojo will Apfel

    Ich habe ein MacBook 2GHz und es hat laut Fehlermeldungen keine Classic-Umgebung. Kann man da irgendwo was downloaden oder so?

    jojo :confused: :meckert:
     
  2. maximilian

    maximilian Active Member

    Hallo!

    Oder so vielleicht. Aber nicht wirklich. Es gab/gibt da eine Software namens SheepShaver ( http://de.wikipedia.org/wiki/SheepShaver ) die das bewerkstelligen sollte, aber das ist eher was für Fachleute und so richtig toll funktioniert hat das glaube ich nie. Ausserdem mußt Du Dir noch ein OS9 irgendwo kaufen dafür, damit wirklich alles funktioniert.

    Mit Classic ist es vorbei auf neuen Macs, genauso, wie es kein verbleites Benzin an der Tankstelle mehr gibt.

    Grüße, Maximilian
     
  3. MacS

    MacS Active Member

    Da es nie ein MacOS 9 (oder älter) für Intel-Prozessoren gab, wird es dies auch nie mehr geben.

    Dein Mac hat eine Intel-CPU und keine PPC-CPU! Dir sollte doch klar sein, dass der PPC-Programm-Code nicht von einem Intel-Prozessor ausgeführt werden kann!
     
  4. TomPo

    TomPo Active Member

    Classic-Umgebung auf Intel-Macs
    Basilisk II und Sheep-Shaver emulieren ältere Prozessoren

    Intel-Macs erlauben per Rosetta-Umgebung Zugriff auf G3- und G4-Programme für Mac-OS X, mit Classic-Programmen bis Mac-OS 9 wissen die neuen Apple-Rechner aber nichts anzufangen.

    Diese Beschränkung wollen zwei Open Source-Emulatoren umgehen, indem sie eine Classic-Umgebung auf Intel-Macs zu Verfügung stellen: Basilisk II JIT, das einen Motorola-68040-Mac nachbildet und Mac-OS 7.x bis 8.1 unterstützen soll, sowie Sheep-Shaver, das eine Power Mac G4-Umgebung emuliert. Damit lassen sich dann laut Entwickler alle klassischen Apple-Betriebssysteme von 7.5.2 bis 9.0.4 betreiben. Beide Emulatoren enthalten einen Just-in-Time (JIT) Compiler für bessere Performance. Sie setzen das Original-ROM eines Classic-fähigen Macs voraus und sind ansonsten kostenlos erhältlich, aber noch jeweils im Beta-Stadium.
     
  5. Apple IIGS User

    Apple IIGS User Und Mac-Anwender ;-)

    Diese Informationen wurden nicht ganz korrekt von der Macwelt recherchiert. Richtiger ist:
    Basilisk II: MacOS 7.0 bis 8.1 (Motorola 68020/68030/68040-Prozessoren)

    SheepShaver (Macintosh-Port): MacOS 8.5.1 bis 9.0.4 (PowerPC-Emulator)

    Zur Zukunft von SheepShaver gibt es noch folgenden Hinweis:
    SheepShaver installieren -> Wie geht es?
     

Diese Seite empfehlen