Problem mit IP Vergabe OSX 10.3

Dieses Thema im Forum "Software" wurde erstellt von hopper13, 21. Januar 2004.

  1. hopper13

    hopper13 New Member

    Ich habe folgendes Problem:
    Ich habe zwei Macs die in einem kleinen Netzwerk via Zyxel ISDN Router-Modem ins Internet gelangen. Das Modem vergibt dazu jedem verbundenen Mac eine IP Adresse ab 192.168.1.33. Da aber beide Macs über Airport miteinander kommunizieren, vergibt das Airport den Macs eine IP Adresse 10.x.x.x.
    Das Problem tritt bei jedem Neustart, Einschalten des Modems oder Erwachen aus dem Schlafzustand auf: automatisch erhält der Mac zuerst die IP vom Airport, womit keine Internetverbindung zustande kommt. Ich muss somit jedes Mal in die Systemeinstellungen -> Netzwerk -> TCP/IP und DHCP-Lease erneuern drücken bis ich eine IP 192.x.x.x erhalte.
    Früher unter Panther (10.2.3) konnte ich jedem Mac in den Netzwerkeinstellungen eine fixe IP zuweisen (192.168.1.33 und 192.168.1.34) womit sich die mühsame manuelle Konfiguration nach jedem Neustart erübrigte. Dies geht mit Jaguar nicht mehr

    Kann mir jemand helfen?
     
  2. Macci

    Macci ausgewandert.

    Willkommen erstmal im besten Forum der Welt ;)

    MacOS 10.2 hiess Jaguar, 10.3 heisst Panther, m das erstmal schnell zu klären. Warum kannst du aber unter Panther keine fixen IP-Adressen vergeben ? Das geht doch völlig problemlos:
    Systemeinstellungen/Netzwerk
    dort statt DHCP einfach Manuell wählen.
     
  3. hopper13

    hopper13 New Member

    Zuerstmal Entschuldigung aber bei Raubkatzen kenne ich mich nicht so gut aus :D
    Die manuelle IP Vergabe bei 10.2 lief problemlos, aber seit dem Update auf 10.3 geht es nicht. Wenn ich z.B. dem iBook 192.168.1.33 vergebe mit korrekter Subnetmaske und Router 192.168.1.1 meldet der Mac beim Versuch ins Internet zu wollen, es gäbe keine Antwort. Das gleiche wenn ich als Router das Airport angebe (10.x.x.x)
    Das ist ja für mich auch das komische!?
     
  4. sandretto

    sandretto Gast

    Kann es sein, dass du in den Netzwerk-Konfigurationen, deine ISDN-Router-Konfiguration erst an zweiter, und die Airport-Konfiguration an erster Stelle hast ? An erster Stelle sollte immer die Konfiguration stehen, mit der man ins Web geht. Bei dir also die ISDN-Konfig.
     
  5. hopper13

    hopper13 New Member

    Bei mir ist die Ethernet-Konfiguration an erster Stelle und Airport erst an zweiter Stelle. Ich habe auch versucht, Airport zu deaktivieren und sogar aus dem Netzwerkmenü zu löschen. Hilft alles nix.
     
  6. lemming

    lemming New Member

    Dann schallt doch den DHCP am Airport aus?
     
  7. hopper13

    hopper13 New Member

    Bei mir ist die Ethernet-Konfiguration an erster Stelle und Airport erst an zweiter Stelle. Ich habe auch versucht, Airport zu deaktivieren und sogar aus dem Netzwerkmenü zu löschen. Hilft alles nix.
     
  8. lemming

    lemming New Member

    Dann schallt doch den DHCP am Airport aus?
     
  9. hopper13

    hopper13 New Member

    Bei mir ist die Ethernet-Konfiguration an erster Stelle und Airport erst an zweiter Stelle. Ich habe auch versucht, Airport zu deaktivieren und sogar aus dem Netzwerkmenü zu löschen. Hilft alles nix.
     
  10. lemming

    lemming New Member

    Dann schallt doch den DHCP am Airport aus?
     
  11. sandretto

    sandretto Gast

    >>>Ich habe auch versucht, Airport zu deaktivieren und sogar aus dem Netzwerkmenü zu löschen. Hilft alles nix.

    Also so wie sich das anhört, scheint etwas mit dem dem Zusammenspiel von Panther (10.3.x) und dem Zyxel ISDN Router-Modem nicht mehr zu stimmen. Denn wenn Airport deaktiviert ist, und das Problem besteht weiterhin, ja dann.


    >>>Das Problem tritt bei jedem Neustart, Einschalten des Modems oder Erwachen aus dem Schlafzustand auf: automatisch erhält der Mac zuerst die IP vom Airport, womit keine Internetverbindung zustande kommt. Ich muss somit jedes Mal in die Systemeinstellungen -> Netzwerk -> TCP/IP und DHCP-Lease erneuern drücken bis ich eine IP 192.x.x.x erhalte.

    Was steht dann nachher unter TCP/IP im Netzwerkpanel der ISDN-Router-Umgebung, ist die IP dann überhaupt noch zu sehen ? Du schreibst ja........ DHCP-Lease erneuern drücken bis ich eine IP 192.x.x.x erhalte.

    Könnte auch ein Bug sein von Panther, schon mal die einschlägigen Foren abgeklappert ?
     
  12. hopper13

    hopper13 New Member

    >>>Also so wie sich das anhört, scheint etwas mit dem dem Zusammenspiel von Panther (10.3.x) und dem Zyxel ISDN Router-Modem nicht mehr zu stimmen. Denn wenn Airport deaktiviert ist, und das Problem besteht weiterhin, ja dann.

    Es scheint so zu sein, dass Panter zuerst die IP vom Airport bezieht und sodann natürlich nicht noch die IP vom Zyxel bekommen kann.

    >>>Was steht dann nachher unter TCP/IP im Netzwerkpanel der ISDN-Router-Umgebung, ist die IP dann überhaupt noch zu sehen ?

    Es erscheint immer eine IP - aber eben immer die 10.x.x.x vom Airport, dann "DHCP Lease erneuern" und irgendwann schafft es dann Panther vom Zyxel eine 192.168.1.x IP zu bekommen.

    Ich habe bis jetzt keine Lösung gefunden, das Problem besteht wie gesagt erst seit letzten Sonntag als ich das Jaguarkätzchen vom Panther verjagt habe.
    p.s. Problem besteht sowohl auf dem iBook als auch beim Desktop G4
     
  13. sandretto

    sandretto Gast

    >>>Es scheint so zu sein, dass Panter zuerst die IP vom Airport bezieht und sodann natürlich nicht noch die IP vom Zyxel bekommen kann.

    Irgend etwas machst du wahrscheinlich falsch, es sei denn es ist ein Bug, denn es ist mit MacOSX problemlos möglich, mehrere Netzwerkumgebungen gleichzeitig zu verwalten.

    Wenn du eine Umgebung für Airport hast, und dann noch eine für dein ISDN-Router, dann kann es nicht sein, dass jeweils nur eine IP vergeben wird !

    Du musst in den Netzwerk-Konfigurationen beide aktivieren, Ethernet (Router) an 1., Airport an 2. Stelle. Beide können separate IP's verwalten, 10.x.x.x für die Airport-Umgebung, und 192.168.x.x für die ISDN-Router-Umgebung.

    >>>Es erscheint immer eine IP - aber eben immer die 10.x.x.x vom Airport, dann "DHCP Lease erneuern" und irgendwann schafft es dann Panther vom Zyxel eine 192.168.1.x IP zu bekommen.

    Genau das darf aber nicht passieren, sollte auch nicht, wenn du zwei Umgebungen korrekt konfiguriert hast.
     
  14. hopper13

    hopper13 New Member

    Danke für die Hilfe!

    Ich habe am Airport die automatische IP Vergabe per DHCP deaktiviert. Und siehe da: Die IP des Routers nimmt der Mac gleich an. Komisch nur, dass dies unter Jaguar funktionierte; vielleicht hängt es mit dem Update der Airport Software zusammen.
     
  15. hopper13

    hopper13 New Member

    Bei mir ist die Ethernet-Konfiguration an erster Stelle und Airport erst an zweiter Stelle. Ich habe auch versucht, Airport zu deaktivieren und sogar aus dem Netzwerkmenü zu löschen. Hilft alles nix.
     
  16. lemming

    lemming New Member

    Dann schallt doch den DHCP am Airport aus?
     
  17. sandretto

    sandretto Gast

    >>>Ich habe auch versucht, Airport zu deaktivieren und sogar aus dem Netzwerkmenü zu löschen. Hilft alles nix.

    Also so wie sich das anhört, scheint etwas mit dem dem Zusammenspiel von Panther (10.3.x) und dem Zyxel ISDN Router-Modem nicht mehr zu stimmen. Denn wenn Airport deaktiviert ist, und das Problem besteht weiterhin, ja dann.


    >>>Das Problem tritt bei jedem Neustart, Einschalten des Modems oder Erwachen aus dem Schlafzustand auf: automatisch erhält der Mac zuerst die IP vom Airport, womit keine Internetverbindung zustande kommt. Ich muss somit jedes Mal in die Systemeinstellungen -> Netzwerk -> TCP/IP und DHCP-Lease erneuern drücken bis ich eine IP 192.x.x.x erhalte.

    Was steht dann nachher unter TCP/IP im Netzwerkpanel der ISDN-Router-Umgebung, ist die IP dann überhaupt noch zu sehen ? Du schreibst ja........ DHCP-Lease erneuern drücken bis ich eine IP 192.x.x.x erhalte.

    Könnte auch ein Bug sein von Panther, schon mal die einschlägigen Foren abgeklappert ?
     
  18. hopper13

    hopper13 New Member

    >>>Also so wie sich das anhört, scheint etwas mit dem dem Zusammenspiel von Panther (10.3.x) und dem Zyxel ISDN Router-Modem nicht mehr zu stimmen. Denn wenn Airport deaktiviert ist, und das Problem besteht weiterhin, ja dann.

    Es scheint so zu sein, dass Panter zuerst die IP vom Airport bezieht und sodann natürlich nicht noch die IP vom Zyxel bekommen kann.

    >>>Was steht dann nachher unter TCP/IP im Netzwerkpanel der ISDN-Router-Umgebung, ist die IP dann überhaupt noch zu sehen ?

    Es erscheint immer eine IP - aber eben immer die 10.x.x.x vom Airport, dann "DHCP Lease erneuern" und irgendwann schafft es dann Panther vom Zyxel eine 192.168.1.x IP zu bekommen.

    Ich habe bis jetzt keine Lösung gefunden, das Problem besteht wie gesagt erst seit letzten Sonntag als ich das Jaguarkätzchen vom Panther verjagt habe.
    p.s. Problem besteht sowohl auf dem iBook als auch beim Desktop G4
     
  19. sandretto

    sandretto Gast

    >>>Es scheint so zu sein, dass Panter zuerst die IP vom Airport bezieht und sodann natürlich nicht noch die IP vom Zyxel bekommen kann.

    Irgend etwas machst du wahrscheinlich falsch, es sei denn es ist ein Bug, denn es ist mit MacOSX problemlos möglich, mehrere Netzwerkumgebungen gleichzeitig zu verwalten.

    Wenn du eine Umgebung für Airport hast, und dann noch eine für dein ISDN-Router, dann kann es nicht sein, dass jeweils nur eine IP vergeben wird !

    Du musst in den Netzwerk-Konfigurationen beide aktivieren, Ethernet (Router) an 1., Airport an 2. Stelle. Beide können separate IP's verwalten, 10.x.x.x für die Airport-Umgebung, und 192.168.x.x für die ISDN-Router-Umgebung.

    >>>Es erscheint immer eine IP - aber eben immer die 10.x.x.x vom Airport, dann "DHCP Lease erneuern" und irgendwann schafft es dann Panther vom Zyxel eine 192.168.1.x IP zu bekommen.

    Genau das darf aber nicht passieren, sollte auch nicht, wenn du zwei Umgebungen korrekt konfiguriert hast.
     
  20. hopper13

    hopper13 New Member

    Danke für die Hilfe!

    Ich habe am Airport die automatische IP Vergabe per DHCP deaktiviert. Und siehe da: Die IP des Routers nimmt der Mac gleich an. Komisch nur, dass dies unter Jaguar funktionierte; vielleicht hängt es mit dem Update der Airport Software zusammen.
     

Diese Seite empfehlen