Problem mit Java-Plug-in

Dieses Thema im Forum "Mac-OS X 10.6 Snow Leopard" wurde erstellt von AndMacs, 31. Januar 2013.

  1. AndMacs

    AndMacs New Member

    Hallo Forum,

    ich habe – mal wieder – ein Problem mit dem Java-Plug-in.

    Die entsprechende Website hat bis heute problemlos funktioniert. Heute nun melden sowohl Safari als auch Chrome lediglich "inaktives Plug-in". Bei einem Klick auf den entsprechenden Pfeil öffnet die Software-Aktualiserung, die dann aber meldet das das System auf dem neusten Stand ist.

    In den Java-Einstellungen sind Applet-Plug-ins und Web-Start Programme aktiviert. Deaktivieren und wieder aktivieren hat nichts gebracht.

    Neustart habe ich versucht, ebenfalls ohne Erfolg.

    Problem besteht auch auf einem alternativen Nutzer-Account.

    Hier kurz meine Daten:
    Mac OS 10.6.8
    Safari 5.1.7
    Chrome 24.0.1312.57

    Java SE 6 1.6.0_37


    Für Hilfe bin ich sehr dankbar.
     
  2. AndMacs

    AndMacs New Member

    Hilf Dir selbst...

    Okay, das ist fast nicht zu glauben... Offenbar handelt es sich um ein weit verbreitetes Problem. Die Lösung hat ein Held hier gefunden:
    https://discussions.apple.com/message/21091411?tstart=0#21091411?tstart=0

    Java läuft nach der Ausführung des Terminal Befehls:

    sudo /usr/libexec/PlistBuddy -c "Delete :JavaWebComponentVersionMinimum" /System/Library/CoreServices/CoreTypes.bundle/Contents/Resources/XProtect.meta.plist

    wieder. Auch dann, wenn man wie ich nicht versteht, was man tut.
     
  3. MACaerer

    MACaerer Active Member

    Das wäre aber keine schlechte Idee sich vorher kundig zu machen, bevor man einen Befehl mit Root-Rechten ausführt. Es gibt leider genügend Scherzkekse, die einem irgendwelche harmlos aussehenden Befehle zur Lösung irgendwelcher Probleme empfehlen und die dann schwerwiegende Schäden anrichten.
    Beim vorliegenden Befehl ist das glücklicherweise nicht der Fall. Der Befehl startet das UNIX-Tool PlistBuddy, mit dem man ähnlich wie mit dem defaults-Editor Plist-Dateien editieren kann. Der Befehl löscht die Zeile "JavaWebComponentVersionMinimum aus der XProtect.meta.plist.
    Wie bei jeden tiefgreifenden Befehl in den UNIX-Eingeweiden ist es aber trotzdem zu empfehlen ein BackUp in Reserve zu heben.

    MACaerer
     
  4. AndMacs

    AndMacs New Member

    Danke für die Belehrung. Ganz so unbedarft wie es scheinen mag, bin ich dann doch nicht; ich weiß schon halbwegs was ich tue.

    Was ich mich vor allem aber frage ist: Wieso wird diese Zeile heute plötzlich zum Problem?
     
  5. MACaerer

    MACaerer Active Member

    Warum das entfernen der Zeile das Problem behebt weiß ich auch nicht. Übrigens sollte mein Kommentar keine "Belehrung" sein, sondern ein Hinweis aus gegebenem Anlass. Schließlich hast du ja selber geschrieben, dass du nicht weißt was der Befehle bewirkt.

    MACaerer
     
  6. toni-mail

    toni-mail New Member

    Hallo Zusammen,
    ich hoffe, die Snow-Leopard-Gemeinde (OSX 10.6.8) hat sich seit dem letzten Thread nicht ganz in Luft aufgelöst und jemand, der sich auskennt, ist imstande, (m)ein Dauerproblem mit Java zu lösen. Der "String der Hoffnung", der AndMacs (siehe oben) vor fast genau 2 Jahren offenbar aus der Java-Patsche holte, hilft bei mir leider überhaupt nicht weiter. Statt der Lösung des Java-Problems bekomme ich folgendes zu lesen:
    Delete: Entry, ":JavaWebComponentVersionMinimum", Does Not Exist
    Da ich neugierig bin, schaute ich mir die betreffende Datei genauer an und erhielt folgenden Inhalt:
    <key>LastModification</key>
    <string>Thu, 23 Jun 2011 08:10:43 GMT</string>
    <key>Version</key>
    <integer>21</integer>


    Wieso ist bei mir eine andere "XProtect.meta.plist"? Selbst wenn sie nicht editiert und gleich komplett in den Papierkorb wandert, ändert sich am Browser nichts. Es erscheint nach wie vor die Meldung "Click to install Java". Das ist echt nervig, denn die einzige herunterladbare Version lässt sich nicht installieren, weil 10.7. verlangt wird.
    Gibts doch noch einen "String der Hoffnung" für mich? Vielleicht etwas ohne Java?
    Danke für hilfreiche Antworten!
    Toni
     
  7. Melissa

    Melissa New Member

    Ich konnte nun wenigstens das Problem einschränken: Offenbar liesst der neue Mac-SL-Treiber die Frontlade-Funkton nicht - der Drucker druckt also nur noch aus dem hinteren papierfach, nicht aber aus dem vorderen ...
     

Diese Seite empfehlen