Problem mit SuSE Linux

Dieses Thema im Forum "Software" wurde erstellt von master_of_sword, 22. Februar 2001.

  1. master_of_sword

    master_of_sword New Member

    Ich habe ein Problem mit SuSE Linux 7, und zwar folgendes:
    Nach dem Installieren von Linux und nach dem Start des Betriebssystems (nicht KDE!) wechselt der Bildschirm mehrmals zwischen der Farbe grau und der Konsole. Danach erscheint der Login-Prompt. Normalerweise müsste sich der Bildschirm zeigen, wo man sich in KDE einloggen kann. Anscheinend kann es das X Windowing System nicht starten. "startx" hilf auch nix. Kann mir vielleicht jemand sagen, was ich da falsch gemacht habe? Bin Linux-Newbie, also bitte genau erklären was ich zu machen habe, sonst verwirrt mich das nur noch mehr... THANX!! Und noch etwas:
    Gibt es ein Utility mit dem sich Partitionen löschen lassen, die nicht im Finder angezeigt werden können? (Zum Beispiel um A/UX Partitionen in HFS+ "umzuwandeln") Für Hilfe wäre ich sehr dankbar!
    master_of_sword
    ps. ich habe soetwas schonmal ins forum gepostet, nur geht das leider immer unter, d.h. es wird immer von neuen verdrängt, leider ... und antworten, die mir geholfen hätten, gab es bisher (leider) noch nicht...
    pps. warum lässt sich auf meinem computer (pm 9600/233) nicht von der SuSE linux 7 cd starten, obwohl da ein system drauf ist?
     
  2. sternenacht

    sternenacht New Member

    hi,
    normalerweise sollte der yast2 dein system problemlos zum laufen bringen, auch in farbe. hast du irgendwelche exotische hardware? schau mal in der db von suse nach.
    unter linux kannst du mit pdisk partitionen loeschen (aber vorsicht, das tool ist nicht so ganz ohne).
    die suse-cds koennen auf dem mac aus lizenzrechtlichen gruenden nicht booten(hat mir ein knilch von der suse-hotline mal erzaehlt). keine ahnung warum. aber mit bootx geht es doch ganz gut(zumindest bei den old-world-macs).
    greetings

    holger
     
  3. master_of_sword

    master_of_sword New Member

    beim allerersten mal (wo ich die festplatte formatiert + partitioniert habe mit laufwerke konfigurieren) ging auch alles einwandfrei. dann als ich einen anderen monitor angeschlossen hatte, trat das problem auf jedesmal wo ich linux bootete. danach hab ich mit pdisk (ist in yast2 eingebaut, oder?) die 2 (1 EXT2 + 1 SWAP) partitionen initialisiert (formatieren kann man ja nur das ganze laufwerk) und linux von grund auf neu installiert. aber es trat trotzdem dasselbe prob auf! obwohl ich es praktisch von grund auf neu installiert habe... (mit der ausnahme dass ich nicht gaaanz von vorne angefangen habe mit formatieren, partitionieren etc.). nunja, hoffentlich kommen noch mehr antworten. in der database werd ich nachschauen, kann ja nicht schaden...
    help!
     
  4. MacGhost

    MacGhost Active Member

    Hallo MoS,

    rufe doch mal Yast auf unter der Konsole und stelle dort die Grafikkarte und den Monitor neu ein.
    Hört sich ganz an als ob Du der Xserver nicht die angegebene Hardware findet.
    Ansonsten versuche Dich doch mal an die Einstellungen heranzutasten.
    Als erstes den VGA16 Farben Modus mit 640x480 bei 60Hz.
    Wenn Du die Daten Deines Monitors und der Grafikkarte vorliegen hast, dann rufe doch mal XF86setup oder XF86Config auf.
    Weiß nicht mehr genau wie das heißt !
    Und hier kann man die daten von Hand eintippen, ansonsten mit dem vi die Datei /etc/X11/XF86Config editieren und hier die Daten zu Fuß eintippen. Kann auch sein das es die Datei XF86Config-4 ist.

    Joern
     
  5. sternenacht

    sternenacht New Member

    hi,
    wenn du nachdem du das linux am laufen hattest einen anderen monitor anschliesst, kann es sehr wohl sein, dass dein x nicht mehr startet. denn der xserver nutzt die grafikkarte in verbindung mit dem monitor maximal aus. d.h. wenn der monitor nicht mehr mitkommt, oder die grafikkarte die aufloesung nicht darstellen kann, startet x nicht.
    probier es nochmal mit dem sax, der sollte dir einen moegliche konfiguration zusammenbasteln koennen, dann kannst du immer noch mit den anderen tools herumhantieren (die sind aber wirklich nicht ganz ungefaehrlich fuer deine hardware).

    greetings

    holger
     

Diese Seite empfehlen