Probleme mit fetchmail

Dieses Thema im Forum "Mac-OS X 10.6 Snow Leopard" wurde erstellt von Deus-X, 23. Februar 2011.

  1. Deus-X

    Deus-X New Member

    Hallo Gemeinde,

    ich habe ein kleines Problemchen bei dem ich nicht so recht weiterkommen.

    Vor mir steht ein Snow Leopard Server der als interner Mailserver fungiert.
    Weiterhin haben wir einen externen Mailserver, von dem der MAC Server per fetchmails seine Mails für die einzelnen Accounts bekommt.

    Die Benutzernamen sind wie folgt aufgebaut:

    1ster Buchstabe Vorname+Nachname = btrenn
    Auch existiert ein Alias dazu in der /etc/postfix/aliases

    b.trenn = btrenn

    Sende ich nun intern Mails, ist es egal welche Variation ich verwende.
    btrenn und b.trenn kommen alle an.

    Sendet man von aussen eine Mail an den lokalen Benutzernamen, so bekomme ich sobald fetchmail ins Spiel kommt, das die Adresse auf sich selbst loopt.

    Meldung die zurück kommt:

    <btrenn@domain.de>: mail forwarding loop for btrenn@domain.de
    Reporting-MTA: dns; mail1.domain.de
    X-Postfix-Queue-ID: 44C7A3781A7
    X-Postfix-Sender: rfc822; btrenn@domain.com
    Arrival-Date: Wed, 23 Feb 2011 16:48:32 +0100 (CET)

    Final-Recipient: rfc822; btrenn@domain.de
    Original-Recipient: rfc822;btrenn@domain.de
    Action: failed
    Status: 5.4.6
    Diagnostic-Code: X-Postfix; mail forwarding loop for btrenn@domain.de

    So und ab hier stehe ich auf dem Schlauch.

    Hinzu kommt, das die Kurznamen, die man im Serveradmin eintragen kann allesamt nie als Mailalias funktioniert haben. Weshalb wir dann eben die Datei aliases dafür verwenden um Mailaliase zu erstellen, oder eine Mailadresse an einen anderen User weiter zu leiten.

    Kann das damit zu tun haben ?

    Ansonsten funktioniert das System tadellos.

    Freue mich auch eure Antworten und Fragen.

    Danke für eure Mühe
     
  2. John L.

    John L. Active Member

    Ich kenn zwar den SL-Server überhaupt nicht aber Postfix ist ja ein gängiges Unix/Linux Paket. Wenn Du nach "Diagnostic-Code: X-Postfix; mail forwarding loop" googlest oder mal die Postfix-Logs nach Fehlern durchsuchst, solltest Du relativ schnell den Fehler finden...

    John L.
     

Diese Seite empfehlen