Probleme mit MacOS X.2 als DSL-Router

Dieses Thema im Forum "Hardware" wurde erstellt von johnny, 31. März 2003.

  1. johnny

    johnny New Member

    Hallo!

    Ich habe mehrere Macs in einem Netzwerk über einen Switch verbunden. Mit dem Uplink hängt der Switch am DSL-Modem. Nun habe ich einen der Rechner mit "Internet-Sharing" zum Router konfiguriert. Alle anderen Rechner als DHCP-Clients.

    Das funktioniert auch alles bestens. Leider kann ich aber mit den Client-Rechnern nur eingeschränkt auf das Internet zugreifen, d.h. ich kann im Schnitt nur 1/5 aller Internetseiten aufrufen, zu allen anderen bekomme ich keine Verbindung. Außerdem ist die Verbindung sehr langsam.

    Kann das Problem vielleicht mit den DNS-Servern zusammen hängen. Hier habe ich eine IP eingetragen, die ich über das Netzwerk-Utility herausbekommen. Mehr waren nicht möglich.Funktioniert aber auch ohne DNS einzutragen.

    Ich hoffe, dass mir jemand bei dem Problem helfen kann.

    Danke für hilfreiche Infos!
    Johnny
     
  2. Kate

    Kate New Member

    Das Problem scheint wirklich die Namensauflösung zu sein. Du solltest als DNS Server entweder den Server deines Providers angeben(auf allen Clients), oder DNS auf dem "Route"-Mac anschalten, was aber eine Menge Konfigurationsarbeit verlangt und nicht so trivial ist.
     
  3. johnny

    johnny New Member

    Die DNS hatte ich bereits auf allen Clients eingetragen. Funktioniert trotzdem nicht.
    Kannst du mir vielleicht kurz (falls das überhaupt möglich ist) erklären, wie ich die DNS auf dem Router-Mac konfiguriere?

    Noch eine kleine Info: Es werden alle Internetseiten gefunden, es kann aber zu den meisten keine Verbindung aufgebaut werden.
     
  4. Kate

    Kate New Member

    Mich würde interessieren wie deine Netztopologie aussieht.

    Wenn du über deinen MacRouter eine DSl Leitung gemeinsam nutzen willst, muss diese direkt mit dem Ethernetport des RouterMac verbunden sein.Damit der dann im Netz selber noch aktiv sein kann braucht man eigentlich ein zweites Interface , also eine weitere Ethernetkarte. Ethernet1 wird mit dem Router verbunden und Ethernet2 wird per Hub oder Switch mit den anderen Macs verbunden. Anscheinend hast du aber alles mit dem Hub/Switch verbunden.

    Das müsste auch gehen, wenn das Modem selber einen DHCP Server eingebaut hätte, haben die aber meist nicht.
     
  5. johnny

    johnny New Member

    Da mein Router-Mac nur über eine Ethnetschnittstelle verfügt, habe ich diesen natürlich auch am Switch hängen. Ich habe irgendwo gelesen, dass das aber eigentlich kein Problem darstellen sollte, der MacOS X Router soll angeblich den Traffic steuern und sozusagen den Port für Internet und Netzwerk teilen. Weiß aber nicht, ob das so wirklich richtig ist.

    Das seltsame ist ja eigentlich, dass ich durchaus mit den Client-Macs ins Internet kann, sie können halt nur bestimmte Internetseiten/Server erreichen (wobei sich da kein Muster erkennen lässt). Und Emails empfangen und verschicken funktioniert bestens.

    Vielleicht probiere ich das mit der 2. Netzwerkkarte mal aus, wenn sonst keiner eine Idee hat.
     
  6. Kate

    Kate New Member

    Ja das ist schon richtig, aber anscheinend klappt das Routing dann nicht bei dir.
     

Diese Seite empfehlen