Probleme mit Time Machine

Dieses Thema im Forum "Software" wurde erstellt von berndhelmer, 11. September 2009.

  1. berndhelmer

    berndhelmer New Member

    Lange Zeit hat Time Machine korrekte Backups erstellt. Aber seit ca. 4 Wochen beendet Time Machine den Vorgang mit der Meldung: "Das Backup konnte nicht abgeschlossen werden. Beim Kopieren der Dateien auf das Backup-Volume ist ein Fehler aufgetreten." Habe noch keine Erklärung dafür gefunden.
    Weiß jemand Rat?

    System 10.5.8, iMac 24" 2,4 GHz. Externe Platte Seagate 1,5 TB. Mount-Point: /Volumes/iMac-Save Kapazität: 1,4 TB (1.499.957.936.128 Byte)
    Format: Mac OS Extended (Journaled) Verfügbar: 1,1 TB (1.228.594.180.096 Byte)
    Eigentümer aktiviert: Ja Belegt: 252,7 GB (271.363.756.032 Byte)
    Anzahl der Ordner: 417.727 Anzahl der Dateien: 2.997.309

    berndhelmer
     
  2. dimoe

    dimoe New Member

    ich habe bei so einer Meldung als erstes mit dem Festplattendienstprogramm die Rechte des Time-Machine-Volumes überprüft und wenn das nicht geholfen hat DiskWarrior genommen, danch ging es immer wieder (4-5 Mal schon)
     
  3. berndhelmer

    berndhelmer New Member

    Danke dimoe!
    Im Festplattendienstprogramm ist bei mir die Rechteprüfung nur für das Startvolume möglich. Wenn ich die externe Platte auswähle ist die Funktion ausgegraut. DiskWarrior besitze ich leider nicht - ist wohl nur in englisch verfügbar. Was macht dieses Programm eigentlich? Wenn es Sinn macht besorge ich es mir. Habe auch schon überlegt die externe Platte neu zu formatieren. Aber dann habe ich die Datensicherungen von drei Jahren verloren.

    Weil ich demnächst clean auf den Snowleoparden upgraden möchte brauche ich dringend eine aktuelle Datensicherung.

    berndhelmer
    :rolleyes:
     
  4. MACaerer

    MACaerer Active Member

    Das ist auch richtig so. Die Rechte werden vom System verwaltet und das ist nun mal auf dem Startvolume. Nichts desto weniger trotz werden dadurch auch die Zugriffsrechte auf dem externen Volume korrigiert. Wenn du schon dabei bist, überprüfe doch mal, ob das externe Laufwerk mit der GUID-Partitionstabelle eingerichtet ist. Falls nicht könnte das lt. dem Apple-Support bei größeren Dateimengen Probleme bereiten.

    MACaerer
     
  5. berndhelmer

    berndhelmer New Member

    Das externe Laufwerk ist mit der GUID-Partitionstabelle eingerichtet.
     
  6. dimoe

    dimoe New Member

    entschuldige, Rechteprüfung gibt es ja nur bei startfähigen System-Partitionen, ich meinte, daß Volume zu prüfen/reparieren
    DiskWarrior gibt es wirklich nur in Englisch, ist aber nicht kompliziert, man muß nur das Programm starten können.
    Es werden die Ordner/Verzeichnisse ordentlich zurechtgebogen - wie weiß ich nicht, aber ich vertraue dem Programm seit 5 Jahren!
    Ich habe damit wirklich schon viele Probleme beseitigen können.
     
  7. Kolia

    Kolia New Member

    Falls Du den Zugang zu Deinen letzten 3 Jahren nicht mehr herstellen kannst, würde ich vor dem Formatieren den Backupordner unbedingt auf einer anderen externen Platte "zwischenspeichern".
    1. kannst Du das Backup im schlimmsten Falle immer noch "händisch" nutzen, um Passendes herauszufischen.
    2. stehen die Chancen gut, dass das delikate TM später wieder den Draht zu dem alten Backup aufnehmen kann (einfach nur so oder mit weiteren Tipps aus einem Forum)
    Zuerst würde ich aber folgendes probieren:
    Ich würde auf einem anderen Laufwerk mal ein neues Backup starten, dann hättest Du auch vor deinem Schneeerlebnis ne Sicherung: keine 300 GB in 3 Jahren, das dürfte auf Deiner HD ja nicht zu viel sein (oder, noch besser eine Spiegelung mit SuperDuper oder ccc). Nach der (z.B.) einmaligen Sicherung des aktuellen Zustandes würdest Du dann wieder die alte HD anklemmen, in der TM-Systemeinstellung wieder die HD mit Deinem alten Backup auswählen: Vielleicht kann er wieder an das alte anknüpfen.
    p.s.: habe auch noch so ein altes "verwahrlostes TM-Backup", dass ich aber (noch) nicht wegwerfe.
    Toi,toi
     
  8. berndhelmer

    berndhelmer New Member

    Vielen Dank Kolia!
    Genau das werde ich auch tun. Die externe Platte die hier mit TM Probleme macht ist eine Seagate 1,5 TB - im Juli neu gekauft und mit der GUID-Partitionstabelle eingerichtet. Sie ist über FireWire 800 an den iMac angeschlossen. Habe über die Systemeinstellungen -> TM der Sicherung quasi mal zugeschaut. Während etwa 20 Minuten wird "Backup vorbereiten" angezeigt, dann beginnt TM zu schreiben. Nach etwa 5 MB bleibt der Vorgang hängen und dann tut sich gar nichts mehr. Irgendwann kommt dann die Fehlermeldung von TM. Kann es sein, dass die Ursache gar nicht TM ist, sondern meine Externe sich nicht richtig ansprechen lässt - hängen bleibt?

    Tolles Forum, Dank auch an alle anderen Mitglieder. Hoffentlich kann ich mich mal revanchieren!
     
  9. Kolia

    Kolia New Member

    "Glaube" ich nicht: Bin kein "Bastler", aber Deine Beschreibung - oder ähnlich - habe ich schon vielfach in diesem bzw. anderen Foren gelesen. Die Lösung fand sich immer in irgend einer Datei auf deinem Rechner, an der sich TM verschluckt. Als Lösung ergab sich stets die Sichtung "irgendwelcher Log-Dateien", die genau anzeigen, bei welcher Datei es hakt! Nach Löschung dieser Dateien (o.Ä.) gings wieder glatt: TM iss nu ma pingelig! Such da noch mal nach anderen TM- Threads!!!
     
  10. berndhelmer

    berndhelmer New Member

    Könnte das ein Hinweis sein? Hier eine Fehlermeldung von CCC für "iPhotoAux.db".
    21:31:09 Warning user about performing a destructive action.
    21:31:13 User chose to proceed with destructive action.
    21:31:14 Auf dem Zielvolume sind Zugriffsrechte aktiviert.
    21:31:14 Auf dem Zielvolume sind Zugriffssteuerungslisten aktiviert.
    21:31:14 Überprüfen, ob ein Klonvorgang auf Blockebene möglich ist...
    21:31:14 Aborting block-level clone, starting over with file-level clone.
    21:31:14 Anmelden...
    21:31:22 Synchronisation Engine starten...
    21:31:26 Klonen...
    21:45:10 Detected input/output error
    21:45:10 rsync: read errors mapping "/Users/susannehoy/Pictures/iPhoto Library/Before Restore/iPhotoAux.db": Input/output error (5)
    21:45:22 Detected input/output error
    21:45:22 rsync: read errors mapping "/Users/susannehoy/Pictures/iPhoto Library/Before Restore/iPhotoAux.db": Input/output error (5)
    21:45:22 ERROR: Users/susannehoy/Pictures/iPhoto Library/Before Restore/iPhotoAux.db failed verification -- update discarded. (51)
    21:49:48 rsync error: some files/attrs were not transferred (see previous errors) (code 23) at /Volumes/Home/Users/bombich/Development/Bombich_Software/rsync-3.0.5/main.c(1047) [sender=3.0.5] (51)
    21:49:48 rsync exited with status 23
    21:49:48 rsync exited with a non-zero exit status: 23. (51)
    21:49:49 rsync: CCC hat während des Klonvorgangs Eingabe/Ausgabe-Fehler festgestellt., Error code: 54
    21:49:49 Sync Engine warnings: (
    "rsync: read errors mapping \"/Users/susannehoy/Pictures/iPhoto Library/Before Restore/iPhotoAux.db\": Input/output error (5)",
    "rsync: read errors mapping \"/Users/susannehoy/Pictures/iPhoto Library/Before Restore/iPhotoAux.db\": Input/output error (5)",
    "ERROR: Users/susannehoy/Pictures/iPhoto Library/Before Restore/iPhotoAux.db failed verification -- update discarded.",
    "rsync error: some files/attrs were not transferred (see previous errors) (code 23) at /Volumes/Home/Users/bombich/Development/Bombich_Software/rsync-3.0.5/main.c(1047) [sender=3.0.5]"
    )
    ================================================================================


    21:53:26 Launched Carbon Copy Cloner [3.2.1] on Version 10.5.8 (Build 9L30)
     
  11. Kolia

    Kolia New Member

    Da scheint ja die Datenbank von iPhoto durcheinander: Die musst Du eh reparieren: iPhoto mit gedrückter alt-Befehl (Option-command) - Taste öffnen: Es erscheint untenstehendes Dialogfeld. Klicke alles an (so machte ichs, da ich kein Spezialist bin, der aus der Fehlermeldung das kritische Detail herausfischen kann) und lasse alles reparieren . Es wird immer empfohlen zuerst eine Kopie des iPhoto - Ordners (umbenannt) an anderer Stelle zu machen (aber so, dass TM nicht später auch diesen "Schrott" - Verzeihung - wieder vergeblich sichern will). Dann lässt Du das reparieren und hast wahrscheinlich wieder ein sauberes iPhoto und danach coole Sicherungen via CCC (ich bevorzuge SuperDuper, der repariert auch vorher Rechte; weiß nicht ob CCC auch) und später TM.
    Viel Erfolg!
     

    Anhänge:

    Zuletzt bearbeitet: 16. September 2009
  12. berndhelmer

    berndhelmer New Member

    Herzlichen Dank Kolia!
    Das wars! Habe die defekte Datei "iphotoaux.db" auf den Desktop gezogen und umbenannt. Danach die iPhoto-Datenbank neu aufgebaut. Nach dem iPhoto einwandfrei lief die Datei gelöscht, TM gestartet - und siehe da TM machte ein einwandfreies Backup.
    Mir fällt ein Stein vom Herzen!

    Danke!
     

Diese Seite empfehlen