Probleme mit VMWare Fusion 2.0.5 und MS Word

Dieses Thema im Forum "Software" wurde erstellt von ranimus, 20. August 2009.

  1. ranimus

    ranimus New Member

    Hallo,

    Bin nach erstem Scheitern mit Apple iMac in 2008 und Rückkehr zum PC seit Mitte Mai 2009 erneut Switcher von PC auf iMac 2,66 GHz, 4 GB RAM. Bootcamp Partition mit Windows XP, genutzt von VMWare Fusion. Version 2.0.0 war sehr langsam. Das Durchklicken zu meinen shared Folders auf dem iMac und dann weiter zu den einzelnen Ordner-Hierarchien dauerte sehr lange. Zum Teil 20 bis 45 Sekunden. Habe nun upgedatet auf VMWare Fusion 2.0.5, was die Probleme zum Teil noch vergrößert hat, wenn auch manches schneller zu gehen scheint.

    Laden von MS Word: 14 Sek.
    Verbindungsversuch mit host/shared Folders: 10 Sek.
    Anklicken von dem ersten Ordner: Meldung: „MS Visual C++ Runtime Library. Assertion failed. Usw.“ 10 Sek.
    Auswahl Abbrechen, Wiederholen oder Ignorieren.

    Wiederholen oder Ignorieren führt zum nächsten Unterordner. Laden: 11 Sek.
    Auswahl eines anderen Unterordners bringt wieder die Meldung: „MS Visual C++ Runtime Library. Assertion failed. Usw.“ Aber diesmal kommt diese Meldung mehrfach, bis zu 4-fach oder 5-fach. Alle müssen per „Wiederholen“ oder „Ignorieren“ weggeklickt werden.

    Wie kann ich diese lästige Meldung „Assertion failed.“ wegkriegen?

    Dieses Problem hatte ich bei VMWare Fusion 2.0.0 nicht.

    Beste Grüße

    ranimus
     
  2. DominoXML

    DominoXML New Member

    Hi,

    hast Du nach der Aktualisierung von VM-Ware dir VM-Ware Tools aktualisiert bzw. neu installiert? Nur mit den aktuellsten Treiber läuft die Virtualisierung rund.

    LG

    Volker
     
  3. ranimus

    ranimus New Member


    Bei dem Update auf 2.0.5 hat das Programm die VMWare Tools neu installiert. Es wird wohl wenig Sinn machen, sie noch einmal neu zu installieren, da ich das Problem schon einmal hatte. Es ist jetzt mein zweiter Versuch, von 2.0.0 auf 2.0.5 upzudaten, mit dem selben Problem bei MS Word.

    LG

    ranimus
     
  4. DominoXML

    DominoXML New Member

    Ich habe Parallels im Einsatz und kenne mich mit VM-Ware nicht so gut aus.

    Die extrem langsamen Ladezeiten deuten entweder auf einen nicht sauber installierten Treiber, unpassende Einstellungen der VM oder auf eine fragmentierte VM-Partition hin.

    Bei meinen insgesamt drei VM's ist die Geschwindigkeit bei "normalen" Programmen (Office etc.) recht gut, d.h. Word (auch wenn ich es nicht mag) ist in 2-3 Sekunden gestartet.

    Das Einzige was ich Dir anbieten kann ist, daß Du ein mal deine VM.Einstellungen postest und wir hier im Forum diese mit unseren Einstellungen vergleichen.
    Bei Parallels gibt es ein Image-Tool mit dem man Werkzeuge zur Pflege der VM zur Verfügung hat. Gibt es solche auch bei VM-Ware? Eine Deinstallation und Neuinstallation der Tools schadet sicher nicht.

    Edit: Um welches Win handelt es sich? Bei Vista muß man soweit ich weis an ein paar stellen schrauben damit es flutscht.
     
  5. ranimus

    ranimus New Member

    Hallo,

    Einstellungen VMWare Fusion
    1 CPU (mit 2 CPU war das Ergebnis nicht besser)
    2048 MB
    3 Ordnerfreigaben
    AutoProtect deaktiviert
    Netzwerk: NAT (bridged war nicht besser)
    Auf Bootcamp Partition: Windows XP Professional

    Ich vermute inzwischen, dass das Problem mit "Assertion failed" damit zusammenhängt, dass die Version 2.0.5 nicht richtig mit der von mir installierten Software Dragon Naturally Speaking Preferred 10 zusammenhängt. DNS hat eine eigene MS Visual C++ Runtime-Version, ohne die DNS nicht installiert werden kann.

    Beste Grüße
    ranimus
     
  6. DominoXML

    DominoXML New Member

    Assertion failed deutet auf eine "vermackelte" Installation hin. Soweit ich weis bringt DNS eine eigene runtime mit welche erst initialisiert werden muß.
    Klappt das nicht dann versucht die runtime u.U. ständig das "Kommunikationsproblem" zu beheben und zieht dann vermutlich den Rechner runter. In diesem Fall dürftest Du eine recht hohe nahezu gleichbleibende Prozessor-Last verzeichnen.

    Kann gut sein, daß DNS nicht mit VM-Ware kompatibel ist. Ich werde mich mal schlau machen und nach dem Fehler suchen...

    Was könntest Du noch checken? Versuche es mal mit einem neuem Windows-Benutzer-Account. Vielleicht sind ja nur bestimmte persönliche Einstellungen defekt.

    Edit: Also an vm-ware sollte es eigentlich nicht liegen. DNS geht wohl normalerweise recht gut.
    Hast Du bereits den vm-ware support kontaktiert? Habe mit dem Parallels-Support recht gute Erfahrungen gemacht.
     
  7. ranimus

    ranimus New Member

    Hallo,

    danke für Deine Überlegungen und Bemühungen.

    DNS läuft mit seiner speziellen Runtime absolut einwandfrei auf der Bootcamp-Partition, ebenso mit MS Word. An der Installation liegt es m.E. nicht, weil Word einwandfrei unter VMWare 2.0.0 funktionierte - abgesehen von den langen Durchklickzeiten. Die Funktion von DNS war einwandfrei.

    Die Installation von DNS unter VMWare Fusion war meines Erachtens auch einwandfrei. Offenbar greift DNS zum Teil auf unsichtbare Bereiche zurück. Unter VMWare Fusion kann ich die angelegte Sprachdatei unter "C:/ (finde den richtigen Schrägstrich nicht auf meiner Mac-Tastatur) /Dokumente und Einstellungen/ All Users/ Anwendungsdateien/Nuance/Naturally Speaking/Users nicht finden. Auf der Windows-Partition ist das kein Problem.

    Ich habe nur ein Problem mit VMWare Fusion 2.0.5, das bei Word diesen Fehler mit der Runtime und Meldung "Assertion failed" bringt. Bei 2.0.0 tritt dieser Fehler ja nicht auf. Also kann das Problem nur in Verbindung von VMWare Fusion 2.0.5 mit DNS liegen. Das Update auf 2.0.5 wurde von mir vor einigen Tagen gemacht. Um den Fehler mit "Assertion failed" zu beseitigen wurde von mir zuerst die DNS-Runtime gelöscht und dann neu installiert. Keine Besserung. Danach wurde VMWAre deinstalliert und neu installiert von der CD mit 2.0.0. = einwandfreie Funktion. Das erneute Update auf 2.0.5 brachte wieder den Fehler mit der Runtime.

    Ich werde - wenn es meine Zeit erlaubt - mein Problem ins Englische übersetzen und ins Forum von VMWare Fusion gehen. Den Support will ich nicht nutzen, weil er mir zu teuer ist. Ich habe VMWare schon seit Mitte Mai. Der kostenfreie Support ist abgelaufen.

    LG

    ranimus
     
  8. DominoXML

    DominoXML New Member

    Hm, scheint also ein Bug in 2.0.5 zu sein. Du könntest noch z.B. 2.0.4 versuchen.
    Müsste auf der Download-Seite liegen.
    Mir gehen leider erst mal die Ideen aus.

    Sorry und noch einen schönen Abend

    LG

    Volker
     

Diese Seite empfehlen