Prozess-monitor - Frage

Dieses Thema im Forum "Hardware" wurde erstellt von tazmandevil, 16. Februar 2003.

  1. tazmandevil

    tazmandevil New Member

    s dieser "sh" 's sind quer verstreut, besitzen aber alle die übergeordnete Prozess-ID "0" und

    sie erscheinen "ALLE" nicht, wenn ich im Terminal mit dem Kommando "top" (als superuser selbstverständlich) dieselben Prozesse auflisten und ansehen will....

    1. Ist das normal und
    2. was bedeutet der Status "Zombie"? *fürcht* ;-) und
    3. was sind dies wohl für "Prozesse"?
     
  2. tazmandevil

    tazmandevil New Member

    Hmmmmm, seit dem neusten Neustart haben sich diese vielen kleinen "sh" 's verdoppelt... jetzt sind es schon rund 30 Prozesse.... *grübel*...

    sind die bei jemandem von euch auch am laufen, wenn ihr in den Prozess-Monitor seht? *wunder*...
     
  3. disdoph

    disdoph New Member

    Hab hier mal gelesen, dass Zombie-Prozesse solche sind die eigentlich nicht mehr laufen dürften und ohne die Kontrolle des Systems einfach weiter rennen. Im Prozess-Monitor kannst Du die beenden. Hab ich mit mldonkey schon an und ab mal gemacht. Aber auf eigene Gefahr. Bin ganz und gar nicht mit UNIX vertraut.

    Evtl. hat's trotzdem etwas geholfen.

    Grüße

    disdoph
     
  4. tazmandevil

    tazmandevil New Member

    hm, ja, es scheint mir auch, dass die eigentlich gar nicht laufen sollten... merkwürdig find ich einfach, dass der "Prozess-Monitor" die Dinger anzeigt, der Terminalbefehl "top" (als root ausgeführt) jedoch nicht... das löschen funktioniert jedoch komischerweise nur von zweien davon, welche in meinem Administratormodus liefen... die root-prozesse kann ich im Prozessmonitor nicht beenden und im Terminal deswegen nicht, weil es die Deamons nicht findet.... "no such prozess" merkwürdig....

    *grrrr*, ausserdem verfielfältigt sich das "Ding". Nach jedem Neustart tauchen wieder mindestens 14 davon auf und nach ner Weile (20 Min.) werden daraus locker 21.... *grrrrrrrr*....
     
  5. tazmandevil

    tazmandevil New Member

    Himmel nochmal, ich muss ins Bett.... *grübel*... naja, zuvor hab ich noch folgendes rausgefunden:

    1. Es sind jetzt schon 35 Zombiprozesse.

    2. das einzig "aktive" Logfile scheint um die Zeit noch das "console.log" zu sein. (ich bin online)... dieses meldet in etwa alle 10 Sekunden:

    2003-02-17 01:29:03.105 Process Viewer[628] enumerateProcessesAndFetch couldn't scan time

    und alle 5 Minuten:
    ## Component Manager: attempting to find symbols in a component alias of type (imdc/MP42/MSFT)
     
  6. disdoph

    disdoph New Member

    t scan time' hat wohl was mit dem Time-Server bzw. dem Uhrzeitabgleich des Systems mit diesem zu tun.

    Ansonsten kann ich leider nicht weiterhelfen. Denke mal Du bist mir um Lichtjahre voraus.

    Einen schönen Tag noch. Du wirst es schon noch rausfinden.

    disdoph
     

Diese Seite empfehlen