QT-movie als .mp4 exportiert - Safari spielt keinen Ton

Dieses Thema im Forum "Software" wurde erstellt von p.i.t., 16. September 2004.

  1. p.i.t.

    p.i.t. Ural-Silber

    hallo schuschammen

    Ich hab da einen QT-film in DV-PAL. dem habe ich eine tonspur hinzugefügt (ein aif-file). Ich exportiere den clip, ton und bild, aus QT Pro als mp4 mit den Standardeinstellungen. Der mp4-film läuft im Finder und in QT prima.

    Nun möcht ich den aber ins netz stellen: in dreamweaver eine html-datei gemacht mit platziertem mp4 drin. in DW kann man den Film ja schon gucken - kommt aber kein Ton. Vorschau in Safari: nix kommt - nur QT-symbol drin!!

    wenn ich das mp4 direkt in ein safari-fenster ziehe, erscheint nichts! wenn ich das mp4 umbenenne in .mov, erscheint bild, aber nicht ton – Auch bei den steuerelementen am rand fehlt der volume-regler...

    ?? was ist an diesem mp4 falsch ???
     
  2. wm54

    wm54 New Member

    Komisch. Ich hatte letztens irgendwann mal den Quellcode gepostet, wie man ein QuickTime einbindet. Damit müsste es dann (zumindest das Bild, falls der Fehler woanders liegt) in Safari funktionieren.
     
  3. p.i.t.

    p.i.t. Ural-Silber

    ich glaube ich hab den einen fehler - warum es im dreamweaver nicht ging - gefunden. der pfad war zwar richtig, aber safari hat ihn bei der preview nicht gefunden, weil ich die dreamweaver-datei nicht richtig abgesichert hatte.

    wenn ich mir diesen mp4-film näher anschaue ,so gibt mir QT ein paar audiospuren an, von denen ich keine ahnung hab, woher die kommen... (siehe attachment).

    beim exportieren aus QT hab ich jetzt noch ein wenig herumexpierimentiert: statt "Film -> MPEG-4" hab ich "Film -> QuickTime Film" genommen, und die gleichen video- und audioeinstellungen vorgennommen... und gleich .mov statt .mp4 als endung... TADAA... geht plötzlich überall, in safari und in dw...

    seltsame sache das... kann das mal jemand bei euch nachbauen? aus QT ein mp4 exportieren auf diese 2 verschiedenen arten?
     
  4. kawi

    kawi Revolution 666

    Normale sache das.
    das eine ist einfach eine Quicktime Datei (*.mov) die "zufällig" für den audio und Videocodec MPEG4 verwendet (man hätte ja auch zwischen 20 andere Codecs wählen können)

    das direkt exportieren als *.mp4 erstellt aber eine Datei die keine "Quicktime" datei mehr ist sondern ein standardkonformes MPEG4, diese kann man auch mit verschiedenen Playern abspielen und auch auf verschiedenen geräten - nämlich allen Geräten die den abgesegtenen MPEG 4 Standard untersytützen.
    Da MPEG4 für mehr anwendungsgebiete geeigent und angelegt ist als ein einfacher Quicktime Film enthält ein MPEG4 auch mehr Spezifikationen,
    auch wenn diese Spuren keine Informationen enthalten - der MPEG 4 Standard verlangt das sie vorhanden sind. Eine DVD Video hat ha z.B. auch IMMER einen AUDIO_TS ordner, selbst wenn es eine Video DVD ist und der audio TS Ordner leer ist. Der DVD Standard verlangt das vorhandensein und erkennt auch z.T erst daran das es sich bei medium XY um eine DVD handelt.
    So verhält es sich auch mit dem *.mp4
    Wenn du z.B. beim exportieren die Option ISMA unter Kompatiblität auf OHNE stellst sieht dein Ergebniss so aus wie meins.
    das die Spuren vorhanden sind muss dich nicht interessieren, für den Fall eines anderen verwendungszwecks oder zur verwqendung auf anderen externen geräten müssen die vorhanden sein. thats all.
     

Diese Seite empfehlen