Quicktime pro, Audioclip importieren?

Dieses Thema im Forum "Software" wurde erstellt von jensf, 1. Dezember 2003.

  1. jensf

    jensf New Member

    Ich habe mit für eine DVD eine .m2v MPEG2-Datei und die dazugehörende Audiodatei .aiff.

    nun möchte ich im Qucktime pro daraus eine MPEG4-Datei machen.
    aber wie krieg ich die Audiodatei dazu in den player?
    kreig das nicht hin.
    Danke Jens
     
  2. AndreasG

    AndreasG Active Member

    QT kann MPEG2-Material nur lesen (decodieren), wenn die MPEG2-Wiedergabe-Komponente installiert ist. Die bekommst Du bei Apple, sie kostet €25.

    Gruss
    Andreas
     
  3. jensf

    jensf New Member

    die hab ich,
    das bild klappt auch, aber wie komm ich zum ton?
    separate aiff-datei)
     
  4. AndreasG

    AndreasG Active Member

    Ok. Dann sehe ich nur einen Weg: Die AIFF mit ffmpegX nach MP2 (MPEG Audio Layer II) codieren (Voreinstellung "MPEG Audio" oder so ähnlich) und das MP2 mit dem M2V multiplexen (ebenfalls mit ffmpegX). Das AIFF muss aber exakt die selbe Länge haben wie der Film, sonst gibts beim Multiplexen Probleme.

    Dann müsste der Import in QT mit Ton klappen und dem Export nach MPEG4 steht nichts mehr im Weg.

    Gruss
    Andreas
     
  5. jensf

    jensf New Member

    ok, danke
    dachte eigentlich, das ist normal bei mpeg2, dass das audio-file sep. ist.
    oder?
    oder ist das nur, wenn es für ne dvd ist (habe es mit compressor gemacht.)

    ist wahrscheinlich besser, wenn ich das mpeg4 auch direkt da raus mache.

    Dachte nur, in QT geht es schneller (fürs mpeg4 ist die qualität nicht so wichtig)
     
  6. joerch

    joerch New Member

  7. AndreasG

    AndreasG Active Member

    Für das Authoring einer DVD ist es tatsächlich so, dass Audio und Video erst mal getrennt verarbeitet werden. Erst beim Erstellen der DVD (VIDEO_TS) wird dann gemultiplext.

    Für den Export in ein anderes Format braucht QT aber gemultiplextes Material - es sei denn, es gibt einen anderen Weg, aber den kenne ich nicht.

    Gruss
    Andreas
     
  8. jensf

    jensf New Member

    Danke
    alles klar

    Jens
     
  9. jensf

    jensf New Member

    beim import der aiff datei kommt bei ffmpeg eine Fehlermeldung, unbekanntes Format.
    Muss da eine komponene noch installiert werden?
     
  10. AndreasG

    AndreasG Active Member

    ffmpegX kann kein AIFF? Merkwürdig... Hast Du unter Options "Mit QuickTime decodieren" angewählt? Alles, was QuickTime abspielen bzw. anzeigen kann, müsste ffmpegX eigentlich auch decodieren können...

    Gruss
    Andreas
     
  11. jensf

    jensf New Member

    also die option kann ich nicht finden
    habe version 0.0.9a

    gehe bei voreinstellung auf audiodatei zu mp2
    und muss dann bei öffnen die aiff-datei wählen

    und dann bleibt der mplayer schon mal hängen

    im progressfenster steht dann unter info:
    Encoding started on Wed Dec 3 12:36:06 CET 2003
    /Volumes/Macintosh HD2/Filme/Jens.aiff:
    Unknown format
     
  12. jensf

    jensf New Member

    und wenn ich gerne eine mp4 datei hätte, kommt immer nur ne .avi raus?
    die auf QT nicht läuft
    ist das so?
     
  13. AndreasG

    AndreasG Active Member

    Eben nicht mplayer, sondern QuickTime sollte es sein. Unter Options sollte das Kastchen "Mit QuickTime decodieren" angewählt, das mit dem mplayer hingegen abgewählt sein. Oder siehst Du dieses Kästchen gar nicht?

    Hocke leider nicht am Mac, sonst könnte ich es ausprobieren. Ev. musst Du unter Video den mpeg2enc wählen, obwohl Du gar kein Video codieren musst. ffmpegX macht oft ein ziemliches Durcheinander mit den Settings, die zu den vielen Encodern und Decodern gehören...

    Gruss
    Andreas
     
  14. jensf

    jensf New Member

    muss heut abend nachgucken, bin nicht vor dem mac.
    habe es aber nicht gesehen

    habe auf jeden fall die möglichkeit unter video bei der Auswahl mpeg4(ffmpeg) oder mpeg4 (mpeg2enc) zu wählen. mehr glaub ich nicht

    und da kommt dann bei video ein .avi raus

    ist schon irgendwie ein durcheinander
     
  15. AndreasG

    AndreasG Active Member

    Also die Voreinstellung "audiodatei zu mp2" ist schon mal richtig. Nun ev. einfach unter Video den mpeg2enc wählen (und das Häkchen "Video codieren" nicht wählen. Dann sollte "Mit QuickTime decodieren" im Reiter Options wählbar sein.

    Gruss
    Andreas
     
  16. jensf

    jensf New Member

    danke, werde das heut abend mal probieren und mich wieder melden.
    Gruss Jens
     
  17. jensf

    jensf New Member

    die option QT habe ich wirklich nicht
    kann es sein, weil ich noch die demo version habe
    und darum kennt er auch .aiff dateien nicht?
     

Diese Seite empfehlen