Rechner frieren ein!

Dieses Thema im Forum "Software" wurde erstellt von BlueWhite, 3. November 2000.

  1. BlueWhite

    BlueWhite New Member

    verschwinden' zu lassen. Sie werden verstehen, daß ich verärgert bin; denn ich habe ein Jahr lang mit einem teuer erstandenen aber leider werkseitig fehlerhaften Rechner, mein Geld verdienen müssen, was unter den gegebenen Umständen immens Zeit und Nerven gekostet hat. Wer kann schon vernünftig mit einem Rechner arbeiten, der in regelmäßigen Abständen willkürlich einfach einfriert. Hinzu kommen viele Wochen zusätzliche Arbeit bei der Fehlerdiagnose, die ohne die Unterstützung meines Händlers gar nicht möglich gewesen wäre, von den entstandenen Kosten durch die Reise nach München - 650 km hin, 650 km zurück - oder der Hotelrechnung ganz zu schweigen, die insgesamt entgangene Arbeitszeit u.s.w....

    ...und das alles nur, um die Reparatur eines von Anfang an fehlerhaften Gerätes zu erzielen?

    Was auch immer Sie mit diesen Informationen anfangen mögen, welche Möglichkeiten oder Kontakte auch immer Sie haben, eventuell auf Apple einzugehen; ich jedenfalls muß meiner Enttäuschung einmal Luft machen - diese Mühen waren wohl umsonst. Meine -ansonsten unbekümmerte- Begeisterung bezüglich der Firma Apple hat durch diese Erfahrung merklich abgenommen und es würde mich nicht wundern, wenn andere Apple User ähnlich reagieren würden...

    Über eine Stellungnahme würde ich mich freuen und verbleibe
    mit freundlichem Gruß

    ...

    P.S.: Sie können das o. g. Testskript im Internet downloaden unter: www.pwsonline.com/g3g4testskript.sea oder www.pwsonline.com/testskript.sit
     
  2. Heiko

    Heiko New Member

    Nachdem ich mir das Script heruntergeladen und an einer Neuinstallation auf einer frisch initialisierten Platte getestet habe, kam es "natürlich" gleich beim 3. Durchlauf innerhalb des Scripts zum Einfrieren! ÄRGER!

    Konfiguration:
    OS 8.6
    G3/350 B+W
    Mainboard Rev. 2 (neue Vers. des U-ATA-Controlers (646U2-402))
    RAM:
    64MB (Original Apple 3-2-2)
    128 MB (Original Apple 3-2-2)
    128 MB (vom PC-Höker: ???)
    HD:
    Master: 40GB Maxtor 54098U8
    Slave: 6GB Quantum Fireball EX6.4A
    CD:
    Matshita CR-589 (Apple)
    ZIP:
    Iomega Zip 100
    Monitor:
    Studio Display 17 B+W

    Außer dem Monitor, Tastatur + Maus waren alle anderen Geräte abgezogen.

    Allerdings habe ich dann auch noch einmal etwas herumexperimentiert und interessante, vielleicht sogar neue Beobachtungen gemacht!

    Wieder zurück auf dem normalen Startvolume habe ich nur den Cacheprofiler seperat per Maus gestartet:
    Beim 1. mal wurde er geöffnet, allerdings mit einer merkwürdigen Verzögerung!
    Beim 2. mal sofort CRASH !!!!
    (Wenn ich die Prefs vom Cacheprofiler lösche, nachdem ich ihn 1x gestartet habe, kann ich ihn ein weiteres mal starten!)
    Dann das Testprogramm laufen gelassen: CRASH

    Jetzt das vielleicht neue:
    Wenn nur EIN USB-Gerät (Tastatur ODER Maus) am Rechner hängt, läuft das Testprogramm problemlos durch, ich habe es hintereinander 10x gestartet, KEIN crash!!!!!
    Selbst wenn ich mein System mit allen Erweiterungen (152!) und allen Zeichensätzen (119!) geladen habe: NUR mit Maus ODER Tastatur: KEIN CRASH!!!

    Aus diesen Beobachtungen schließe ich, das das Hauptproblem am USB-Controler liegt!
     
  3. BlueWhite

    BlueWhite New Member

    Hallo Heiko,

    ertsmal Danke für Deine umfangreichen Tests. Hört sich interessant an! Wir werden der Sache mit den USB Geräten, so wie Du sie beschrieben hast, auch mal nachgehen...
     
  4. Heiko

    Heiko New Member

    Ich habe mir schon gedacht, das bei den unterschiedlichen Rechner nicht auch immer die Tastaur + Maus abgenommen wurde bzw. immer die gleiche verwendet wurde, da kommt man ja kaum drauf.
    Nach ein wenig Recherce bei www.xlr8yourmac.com/G3-ZONE/ habe ich Berichte über Probleme mit den USB-Ports beim G3 BW gefunden, speziell mit der VERLÄNGERUNGSKABEL der Tastatur!
    Gerade eben mit vollem System (alle Erweiterungen/Zeichensätze) mal ohne Verlängerungskabel versucht und Maus + Tastatur dran: Kein crash!
    Dann zusätzlich ISDN Acer T50 über passives Hub: kein crash!
    Dann noch Scanner + Drucker (auch über dieses Hub): kein crash!
    Nach einem Restart mit eingeschalteten USB-Geräten (Drucker + Scanner tauchen dann im Systemprofiler doppelt auf!): CRASH
     
  5. BlueWhite

    BlueWhite New Member

    Prozessorboards' läuft der betreffende G3 wie eine Eins; alle sonstigen Komponenten sind jedoch gleich geblieben - auch die Hauptplatine!
    Ich vermute, daß der Defekt schon mit dem Prozessorboard zusammenhängt; der nach dem Austausch funktionierende Rechner belegt dies ebenso wie die Aussage der Apple-Techniker. Allerdings scheint gerade das Zusammenspiel mit dem USB-Controller bzw. diversen Schnittstellenchips durch den Fehler betroffen zu sein, was auch die häufig auftretenden Probleme beim Internetzugang (über USB) zeigen.
     
  6. Kuulest

    Kuulest New Member

    Ich verstehe das Problem nicht ganz: Du hast mit dem Tool von Powerlogix das Verhältnis Prozessor/Backside-Frequenz geändert? Ich habe einen PB1400 mit G3-Karte von NewerTech und NT schreibt ausdrücklich, daß man das Verhältnis *auf keinen Fall* auf 1 setzen soll! Selbst 3:2 könnte kritisch werden.
    Wenn das Einfrieren aber auch noch bei harmloseren Verhältnissen auftritt, scheint Motorola in der Tat ein sehr ernsthaftes Problem mit seinen Fertigungstoleranzen zu haben. Wofür spricht, daß das Einfrieren bei einigen Rechnern auftritt und bei anderen nicht. Du hast ja jetzt eine neue Prozessorkarte :) aber wenn Ihr noch einen Rechner mit diesen Mucken auftreiben könnt, setzt die Ratio doch mal ganz runter oder schaltet den Backsidecache ganz aus.

    Gute Nacht, Kuulest

    ps: Daß die lieben MacWelt-Redakteure auch nicht weniger arrogant wie Apple sind, kann ich leider nur bestätigen :-(
     
  7. BlueWhite

    BlueWhite New Member

    speculative adressing oder access' Feature des Prozessors. Denn wird dieses mit Hilfe des Cache Profilers deaktiviert, verschwindet auch der Fehler.
    Daß völlig baugleiche Rechner mit exakt gleichen Konfigurationen unterschiedlich reagieren (manche frieren ein, manche nicht!) läßt eindeutig auf Produktionstoleranzen schließen.
     
  8. Tom

    Tom New Member

    Hallo Bluewhite,
    erstmal herzlichen Dank für deinen heroischen Einsatz beim aufspüren dieses Fehlers. Als Entwickler kann ich mir den "Spass" dabei lebhaft vorstellen &! Dank auch an deinen Händler.
    Ich habe anscheinend auch so einen Problemfall hier stehen: einen iMac Rev. B. Auf meinem iBook läuft das Script problemlos, auf dem iMac steht der Rechner sofort. Deshalb meine Frage: gibt es ein anderes Tool um die "spekulative Address&" Option auszuschalten und damit mehr Stabilität zu gewinnen ? Soweit ich dich verstanden habe, kann man damit das Einfrieren verhindern.
    Ich hoffe dass sich nicht nur die c't sondern auch die manchmal sehr speichelleckende deutsche Mac-Presse dieser Sache annimmt.
     
  9. BlueWhite

    BlueWhite New Member

    disable Speculative Access on Restart' aktivieren!

    Nach einem Neustart (evtl auch PRAM löschen) müßte es funktionieren!
     
  10. Tom

    Tom New Member

    hi, danke für den Tip. Es hat funktioniert. Nachdem das INIT installiert war, war auch der Hänger verschwunden. Heisst das nun, dass mein Recher doch OK ist ? Das reine Installieren des Inits hat bei mir das Problem behoben. Die Einstellung der Optionen scheint keinen Einfluss auf das Problem zu haben. Leider wird aus deiner Beschreibung nicht ganz deutlich ob Du deine Tests immer mit installiertem INIT durchgeführt hast, oder nicht. Das Testscript scheint ja keines zu installieren.
    Gruss Tom
     
  11. chris

    chris New Member

    hallo bluewhite,

    das ganze ist ja wahnsinnig interessant! zum glück tangiert meinen beigen g3 die sache nicht (hab´s ausprobiert) aber: bist du dir sicher, da nicht das rad zum 2. mal erfunden zu haben? soll heissen, hast du schon irgendwelche querverweise aus z.b. englischsprachigen medien eingeholt? immerhin ist ja die us-amerikanische mac-basis viel breiter als hier. vielleicht ist da via internet noch info rauszuholen (per kontakt mit den entsprechenden mac-sites, wie z.b. xlr8yourmac, u. ä.) ?
    grüße
    chris
     
  12. BlueWhite

    BlueWhite New Member

    Veröffentlichung' des Fehlers besteht. Der Ball wird dort immer sehr flach gehalten und Apple verweist auf die Bearbeitung der Fehlerursache in USA. Zugegebenermaßen ist der Fehler trotz des Testskripts etc. nur sehr umständlich nachzuweisen und es kostet schon einige Mühe das Ganze überhaupt zu erklären. Ich stehe noch in Kontakt zu den diversen Apple-Verantwortlichen, habe aber keine großen Erwartungen mehr.
    Naja, mein Rechner läuft ja jetzt auch!
    Wenn Du mit geringen Geschwindigkeitseinbußen bzw. dem INIT leben kannst, wäre mein Tip: Laß einfach das INIT drin und der Rechner ist garantiert um Einiges stabiler!
     
  13. BlueWhite

    BlueWhite New Member

    einfrierfreudig' war und sind so auf die ganze Geschichte gestoßen. Daß das Problem auch ganz neue Apple Rechner betrifft ist sicherlich nicht erfreulich und wir waren genauso erschrocken darüber. Ohne die Hilfe meines Händlers, bzw. die Möglichkeit und Hartnäckigkeit so viele Rechner zu testen, wären wir auch niemals zu dieser traurigen Erkenntnis gekommen.
    Warten wir mal ab, was passiert...vielleicht kommt ja noch eine Reaktion von Apple-USA?...
     
  14. BlueWhite

    BlueWhite New Member

    Wen's noch interessiert....

    im Macnews-Forum geht die Diskussion unter FREEZE weiter...
     

Diese Seite empfehlen