Router und Xdonkey?

Dieses Thema im Forum "Hardware" wurde erstellt von mac_sebastian, 1. Juli 2004.

  1. mac_sebastian

    mac_sebastian New Member

    hallo,
    ich benutze einen Draytek Vigor 2500 zusammen mit der airport base station. über airport hängen 2 rechner am netz.
    internet (mails und surfen) funktioniert perfekt.
    auf dem G3 b/w habe ich jetzt mal Xdonkey ausprobiert, funktioniert auch bis zu einem gewissen zeitpunkt.
    dann bleibt die verbindung stehen bzw. wird beendet und erst wenn man den vigor aus+anschaltet gehts wieder...
    woran kann das liegen?
    ich habe die leerlaufzeit des routers auf 2400 sek. gestellt...
    hat aber nichts gebracht?
    hat jemand tipps??
     
  2. Tsujoshi

    Tsujoshi New Member

    Eventuell die NAT-Einstellungen des Routers überprüfen? Da ich XDonkey nicht kenne würd ich mal die Suchfunktionen in entsprechenden Foren empfehlen.
    :rolleyes:
     
  3. mac_sebastian

    mac_sebastian New Member

    danke!
    was ist denn die NAT funktion?
    auf was für einen wert muss ich die einstellen?
     
  4. Tsujoshi

    Tsujoshi New Member

    NAT=Network Adress Translation
    Dem Router muss gesagt werden an welche IP bzw. an welchen Rechner im Netz die empfangenen Datenpakete geschickt werden sollen.
     
  5. Taipan

    Taipan New Member

    Hi!

    Ich habe zwar einen anderen Router (T-Sinus 154DSL basic), aber bei mir war es auch so, dass der Router bei Benutzung von mldonkey nach einigen Stunden abstürzte. Nach einiger Recherche im Internet kam ich zu der Erkenntnis, dass die Firewall im Router wohl die vielen ins Leere laufenden Verbindungsanfragen als Angriffe interpretiert und dann aufgrund der schieren Menge überfordert ist (scheinbar laufen irgendwelche caches über oder so). Jedenfalls habe ich seit dem Abschalten der routerinternen Firewall keine Probleme mehr. Sicherheitstechnisch ist das vertretbar, da die Firewall nur für ausgehende Verbindungen zuständig ist, da eingehende von der NAT-Funktion gefiltert werden.
     
  6. tobio

    tobio New Member

    Der Vigor ist klasse! und mit der einzigste Router der wirklich vernünftige Einstellungen bietet! Du musst verschiedene Ports auf einen Rechner in Deinem Netz auf dem der Esel läuft umleiten, sonst gibt es immer eine Low ID. Also:

    Unter NAT -> Portumleitungstabelle:

    TCP 4661 + 4662 auf gleichen Port des internen Mac
    UDP 4663 + 4665 " " "


    Viel Erfolg!


    tobio
     
  7. mac_sebastian

    mac_sebastian New Member

    viele dank euch für die tipps, werde mich heute abend mal dran machen...

    @taipan
    mal sehen, ob der router die firewall aktiviert hat (wenn überhaupt eine drin ist...)

    @tobio
    die portumleitung habe ich in der airport-station schon eingerichtet, die ja auch ein router ist.
    also muss ich praktisch die gleichen ports im vigor auch nochmal umleiten auf die IP der airport-station?
    hast du eventuell einen link mit einer liste der ports, die
    freigeschaltet werden müssen?

    danke+grüsse
     
  8. Taipan

    Taipan New Member

    Äh, benutzt den Esel mit diesen Einstellungen erfolgreich? Die sind nämlich falsch, zumindest, wenn xdonkey die gleichen Ports wie mldonkey benutzt.
    Du brauchst für den normalen client nur die Ports 4662 TCP und 4666 UDP, wobei Du den TCP-Port auch in den Einstellungen ändern kannst, der UDP-Port ist dann immer um 4 höher.
    4661 TCP und (wenn ich mich recht erinnere) 4665 UDP braucht man nur für einen mldonkey-Server, den die wenigsten von uns laufen haben dürften.

    Kleiner Nachtrag: Natürlich kommen noch andere Ports dazu, wenn man in mldonkey noch andere Protokolle, z.B. BitTorrent oder Overnet, aktiviert.
     
  9. mac_sebastian

    mac_sebastian New Member

    hallo,
    ich benutze einen Draytek Vigor 2500 zusammen mit der airport base station. über airport hängen 2 rechner am netz.
    internet (mails und surfen) funktioniert perfekt.
    auf dem G3 b/w habe ich jetzt mal Xdonkey ausprobiert, funktioniert auch bis zu einem gewissen zeitpunkt.
    dann bleibt die verbindung stehen bzw. wird beendet und erst wenn man den vigor aus+anschaltet gehts wieder...
    woran kann das liegen?
    ich habe die leerlaufzeit des routers auf 2400 sek. gestellt...
    hat aber nichts gebracht?
    hat jemand tipps??
     
  10. Tsujoshi

    Tsujoshi New Member

    Eventuell die NAT-Einstellungen des Routers überprüfen? Da ich XDonkey nicht kenne würd ich mal die Suchfunktionen in entsprechenden Foren empfehlen.
    :rolleyes:
     
  11. mac_sebastian

    mac_sebastian New Member

    danke!
    was ist denn die NAT funktion?
    auf was für einen wert muss ich die einstellen?
     
  12. Tsujoshi

    Tsujoshi New Member

    NAT=Network Adress Translation
    Dem Router muss gesagt werden an welche IP bzw. an welchen Rechner im Netz die empfangenen Datenpakete geschickt werden sollen.
     
  13. Taipan

    Taipan New Member

    Hi!

    Ich habe zwar einen anderen Router (T-Sinus 154DSL basic), aber bei mir war es auch so, dass der Router bei Benutzung von mldonkey nach einigen Stunden abstürzte. Nach einiger Recherche im Internet kam ich zu der Erkenntnis, dass die Firewall im Router wohl die vielen ins Leere laufenden Verbindungsanfragen als Angriffe interpretiert und dann aufgrund der schieren Menge überfordert ist (scheinbar laufen irgendwelche caches über oder so). Jedenfalls habe ich seit dem Abschalten der routerinternen Firewall keine Probleme mehr. Sicherheitstechnisch ist das vertretbar, da die Firewall nur für ausgehende Verbindungen zuständig ist, da eingehende von der NAT-Funktion gefiltert werden.
     
  14. tobio

    tobio New Member

    Der Vigor ist klasse! und mit der einzigste Router der wirklich vernünftige Einstellungen bietet! Du musst verschiedene Ports auf einen Rechner in Deinem Netz auf dem der Esel läuft umleiten, sonst gibt es immer eine Low ID. Also:

    Unter NAT -> Portumleitungstabelle:

    TCP 4661 + 4662 auf gleichen Port des internen Mac
    UDP 4663 + 4665 " " "


    Viel Erfolg!


    tobio
     
  15. mac_sebastian

    mac_sebastian New Member

    viele dank euch für die tipps, werde mich heute abend mal dran machen...

    @taipan
    mal sehen, ob der router die firewall aktiviert hat (wenn überhaupt eine drin ist...)

    @tobio
    die portumleitung habe ich in der airport-station schon eingerichtet, die ja auch ein router ist.
    also muss ich praktisch die gleichen ports im vigor auch nochmal umleiten auf die IP der airport-station?
    hast du eventuell einen link mit einer liste der ports, die
    freigeschaltet werden müssen?

    danke+grüsse
     
  16. mac_sebastian

    mac_sebastian New Member

    hallo,
    ich benutze einen Draytek Vigor 2500 zusammen mit der airport base station. über airport hängen 2 rechner am netz.
    internet (mails und surfen) funktioniert perfekt.
    auf dem G3 b/w habe ich jetzt mal Xdonkey ausprobiert, funktioniert auch bis zu einem gewissen zeitpunkt.
    dann bleibt die verbindung stehen bzw. wird beendet und erst wenn man den vigor aus+anschaltet gehts wieder...
    woran kann das liegen?
    ich habe die leerlaufzeit des routers auf 2400 sek. gestellt...
    hat aber nichts gebracht?
    hat jemand tipps??
     
  17. Tsujoshi

    Tsujoshi New Member

    Eventuell die NAT-Einstellungen des Routers überprüfen? Da ich XDonkey nicht kenne würd ich mal die Suchfunktionen in entsprechenden Foren empfehlen.
    :rolleyes:
     
  18. mac_sebastian

    mac_sebastian New Member

    danke!
    was ist denn die NAT funktion?
    auf was für einen wert muss ich die einstellen?
     
  19. Tsujoshi

    Tsujoshi New Member

    NAT=Network Adress Translation
    Dem Router muss gesagt werden an welche IP bzw. an welchen Rechner im Netz die empfangenen Datenpakete geschickt werden sollen.
     
  20. Taipan

    Taipan New Member

    Hi!

    Ich habe zwar einen anderen Router (T-Sinus 154DSL basic), aber bei mir war es auch so, dass der Router bei Benutzung von mldonkey nach einigen Stunden abstürzte. Nach einiger Recherche im Internet kam ich zu der Erkenntnis, dass die Firewall im Router wohl die vielen ins Leere laufenden Verbindungsanfragen als Angriffe interpretiert und dann aufgrund der schieren Menge überfordert ist (scheinbar laufen irgendwelche caches über oder so). Jedenfalls habe ich seit dem Abschalten der routerinternen Firewall keine Probleme mehr. Sicherheitstechnisch ist das vertretbar, da die Firewall nur für ausgehende Verbindungen zuständig ist, da eingehende von der NAT-Funktion gefiltert werden.
     

Diese Seite empfehlen