Schrift spinnt - aus ä wird {³

Dieses Thema im Forum "Hardware" wurde erstellt von ibins77, 25. Juli 2003.

  1. ibins77

    ibins77 Gast

    Hilfe....

    wenn ich z.b. via FTP Programm eine Textdatei vom Server auf den MAC hole, diese Datei dann mit dem Texteditor öffne, werden aus ö, ä, ü, ß
    irgendwelche nicht erkennbaren Zeichen. Das gesamte Dokument wird dann durch diesen Mist ersetzt. ;-( Am IBM PC kein Problem...

    Bitte um Tipp, Danke :)
     
  2. Macci

    Macci ausgewandert.

    kein Wunder, dein Server kann mit den Umlauten vom Mac nix anfangen und umgekehrt...deswegen verwendet man ja in Dateinamen z.B. auch keine Umlaute oder Sonderzeichen.
    Kannst du deinem Texteditor evtl. ne andere Textcodierung verpassen (irgendwo in den Einstellungen)?
     
  3. ibins77

    ibins77 Gast

    das hat nix mit dem server zu tun.
    es geht nicht um die benennung der datei, sondern um den inhalt.
    das ganze funktioniert seit 3 jahren einwandfrei mit einem PC, wenn ich aber ein selbst erstelltes php dokument von meinem ftp server auf den mac runter lade, werde diese umlaute (die in einem normalen text durchaus vorkommen) total falsch dargestellt und auch eigenmächtigt geändert. mit einem pc habe ich zeitgleich diese probleme nicht.
    ich will aber weg vom pc...


    verwende X 10.2 neustes update
     
  4. Macci

    Macci ausgewandert.

    das hab ich schon begriffen, dass es um den Inhalt geht...hast du mal Textdateien vom PC direkt auf den Mac geschickt, und dir die Umlaute angesehen? Was glaubst du, weshalb es solche Formate wie PDF gibt, bzw. unterschiedliche Textcodierungen...
    Schreib doch mal, mit welchem Programm du den Text öffnest.
     
  5. ibins77

    ibins77 Gast

    das gleiche problem gibts auch bei eingehenden emails.
    der mac macht aus Ä z.b. %
    ich öffne den text mit TextEdit
     
  6. Macci

    Macci ausgewandert.

    in Textedit kannst du unterschiedliche Codierungen einstellen.
    TextEdit: Einstellungen, da gibts rechts zwei Aufklappmenüs...Öffnen und Sichern.
    Wenn du da eine andere Kodierung (z.B. Windows Latin 1 oder Unicode) auswählst, sollte auch die Umlaute richtig dargestellt werden.

    für Mail gibt es diese Einstellungen leider nicht...
     
  7. kawi

    kawi Revolution 666

    > das gleiche problem gibts auch bei eingehenden
    > emails. der mac macht aus Ä z.b. %


    Also mails hab ich da noch nie beobachten können, es sei denn der Abseder stammt aus dem Ausland und sendet seine mails in einer anderen Formatierung. Auch hier gibt es verschiedene Textformat Standards Western (Latin1) Western (Mac) Western (Win) cyrillisch (ISO 8859-5)

    Vielleicht solltest du das mal checken in deinen maileinstellungenm ... oder der Absender

    Für php oder html daten die man auf einen ftp server schiebt gibt es übrigens auch einen standard
    ä = ä
    ö = ö
    ü = ü
    ß = ß
    ect ...

    begründet vor allem darin das Umlaute eben nicht international sondern spezifisch deutsch sind.
     
  8. Macci

    Macci ausgewandert.

    @kawi: wo kann man Textformatierungen in Mail einstellen? Hab ich da auf die Schnelle was übersehen?
    und was meinst du damit:"Für php oder html daten die man auf einen ftp server schiebt gibt es übrigens auch einen standard
    ä = ä
    ö = ö
    ü = ü
    ß = ß
    ect ... "?
    Ist wahrscheinlich durch die Forumssoftware verhunzt worden...;)

    TEST: ä das war ein html-ä

    genau, liegt am Forum :D
     
  9. kawi

    kawi Revolution 666

    > wo kann man Textformatierungen in Mail
    > einstellen?

    ähem ... was war mail nochmal? Achso, das Teil was ich wegen unzulänglichem Funktionsumfang und widerwärtigem Verhalten meinen mails gegenüber seinerzeit verbannt habe ... keine Ahnung was mail betrifft...


    > ä = ä
    > ö = ö
    > ü = ü
    > ß = ß
    > ect ... "?
    > Ist wahrscheinlich durch die Forumssoftware
    > verhunzt worden...

    ach shit ... da wird der code tatsächlich gleich in den Umlaut verwandelt
    also
    ä = & a u m l ;
    ö = & o u m l ;
    ect ... (ohne leerzeichen)
     
  10. ibins77

    ibins77 Gast

    vielen dank euch allen, textedit läuft:D

    schönes wochenende...

    P.S. der schlüsselbund verliert andauernd die passwörter...
     
  11. Macci

    Macci ausgewandert.

    das ist ein anderes Thema, solltest mal versuchen, die Zugriffsrechte zu reparieren...findest du auch irgendwo hier im Forum
    ;)
     
  12. sissifan

    sissifan New Member

    >> In Textedit kannst du unterschiedliche Codierungen einstellen.
    TextEdit: Einstellungen, da gibts rechts zwei Aufklappmenüs...Öffnen und Sichern.
    Wenn du da eine andere Kodierung (z.B. Windows Latin 1 oder Unicode) auswählst, sollte auch die Umlaute richtig dargestellt werden. <<

    Hab das Problem ebenfalls und das mit dem Windows Latin gerade eben probiert; funktioniert bei mir aber nicht.

    Wenn ich die url dieses Themas auf den Schreibtisch ziehe, dann sieht das ganze bei mir so aus:

    - Schrift spinnt - aus ?§ wird {¬?
     
  13. Macci

    Macci ausgewandert.

    Ja, das sieht bei mir genauso aus, liegt in dem Fall am Finder...denn in dem wird ja die Schreibtischdatei verwaltet.
    Und das lässt sich nicht ändern...:(
     

Diese Seite empfehlen