SCSI-Controller für G4

Dieses Thema im Forum "Hardware" wurde erstellt von Harry Caul, 4. Mai 2004.

  1. Harry Caul

    Harry Caul New Member

    Hallo,

    ich bräuchte mal eine Empfehlung von Euch:

    Ich habe schnelle 2 UW-SCSI-Seagate-Platten, die ich jetzt gerne am G4 als Software-RAID betreiben würde.

    Welcher Controller macht das anstandslos unter Panther im G4? Es sollte sich außerdem um eine preiswerte Lösung handeln.

    Gruß
    Harry
     
  2. AndreasG

    AndreasG Active Member

    Es gibt nur noch Adaptec und Atto, die solche Controller anbieten.

    Atto soll die bessere Treiberunterstützung bieten. Ich selber habe die Adaptec 29160, und die läuft auch unter Panther 10.3.3 problemlos - na ja, hatte zwar immer mal wieder einige Querelen, aber das liess sich bisher immer lösen.

    Preiswert sind U2W bzw. U160-Karten aber auf keinen Fall. 400 Euro kosten die sowohl bei Atto als auch bei Adaptec. Ev. nach gebrauchten suchen.

    Gruss
    Andreas

    P.S: Booten kannst Du bei Soft-RAID nur mit Mirrored-, nicht aber mit Striped-Arrays.
     
  3. Harry Caul

    Harry Caul New Member

    Hallo Andreas,

    Dank für Deine schnelle Antwort. Es scheint mir auf die Adaptec 29160 hinauszulaufen, da die ATTO UL3s kaum zu bekommen ist. Aber welcher Art waren denn Deine Querelen unter 10.3.3? Und wie konntest Du sie lösen?

    Gruß
    Harry
     
  4. Harry Caul

    Harry Caul New Member

    Hallo Andreas,

    ich muß jetzt, nachdem ich mich etwas schlau gemacht habe, noch mal bei Dir nachhaken.

    Für die Adaptec 29160 habe ich bei Adaptec keine Informationen dazu gefunden, daß sie überhaupt mit OS X zusammenarbeitet. Alle anderen Betriebsysteme scheinen dagegen unterstützt zu werden. Über Versiontracker habe ich aber eine Treiber-Beta der Versionsnummer 1.3.0b1 gefunden. Soll wohl unter Jaguar laufen, aber ob Panther ebenfalls unterstützt wird, wird nicht eindeutig ersichtlich.

    Wie hast Du Deine zum Laufen bekommen?

    Gibt es eine spezielle Mac-Version der Karte, die sich hardwaremäßig von der PC-Version unterscheidet? Oder ist das bloß eine Frage des Treibers?

    Für meine Ultra 160 SCSI-Platten muß ich, wenn ich es richtig verstehe, darauf achten, die 29160 und nicht die 29160N oder LP zu bekommen, richtig?

    Sorry, daß ich Dich so löchere. (Es ist auch jeder andere, der in dieser Frage kompetent ist, eingeladen zu antworten.

    Danke und Gruß
    Harry
     
  5. AndreasG

    AndreasG Active Member

    Also: Du brauchst die PowerDomain 29160, nicht die AHA29160. Letztere ist die PC-Version und läuft meines Wissens nicht im Mac, obwohl sie von der Hardware her vermutlich absolut identisch ist, aber eine andere Firmware hat, die sich nicht umflashen lässt. Adaptec weiss schon, warum. Die PowerDomian kostet vermutlich mehr als das PC-Pendant.

    http://www.adaptec.com/worldwide/pr...ml?cat=/Technology/Macintosh&source=home_menu

    OSX unterstützt seit 10.1.x diese Karte nativ, d.h. die Treiber (natülich von Adaptec) liefert Apple mit OSX bereits mit. Einstecken und loslegen, wie man sich das am Mac gewohnt ist. Es gibt unter OSX halt kein Kontrollfeld mehr wie unter OS9, das hat Apatec ganz einfach eingestellt. Nun kann man nichts mehr parametrieren, aber das müssen 99.9% der Anwender auch gar nicht.

    Die Problemchen: Apple liefert manchmal veraltete Treiber mit OSX mit, manchmal aber auch neue, die Adaptec noch nicht mal zum Download anbietet. Man muss einfach aufpassen, ob man nun den Treiber von der Apaptec-Seite über den von OSX drüberinstallieren soll oder nicht. Wichtig ist hier einfach der Grundsatz: Erst mal mit den von Apple mitgelieferten Treibern arbeiten. Erst, wenn es Probleme gibt, die Treiber von Adaptec drüberladen.

    Bei Panther 10.3.0 wurde z.B. aufgrund eines Fehlers von Apple ein uralter Beta-Treiber geliefert. Erst mal lief nicht mehr viel, erst der neue Treiber von Adaptec konnte die Karte wieder zum laufen bringen. Dann gab es beim Update von 10.3.2 auf 10.3.3 das Problem, das die Karfte in meinem Mac nach einem Neustart manchmal nicht mehr erkannt wurde. Ich musste den Mac vollständig ausschalten. Merkwürdigerweise trat dieses Problem nur 3 oder 4 mal auf, heute "übersteht" sie den Neustart zuverlässig wie immer. Keine Ahnung, was das war. Vielleicht auch ein Fehler meinerseits, ev. ein Durcheinander im PRAM, wer weiss.

    Dann hatte ich mit einer U2W-Platte von Fujitsu das Problem, dass die unter OSX nur im sehr langsamen 8-Bit-Mode angesteuert wurde, was ca. 4x langsamer als U2W (16 Bit) ist. Unter OS9 hingegen liefen die Platten mit maximaler Geschwindigkeit.

    Dieses Problem kannte Apple und Adaptec gleichermassen, beide schoben sich die Schuld in die Schuhe bzw. verwiesen auf Fujitsu, da der Fehler eigentlich in der Firmware zu suchen sei. Das betraf aber nur einige wenige Platten, heute habe ich U160-Platten, und die laufen mit voller Geschwindigkeit.

    Dann ist es halt so, dass Apple fast mit jedem OSX-Update irgendwas an SCSI rumschraubt. Mit dem Resultat, dass vor allem mein SCSI-Scanner immer mal wieder auf ein Update von VueScan warten muss. Das ist aber weniger ein Problem von Adaptec als vielmehr von Apple. Die Harddisks liefen hingegen immer, hier scheint die SCSI-Spezifikation wohl sattelfest zu sein.

    So, das sind meine Erfahrungen mit der 29160, die ich seit April 2002 gemacht habe. Grundsätzlich arbeitet die Karte zuverlässig. Adaptec entwickelt halt nicht mehr mit Hochdruck an ihren Mac-Produkten, aber SCSI ist leider auch kein wichtiger Sektor mehr für Adaptec.

    Zu sagen ist noch, dass der Adaptec-Support relativ schnell und freundlich (auf Deutsch) reagiert, die Problemlösung allerdings meist erst nach mehrmaligem Nachfragen gefunden werden kann. Aber immerhin, sie antworten. Das ist schon sehr viel wert.

    Gruss
    Andreas
     
  6. AndreasG

    AndreasG Active Member

    Nachtrag: Der Unterschied zwischen 29160 und 29160N ist nur der Stecker: Die N (Narrow) verwendet nicht den U160 (LVD-) Stecker und passt somit nicht zu Deinen Harddisks. Die LP gibts für den Mac gar nicht.

    Der Beta-Treiber von Adaptec ist übrigens wieder neuer, als der, der mit 10.3.3 mitkommt. Er behebt ein Problem, das nur auf G5 im Zusammenhang mit riesigen Platten relevant ist. Ich verwende aber diesen Beta-Treiber nun seit 10.3.3 und habe damit absolut keine Probleme mit meinem G4/933. Der OSX-Treiber würde es aber ebenso tun.

    Gruss
    Andreas
     
  7. AndreasG

    AndreasG Active Member

    Und nochmals Nachtrag:

    Kennst Du Dich mit SCSI eigentlich gut aus? Wenn ja, hast Du sicher bereits die passenden Kabel und Terminatoren.

    Wenn nein, musst Du noch berücksichtigen, dass Du spezielle und relativ teure LVD-Kabel und einen aktiven LVD-Terminator brauchst. Auch die sind nicht gerade billig. LVD-Platten haben nie Terminierung "on board", die ist immer extern.

    Gruss
    Andreas.
     

Diese Seite empfehlen