Seit Tiger: Java Performance mit Eclipse sehr schlecht

Dieses Thema im Forum "Software" wurde erstellt von vf47, 17. Juni 2005.

  1. vf47

    vf47 New Member

    Ich benutze Eclipse zum Entwickeln von Java Software. Seit ich Tiger aufgespielt habe, bricht nach einigen Minuten die Performance extrem ein.

    Selbst auf meinem Dual G5 mit 2 GByte Hauptspeicher wird selbst das Tippen in Eclipse zur Qual. (So ca. 2 Buchstaben pro Sekunde) Auf meinem Powerbook 1GHz wirkt sich dieser Effekt natürlich noch extremer aus.

    Bis 10.3.9 konnte ich mit Eclipse ausgesprochen flüssig arbeiten. Ich habe Eclipse 1GByte Heapsize zugeteilt und das Programm war ausgeprochen fix. (Ebenso auf meinem Powerbook, wo ich den Heapsize etwas weniger großzügig eingestellt habe).

    Nach einem Neustart von Eclipse bleibt es wieder für einige Minuten schnell, dann bricht erneut die Performance ein. Ich habe testweise auf Java 1.5 umgeschaltet, aber auch dort bleibt dieser Effekt.

    Was mich nur irritiert ist:
    Es ist unabhängig von der Java Version.
    Es ist das gleiche Eclipse wie unter 10.3.9. (Version 3.0)
    Auch mit Eclipse Version 3.1 RC2 bleibt das Problem bestehen.
    Es tritt nur unter 10.4 (10.4.1) auf, nicht unter 10.3.9.

    Meine Frage:

    Gibt es Leidensgenossen? Hat jemand von Euch diesen Effekt ebenfalls beobachtet? Kennt gar jemand eine Lösung?

    Bin für jeden Hinweis dankbar.
     
  2. vf47

    vf47 New Member

    Ich muss den Thread noch mal hochschieben :embar:

    Hat den keiner dieses Problem?
     
  3. DALMARE

    DALMARE New Member

  4. Mäkki

    Mäkki New Member

    JavaScript hat nur leider gar nix mit Java zu tun...
     
  5. MacGenie

    MacGenie Quad Mac User

    Java 5 für Mac OS X kommt bald.

    Dann sollte das Problem gelöst sein ...
     
  6. hofmeyer

    hofmeyer New Member

  7. vf47

    vf47 New Member

    Der von mir oben beschriebene Effekt tritt auch mit Java Version 1.5 auf.

    Wäre es von der Betriebssystemversion unabhängig, so würde ich sagen, dass Java ein GC-Problem hat. Irgendwas an Tiger bremst die JVM aus (oder eher den Garbage-Collector).
     
  8. hofmeyer

    hofmeyer New Member

    Also, ich habe hier den aktuellen Milestone (3.1 RC3) und der läuft so weit ich das beurteilen kann auf meinem Powerbook ganz o.k. Ist halt etwas zäh, aber das ist Eclipse auf anderen Plattformen auch, Java halt. Die heftigen Performanceeinbrüche kann ich nicht nachvollziehen. Ich hatte es auch mal kurzzeitig unter 10.3.x laufen, und kann da jetzt keinen Unterschied zur Geschwindigkeit unter 10.4.1 bemerken.
     

Diese Seite empfehlen