single user mode - problem!

Dieses Thema im Forum "Software" wurde erstellt von sorbitt, 20. November 2005.

  1. sorbitt

    sorbitt New Member

    guten abend! ich stehe vor folgendem problem:

    ich möchte fsck laufen lassen, doch es passiert folgendes: ich lasse über den single user mode starten (imac g5 2,0 neuestes update), als letztes steht dann:

    If you wish to boot the system, but stay in single user mode:
    sh/etc/rc
    localhost:/root#

    und der lüfter fährt und bleibt auf vollast. die tastatur ist blockiert, eine eingabe demnach nicht möglich. (normalerweise hängt eine bt-tastatur dran, die ich aber für diesen zweck gegen eine usb vor dem neustart ausgetauscht habe. kann mir eigentlich nicht vorstellen, dass hier ein problem liegt).

    wäre für eine übersetzung und lösung sehr dankbar! (diese dos-alike-geschichten sind und bleiben mir unheimlich)
     
  2. sorbitt

    sorbitt New Member

    danke für den hinweis.

    aber: hat noch jemand eine idee, warum über die tastatur keine eingabe möglich ist?
     
  3. Bathelt

    Bathelt New Member

    Hast du die USB Tastatur noch vor dem Neustart angesteckt?

    Probiere einmal den Parameter Ram zurücksetzen

    Einfach beim starten "ALT" + "APFEL" + "P" + "R" gleichzeitig halten bis nocheinmal ein Systemgong hörbar ist.
     
  4. sorbitt

    sorbitt New Member

    usb-tastatur habe ich natürlich vor dem neustart eingesteckt und auch der PRAM-reset hat nichts bewirkt:

    nach apfel+s stoppt die textlawine mit den oben angegebenen zeichen und der lüfter röhrt, eine eingabe nicht möglich ... nur der aus-/einschaltknopf macht dem ein ende.

    das sieht doch nicht seriös aus ...
     
  5. Bathelt

    Bathelt New Member

    Habe das gerade noch einmal auf einem alten iMac ausprobiert -

    If you wish to boot the system, but stay in single user mode:
    sh/etc/rc
    localhost:/root#

    - steht auch dort...

    wenn ich dann fsck -fy eingebe funktioniert es bei mir.

    warte einfach einmal - evtl. arbeitet der Rechner noch...
     
  6. sorbitt

    sorbitt New Member

    danke für deine mühe, hab aber schon etliche minuten gewartet unter dem gedröhne der lüfter und es tat sich nichts weiter. was mich nämlich zusätzlich besonders irritiert ist das hochfahren der lüftung ...
     
  7. Bathelt

    Bathelt New Member

    kanns das sein...

    Löschen der open Firmeware Startinformation

    Dazu startet man den Rechner neu und hält sofort nach dem Startton die Tasten Befehl-Wahltaste-O-F gedrückt. Der Mac startet dann nicht das Betriebssystem von der Festplatte, sondern nur dessen Lademechanismus Open Firmware. Dann tippt man die drei Befehle "reset-nvram", "set-defaults" und "reset-all" ein (jeweils ohne Leerzeichen und jeweils abgeschlossen durch die Eingabetaste). Da dabei die englische Tastaturbelegung aktiv ist, erreicht man den Bindestrich über die Taste "ß". Nach dem dritten Befehl startet der Mac neu.
    Bei Methode 2 werden allerdings alle Startinformationen gelöscht, was zur Folge hat, dass der Mac mitunter die richtige Festplatte zum Start des Rechners nicht mehr findet. Tritt dieses Problem auf, muss man den Rechner von der Installations-CD oder -DVD starten (Neustart; sofort nach dem Einschaltton die Taste "c" drücken und halten) und das Installationsprogramm starten. Nach der Frage zur Standardsprache kann man im Installationsprogramm über das Menü "Dienstprogramme > Startvolume" wieder die richtige Festplatte zum Start des Rechners auswählen.
     
  8. sorbitt

    sorbitt New Member

    nochmals danke - aber ich scheue mich etwas, diesen schritt aufs geratewohl zu gehen. wenns aber der einzige weg sein sollte ...

    jemand noch ne idee?
     
  9. sorbitt

    sorbitt New Member

    bitte nochmals um mithilfe:

    gibt es noch einen anderen möglichen weg, die tastatureingabe zu ermöglichen, oder bleibt nur die idee vom löschen der of-startinformation?
     

Diese Seite empfehlen