Spotlight tot !

Dieses Thema im Forum "Software" wurde erstellt von garymueller, 15. Mai 2005.

  1. garymueller

    garymueller New Member

    Habe vorhin gerade eine suchabfrage gestartet, bereits nach dem ersten buchstaben bekam ich einen beachball, der auch nach mehreren minuten nicht wegging, also hab ich den finder gecrashed und nochmal ne neue suche gestartet-> selbes ergebnis.
    daraufhin hab ich mich neu eingeloggt und seitdem sucht spotlight gar nicht mehr. nach eingabe dreht sich kurz das schwarze strich-rädchen, dann steht es still, die suchabfrage steht noch in der eingabezeile, aber es werden keine ergebnisse mehr angezeigt. nichtmal der text "keine ergebnisse gefunden" wird noch angezeigt. war's das ?
     
  2. garymueller

    garymueller New Member

    nachtrag:

    zu allem überfluss krieg ich jetzt auch nen beachball, wenn ich auf eine beliebige datei klicke und dann "apfel+i" wähle...
    kann dann nur mehr den finder crashen !
    was soll denn das ?
     
  3. mac_the_mighty

    mac_the_mighty New Member

    Das klingt aber ziemlich brutal! Hast Du in neuester Zeit irgendwelche Veränderungen vorgenommen? Neue Programme installiert, oder irgendwelche Tools oder mit Schriften gespielt? Vielleicht kann man so das Problem einkreisen.
     
  4. CosmicAlien

    CosmicAlien New Member

    Spotlight hat bei mir auch rumgezickt und ständig ca. 30-40% CPU genommen, die Ergebnisse waren langsam und unvollständig.

    Boote mal neu, es gibt da einen Task "mds", wenn der spinnt geht Spotlight nicht mehr.


    Ich mußte 10.4 neu installieren (archiev und install), erst seit dem geht es (einigermaßen)

    Insgesamt ist mit 10.4 der Rechner träger geworden. Ohne Spotlight geht nicht einmal eine einfache Suche im Mailprogrgramm :/
     
  5. garymueller

    garymueller New Member

    hallo mighty,

    der witz ist, dass gestern abend alles noch so funktionierte, wie man es von tiger eben gewohnt war (dass alles einwandfrei funktioniert, möchte ich mal jetzt nicht so lapidar sagen). heute morgen ging plötzlich gar nix mehr.
    ich habe jetzt mal das festplattendienstprogramm von der DVD angeworfen, das auf der festplatte konnte ich erst gar nicht mehr aufrufen, es kam nur noch der beachball...
    zugriffsrechte + volume repariert, ergebnis: der volume-header war beschädigt und konnte repariert werden.
    ich werde jetzt mal testen, wie das ganze läuft...
     
  6. uscher

    uscher New Member

    Festplatten neu indizieren hat auch nichts gebracht.
     
  7. QNX

    QNX New Member

    Was mir aufgefallen ist, das Spotlight bei mir die Festplatte neu indexiert hat.

    Aber es funktioniert ganz normal bei mir.
     
  8. uscher

    uscher New Member

    Spotlight wird ja nicht über Startobjekte gestartet. Finde zumindest nichts da drinnen.
     
  9. uscher

    uscher New Member

    Mit Tiger Cache Cleaner.
    Dagibt es im Menü eine Option:
    Spotlight zurücksetzen. Festplatten werden danach neu indiziert
    und Spotlight geht be mir wieder.
     
  10. rootzone

    rootzone New Member

  11. uscher

    uscher New Member

  12. hannibal

    hannibal New Member

    tja, ich hatte auch nach der Installation vom Tiger die Gelegenheit mich ein paar Tage mit Spotlight auseinandersetzen zu dürfen.

    Bei mir war das Problem, neben meinem für diese Technologie etwas zu langsamen Rechner (G4 867), daß ich eine externe Firewireplatte mit 2 Partitionen angehängt habe.

    Spotlight indiziert diese dann gleichzeitig, was offenbar zu Korruptionen der Indexdateien führen kann.

    Das habe ich dann so gelöst (Variante ohne Terminal):
    Alle Volumes in den Spotlighteinstellungen in "Privatsphäre" ziehen.
    Dadurch werden erst einmal alle Indices wieder gelöscht.
    Einstellungen schließen und wieder öffnen.
    Das erste aus der Liste wieder entfernen und Einstellungen schließen.
    Jetzt wird dieses Volume indiziert.
    Warten, bis das fertig ist und mit den anderen auch so verfahren.
    In der Aktivitätsanzeige kann man dann verfolgen wie der Prozeß "mdimport" sich die meiste CPU holt und die Indizierung vollführt.
    In der Anzeige rechts unten sieht man dann einen großen blauen Bereich. Das sind die sogenannten "nice" Prozesse. Dh. sobald man etwas anderes macht auf dem Rechner gehen die rapiede wieder runter. Was heißt, sobald man am Rechner arbeitet, verlängert das die Indizierungszeit rapide und kann wie in meinem Fall auch zu Korruptionen der Indices führen.

    Da ich den Fehler gemacht hatte einfach zu viel zu arbeiten während der Indizierung habe ich es bei dem letzten Versuch einfach gelassen und nach und nach alle Volumes nach obiger Methode indizieren lassen ohne dann am Rechner groß was zu machen.

    Was am längsten bei mir gedauert hat bei der Indizierung waren die Fonts. Dafür wird nähmlich ein neuer Prozeß gestartet, der aber nicht nice ist (dh. währenddessen kann man wirklich nicht mehr am Rechner arbeiten). ATSServer hieß der und nahm mir schlappe 70 bis 80% der CPU weg. Wobei der mdimport dann auf 6% runter ging.
    Da dies mehrere Stunden dauerte, hatte ich hier öfter den Prozeß unterbrochen, weil ich dachte, da stimmt was nicht. Was hat die Schriftverwaltung mit 80% cpu auf meinem Rechner zu schaffen, wenn ich gar nix dran mache? Bis ich verstanden habe, das mdimport um die tausenden von Schriften die ich habe, indizieren zu können eben diesen ATSServer öffnen muß, der laut Dokumentation für die Schriftverwaltung zuständig ist.

    Nach dem ich dann alle Volumes nach und nach habe indizieren lassen, gings dann ganz gut.
    Im Terminal kann man dann folgendes zur Überprüfung eintippen:

    sudo mdutil -s /Volumes/DeinVolume

    Die Option -s zeigt den Status an.
    ( mdutil can be used to manage the metadata stores used by Spotlight.
    -p publish metadata for the provided volumes.
    -i (on|off) set indexing status for the provided volumes.
    -E erase the master copy of the metadata stores for the provided volumes.
    -s print indexing status for the provided volumes.)

    Für eins meiner Volumes bekomme ich immer noch folgende Meldung:

    Error: Could not get indexing status for volume.

    Spotlight geht aber dennoch auf diesem Volume. Habe nicht rausgefunden worans liegt. Die anderen werden als OK angegeben.

    (so, hier folgte noch ein längerer Monolog über all die Sachen, die mich bei Spotlight nerven. Hab ich jetzt aber gelöscht, weil der Thread dann etwa 5 Meter lang sein würde)
     

Diese Seite empfehlen