TCP/IP-Netzwerk und Aliasse

Dieses Thema im Forum "Software" wurde erstellt von jowe, 28. Oktober 2002.

  1. jowe

    jowe New Member

    Moin, moin,

    wer kennt folgendes Problem (ich muss leider ein klein wenig ausholen).

    Um nicht immer über die Auswahl zu gehen, erstelle ich ein Alias eines Netzwerk-Volumes und mit einem Klick gibts sofort das Benutzer-/Kennwortfenster.

    Gibt es mehrere volumes auf einem Server habe ich mir auch mehrere Aliasse angelegt. Und wenn ein Volume aktiviert ist, öffnen die anderen Volumes natürlich auch gleich ohne Benutzer-Nachfrage.

    Jetzt tritt aber das Problem auf, wenn ich z. B. Volume1 auf dem Server geöffnet habe und jetzt Volume2 über das Alias öffnen möchte wird wieder Volume1 geöffnet.

    Das Problem ist sehr deutlich mit der Datei-Information zu verfolgen:

    Nach dem frischen Anlegen der Aliasse sind die Datei-Informationen korrekt und verweisen auf die verschiedenen Volumes. Trenne ich jetzt die Verbindung und verbinde erneut mit dem Alias für Volume1 öffnet sich korrekt Vol1, wenn ich jetzt auf das Alias für Vol2 klicke öffnet sich Vol1 und die Datei-Info für Alias 2 wird geändert auf Vol1.
    Ändere ich die Öffnen-Reihenfolge, wird erst korrekt Vol2 geöffnet und das Alias für Vol1 wird geändert.

    Das Problem kenne ich schon länger und konnte es bis jetzt umgehen, indem die Aliasse nicht auf dem Schreibtisch erzeuge, sondern aus dem Netzwerk-Browser heraus. Da wir jetzt aber auf TCP/IP umgestellt haben und über den Netzwerk-Browser nur Apple-Share-Verbindungen aufgebaut werden, bin ich jetzt ratlos.

    Ich hoffe ich habe mich verständlich ausgedrückt und es kann jemand helfen?

    Jowe
     
  2. MacELCH

    MacELCH New Member

    Du könntest folgendes Versuchen: Über das Apfel Menü auf Auswahl gehen und dort den entsprechenden Rechner auswählen, dessen HD Du bei Dir mounten möchtest. Dort kann man falls mehrere Partitionen existieren jeweils ein Kreuz anklicken, und auswählen, daß er beim nächsten Neustart sich automatisch dort versucht anzumelden.

    Ich weiß, Du würdest ständig diese Volumes auf Deinem Desktop sehen, aber falls es funktioniert ist es doch egal oder ?

    Ich vermute mal Du bist mit 9.22 unterwegs ?

    Gruß

    MacELCH
     
  3. jowe

    jowe New Member

    Tschuldigung, wollte mit der Antwort nicht so lange warten.

    Jein, ich nutze 9.1.

    Im Prinzip hast du recht. Es geht aber um ca. 20 Volumes/Partitionen auf 4 verschiedenen Servern. Die meistens nur kurz und nicht immer gleichzeitig benutzt werden.

    Und die müllen den desktop ganz schön zu und Perfomance wird dadurch auch nicht besser.

    Das merkwürdige ist, dass nicht alle Volumes/Partionen auf einem Server betroffen sind.
     
  4. MacELCH

    MacELCH New Member

    Was hindert Dich auf 9.22 zu aktualisieren ?

    Könnte sein, daß sich dann das Problem erledigt hat.

    Gruß

    MacELCH
     
  5. jowe

    jowe New Member

    nein, leider nicht. Auch auf den Rechner mit 9.2 tritt das System auf.

    Außerdem ist es eben mal nicht so einfach auf dem Produktionsrechner das System zu aktualisieren. Denn wenn schon, dann schon richtig - also mit neuem Systemordner, um auch andere kleine Macken auszubügeln. Und das kostet halt Zeit.

    Trotzdem vielen Dank
    Jowe

    P. S. Es wundert mich nur, dass anscheinend noch niemand dieses Problem hatte.
     
  6. MacELCH

    MacELCH New Member

    Ne andere Frage:

    Apple Share geht ja bei Dir scheinbar nicht mehr, bzw. Du willst alles über TCP/IP machen (was auch schneller ist).

    Wenn Du dennoch im Apfel Menü auf die Auswahl gehst und dann auf Apple Share, dann bleibt bei Dir vermutlich die Liste der Fileserver leer (?). Du kannst aber in dem Feld Server IP-Adresse schlichtweg die IP Nummer oder den Namen des Rechners eingeben mit dem Du Dich verbinden willst.

    Die so über TCP/IP gemountete Partition/Platte wird Dir dann wie gewohnt auf dem Desktop angezeigt. Dieses einmal anklicken und Apfel+M ein Alias erzeugen. Nochmal eine andere Partition auswählen, gleiches prozedere.

    Dann beide Volumes in den Papierkorb ziehen und ausprobieren ob sie korrekt per doppelklick und Paßwort Abfrage gemountet werden.

    Bei mir geht das zumindest, bisher auch ohne Probleme. Habe gerade auch das mit den mehreren Partitionen von einem Rechner ausprobiert und das funktioniert auch soweit.

    Gruß

    MacELCH
     
  7. jowe

    jowe New Member

    Genau so habe ich es ja gemacht.

    Und sie werden auch korrekt gemountet, wenn noch nichts gemountet ist.

    D.h. Part1 und Part2 vom selben Server liegen als Alias auf dem Schreibtisch. Verbindung ist getrennt. Klick auf das alias mountet jetzt korrekt die entsprechende Partition. Erst jetzt wenn die jeweils andere gemountet werden soll wird nur die zuerst gemountete geöffnet und der Pfad im alias wird geändert.

    Das Problem kann ich im Moment nur umgehen, wenn ich eine andere Partition vom gleichen Server möchte, indem erst die Verbindung kappe und dann das andere Alias aktiviere.

    Es etwas umständlich, funktioniert aber. Ärgerlich ist nur, wenn ich es mal vergesse, ist auch das Alias hinüber und ich muss wieder über die Auswahl die IP-Adresse eingeben um ein neues alias anzulegen.

    Jedenfalls ist das ganze sehr merkwürdig, da ja von extern der Pfad eines Alias auf meinem Rechner geändert wird.
     
  8. MacELCH

    MacELCH New Member

    Welches System ist auf den anderen Rechnern drauf ?

    Bei mir: PB G3@9.22, G4AGP@10.1.5, G4@9.22, IBook@10.2.1

    Leider haben wir hier kein älteres 9er System mehr nur noch ein paar archaische 7.55 *g*

    Gruß

    MacELCH
     
  9. jowe

    jowe New Member

    Im Prinzip alles 9er-Systeme.

    Ich vergaß aber vielleicht zu erwähnen, dass das ganze Server-System natürlich Dosen sind und die Partitionen für den Mac auf den Servern natürlich nur freigeschaltete Ordner auf diesen Dosen-Servern sind. Und die Macs hier in der Unterzahl gegebenüber den Dosen-Clients sind.

    Aber ich glaube nicht, dass hier Problem versteckt ist.
     
  10. MacELCH

    MacELCH New Member

    Da wäre ich mir nicht so sicher !

    Ganz verstanden habe ich es zwar nicht aber ich versuchs mal:

    Also von Deinen Macs ist auf dem PC ein Ordner (quasi als Netzwerklaufwerk), auf diesen greifst Du von Deinen anderen Macs drauf zu ? Sprich Du verbindest Dich zum PC ?

    Kann ich mir ehrlich gesagt nicht ganz so vorstellen ohne Zusatzsoftware wie DAVE, oder ich habe irgendwas nicht ganz verstanden ??

    Gruß

    MacELCH
     
  11. jowe

    jowe New Member

    Nicht ganz.

    Auf dem großen Dosen-Server sind viele Ordner und diese können für den Mac sichtbar gemacht, damit man darauf zugreifen kann. Dafür wird aber von PC-Seite noch Software benötigt. Wir arbeiten mit MacServerIP, ich schätze es arbeitet wie Dave nur etwas professioneller und vor allem ist es wohl für große Netze angelegt.

    Außerdem ist das Problem nur ein "halbes" Problem. Es tritt nur bei einigen Servern auf. Auf den anderen pfunzen die aliasse tadellos.

    Aber das ist eigentlich alles halb so wild. Durch die Netzwerkumstellung bin ich aber erst einmal von meinen bisher genutzten Druckern getrennt und über TCP/IP haben die großen Systemadministratoren zwar Verbindung zum Drucker, aber der Mac will darauf nicht drucken. Ich schweife ab - aber was wäre die Arbeitswelt ohne diese Probleme - einfach langweilig.
     

Diese Seite empfehlen