Terminal und iTunes

Dieses Thema im Forum "Mac-OS X 10.6 Snow Leopard" wurde erstellt von akai, 7. November 2010.

  1. akai

    akai New Member

    Hi,das ist mein erster Versuch in einem Forum!

    Ich habe folgendes Problem: habe in iTunes meinen Kontrast verändert wie in der neusten Ausgabe von MW auf Seite 106 beschrieben. leider kann ich nicht wie beschrieben mit der Endung FALSE die Sache rückgängig machen. Das war mein erster Versuch ins Innere meines Macs vorzudringen. Es wird nämlich langsam Zeit das ich mich mehr damit auseinander setze. Ich bin gespannt wo ich etwas falsch gemacht habe.

    danke im voraus für euere Hilfe.
     
  2. MACaerer

    MACaerer Active Member

    Hey akai
    Willkommen im Forum
    Ich habe den Befehl eben gerade ausprobiert. Er funktioniert einwandfrei in beide Richtungen. Daher vermute ich, dass du dich vertippt hast.
    Ich halte es übrigens auch für eine sehr gute Idee, dass man sich mit dem UNIX-Unterbau des MacOs beschäftigt, bevor man (unbekannte) Terminal-Befehle anwendet. Solange man nur irgendwelche Default-Einstellungen verändert ist es nicht weiter tragisch. Aber es gibt genügend Befehle, bei denen man mit einem Tippfehler das System rettungslos zerschießt oder wichtige Dateien löscht. Vor allem weil es bei Terminalbefehlen keine Rückfragen gibt, wie bei Finder-Befehlen.

    MACaerer
     
  3. akai

    akai New Member

    Hi MACaerer,

    leider funktioniert es nicht ich es mehrmals versucht jeden Buchstaben kontrolliert aber geht nicht. Muss man iTunes beenden oder wie ist die richtige Reihenfolge?

    Gruß akai
     
  4. MACaerer

    MACaerer Active Member

    Ach so ja, natürlich. Du musst iTunes nach der Änderung beenden und neu starten. Sonst siehst du die Änderung nicht. Mit dem Terminalbefehl wird die Voreinstellungsdatei von iTunes verändert. Diese Datei wird nur beim Öffnen des Programms geladen.

    MACaerer
     
  5. akai

    akai New Member

    Ja, mein lieber MACaerer,
    ob Du es glaubst oder nicht, ich bekomme es nicht hin. Habe auch einen Neustart mit dem Mac versucht Selbst das hat nicht funktioniert, dieses Problem habe ich gestern im Forum gelesen blauer Bildschirm und das Karussell dreht sich musste dann das ganze mit OnSchalter abkürzen. Hast Du oder sonst noch jemand eine Idee ? Ich hoffe wir bekommen das hin.

    Gruß akai
     
  6. MACaerer

    MACaerer Active Member

    Tia meine liebe akai, ich weiß nicht wie ich dir da weiterhelfen soll. Die Terminalbefehle funktionieren so wie beschrieben, es ist also kein grundsätzliches Problem. Was das spezielle Problem bei deinem Mac ist kann ich aus der Ferne kaum beurteilen.
    Gibt es denn bei der Eingabe des Terminalbefehls irgend eine Meldung, die auf einen Syntax-Fehler hinweist? Die Befehle im Terminal, die mit "defaults" beginnen, sind keine Standard-UNIX-Befehle sondern erweitern das User-Interface. Wenn man sich dabei vertippt kommt in der Regel eine ganze Latte von Informationen zu den Parametern dieser Befehle, ähnlich den man-Pages der "richtigen" UNIX-Befehle.

    MACaerer
     
    Zuletzt bearbeitet: 10. November 2010
  7. akai

    akai New Member

    Moin MACaerer,

    das mit iTunes hat bis jetzt immer noch nicht funktioniert,ich hebe jetzt mal ein Screenshot von der Meldung gemach vielleicht kannst Du oder sonst jemand daraus
    was ersehen. Das Bild ist im Anhang, ich hoffe ich habe das so richtig gemacht.

    Gruß akai
     

    Anhänge:

  8. MACaerer

    MACaerer Active Member

    Wenn du den Befehl so eingegeben hast wie im Screenshot beschrieben, dann hast du dich tatsächlich vertippt. Der Befehl muss nämlich lauten:

    defaults write com.apple.iTunes high-contrast-mode-enable -bool TRUE/FALSE

    Natürlich muss in der Parameterliste entweder TRUE oder FALSE (bzw. 1 oder 0) eingegeben werden, je nachdem ob man die Funktion ein- oder ausschalten will.
    Wichtig ist die exakte Anordnung der Leer- und sonstigen Satzzeichen, mit denen Befehl und Parameter getrennt werden.

    Aufbau des CLI-Befehls im Terminal:
    defaults write => Befehl
    com.apple.iTunes => Voreinstellungsdatei für iTunes
    high-contrast-mode-enable => auszulösende Funktion
    -bool => es gibt nur zwei Möglichkeiten
    1 oder 0 => Umschalter
    Zwischen den einzelnen Parametern in der Parameterliste muss also jedes mal ein Leerzeichen stehen.

    MACaerer
     
  9. akai

    akai New Member

    Hi MACaerer,

    ich glaube ich bin zu blöd für so etwas.
    Dies ist meine Eingabe
    defaults write com.apple.iTunes high contrast mode enable -bool FALSE
    Kuck doch bitte noch mal.
    Danke für deine Geduld .

    akai
     
  10. MACaerer

    MACaerer Active Member

    Der Funktionsparameter muss lauten
    high-contrast-mode-enable
    Der CLI muss die Funktion als ein Wort interpretieren können, daher die "-" nicht vergessen. Ansonsten stimmt es.

    MACaerer
     
  11. akai

    akai New Member

    Hey MACaerer,

    Bingo!!!! Jetzt funktionier´s , großartig :biggrin:

    Noch mal Danke !

    akai
     

Diese Seite empfehlen