Terminal wieder zurücksetzen ?

Dieses Thema im Forum "Software" wurde erstellt von plochi, 26. Oktober 2003.

  1. plochi

    plochi New Member

    Hallo ;
    ich habe mir Panther installiert & meinen Mac wieder arbeitsfertig gemacht. Dabei habe ich ein kleines Shell-Script geschrieben, mit welcehm ich einen SSH - Zugang zu meinem Webserver starte. Dieses Script habe ich per "Öffnen mit ..." mit dem Terminal verknüpft und "Immer öffnen mit" ausgewählt.

    Nun verhält sich mein Terminal recht eigenartig : Immer wenn ich ein neues Terminalfenster öffnen will, erscheint folgende Meldungen :

    Last login: Sun Oct 26 19:18:34 on ttyp1
    /bin/bash; exit
    Welcome to Darwin!
    Andreas-Plochs-Computer:~ andreasploch$ /bin/bash; exit
    Andreas-Plochs-Computer:~ andreasploch$


    Bekomm' ich die 2 "bin/bash;exit" Einträge irgendwie wieder raus ?
    Habt Ihr eine Idee ?
     
  2. gratefulmac

    gratefulmac New Member

    Hast Du das Script für diese Shell geschrieben, oder noch unter 10.2.
    Die haben die Shell gewechselt.
    Vieleicht liegt es nur daran?
     
  3. plochi

    plochi New Member

    Ääääh - das Script stammt nach aus 10.2.8 . Aber es doch eigentlich nur eine Textdatei, oder ?
    Hier steht folgendes drin :

    ssh -l aploch 217.160.xxx.yyy

    Soll ich die zu verwendende Shell in der ersten zeile vielleicht mit angeben ?
    Andreas
     
  4. gratefulmac

    gratefulmac New Member

    Keine Ahnung.
    Aber vieleicht stimmt dadurch die Zuweisung nicht mehr und die bash shell lehnt das ganze ab, weil es für die tsh shell bestimmt ist.
    Probier doch mal aus Letztere als Standardshell anzumelden.
    Dann müßte das doch wieder laufen.
     
  5. WoSoft

    WoSoft Debugger

    schreib mal in die erste Zeile

    #!/bin/tcsh

    Ansonsten: Datei noch ausführbar und PATH gesetzt? Sonst probiers mal im Verzeichnis des Scripts mit ./Name

    cu
    Peter
     
  6. wurzel

    wurzel New Member

    Terminal beenden und dann die Datei /Homeverzeichnis/Library/Preferences/com.apple.Terminal.plist löschen.

    Jetzt das Terminal neu starten und alles ist wieder Gut.

    PS: Klick mal auf das Terminalsymbol im Dock (Taste gedrückt halten) dann öffnet sich eine Menü und hier "Mit Server verbinden" auswählen. Da kannst Du in einer Liste, Server anlegen und einfach eine Verbindung herstellen (SSH, Telnet SFTP und FTP).

    Gruß,

    WURZEL
     
  7. hakru

    hakru New Member

    lege in deiner HOME-Directory einen unsichtbaren config-File ("~/.profile") an und definiere darin dein Alias - etwa so:

    alias welcome='ssh -l user hostAdressIP'

    ... das wäre schon alles. Dies ist ein einfacher Textfile, braucht also kein "#!/bin/..." als 1. Zeile ...

    hakru
     
  8. avw

    avw New Member

    Wurzel hat recht. Ich hatte auch mal das Problem, dass das Terminal bei jedem Start versucht hat, eine Reihe von Befehlen auszuführen, die ich vorher über ein Apple-Script im Terminal ausführen liess. Irgendwie - und mir ist noch heute ein Rätsel - hat sich dieses Skript in die plist "gebrannt". Also löschen und alles wird gut.... Hoffentlich...

    avw.
     
  9. plochi

    plochi New Member

    Hallo ;
    ich habe mir Panther installiert & meinen Mac wieder arbeitsfertig gemacht. Dabei habe ich ein kleines Shell-Script geschrieben, mit welcehm ich einen SSH - Zugang zu meinem Webserver starte. Dieses Script habe ich per "Öffnen mit ..." mit dem Terminal verknüpft und "Immer öffnen mit" ausgewählt.

    Nun verhält sich mein Terminal recht eigenartig : Immer wenn ich ein neues Terminalfenster öffnen will, erscheint folgende Meldungen :

    Last login: Sun Oct 26 19:18:34 on ttyp1
    /bin/bash; exit
    Welcome to Darwin!
    Andreas-Plochs-Computer:~ andreasploch$ /bin/bash; exit
    Andreas-Plochs-Computer:~ andreasploch$


    Bekomm' ich die 2 "bin/bash;exit" Einträge irgendwie wieder raus ?
    Habt Ihr eine Idee ?
     
  10. gratefulmac

    gratefulmac New Member

    Hast Du das Script für diese Shell geschrieben, oder noch unter 10.2.
    Die haben die Shell gewechselt.
    Vieleicht liegt es nur daran?
     
  11. plochi

    plochi New Member

    Ääääh - das Script stammt nach aus 10.2.8 . Aber es doch eigentlich nur eine Textdatei, oder ?
    Hier steht folgendes drin :

    ssh -l aploch 217.160.xxx.yyy

    Soll ich die zu verwendende Shell in der ersten zeile vielleicht mit angeben ?
    Andreas
     
  12. gratefulmac

    gratefulmac New Member

    Keine Ahnung.
    Aber vieleicht stimmt dadurch die Zuweisung nicht mehr und die bash shell lehnt das ganze ab, weil es für die tsh shell bestimmt ist.
    Probier doch mal aus Letztere als Standardshell anzumelden.
    Dann müßte das doch wieder laufen.
     
  13. WoSoft

    WoSoft Debugger

    schreib mal in die erste Zeile

    #!/bin/tcsh

    Ansonsten: Datei noch ausführbar und PATH gesetzt? Sonst probiers mal im Verzeichnis des Scripts mit ./Name

    cu
    Peter
     
  14. wurzel

    wurzel New Member

    Terminal beenden und dann die Datei /Homeverzeichnis/Library/Preferences/com.apple.Terminal.plist löschen.

    Jetzt das Terminal neu starten und alles ist wieder Gut.

    PS: Klick mal auf das Terminalsymbol im Dock (Taste gedrückt halten) dann öffnet sich eine Menü und hier "Mit Server verbinden" auswählen. Da kannst Du in einer Liste, Server anlegen und einfach eine Verbindung herstellen (SSH, Telnet SFTP und FTP).

    Gruß,

    WURZEL
     
  15. hakru

    hakru New Member

    lege in deiner HOME-Directory einen unsichtbaren config-File ("~/.profile") an und definiere darin dein Alias - etwa so:

    alias welcome='ssh -l user hostAdressIP'

    ... das wäre schon alles. Dies ist ein einfacher Textfile, braucht also kein "#!/bin/..." als 1. Zeile ...

    hakru
     
  16. avw

    avw New Member

    Wurzel hat recht. Ich hatte auch mal das Problem, dass das Terminal bei jedem Start versucht hat, eine Reihe von Befehlen auszuführen, die ich vorher über ein Apple-Script im Terminal ausführen liess. Irgendwie - und mir ist noch heute ein Rätsel - hat sich dieses Skript in die plist "gebrannt". Also löschen und alles wird gut.... Hoffentlich...

    avw.
     

Diese Seite empfehlen