Tiger - Update Apache auf 2.0.54

Dieses Thema im Forum "Software" wurde erstellt von John L., 24. Juni 2005.

  1. John L.

    John L. Active Member

    Hallo allerseits,

    hat jemand schon mal den von Tiger mitinstallierten Apache von 1.3.x auf 2.0.54 upgedated...? Ich komm mit "configure", etc. schon klar, Problem ist nur, wie mach ich ein Update auf den bestehenden Apache (wird ja nicht im standard Pfad /usr/local/ installiert...reicht es, bei "configure" den Installationspfad (/etc/httpd/) anzugeben..?

    Hat hier jemand Erfahrungen oder hat ne Anleitung im Web für mich...bei Apple ist nicht wirklich was zu finden..!

    THX

    John L.
     
  2. hofmeyer

    hofmeyer New Member

    Moin.
    Ich würde den neuen apache mit './configure --prefix=/usr/local/apache_2.0.54' konfigurieren, dann unter /usr/local einen link apache auf apache_2.0.54 erstellen. Dann hast Du den Vorteil, dass Du erstens nicht in der Originalkonfiguration vom Tiger rumgebastelt hast, Du bei Bedarf wieder auf die alte Version umstellen kannst und Du auch problemlos neue Versionen parallel dazu installieren kannst.
    Die Konfigurationsdateien müssen dann unter /usr/local/apache/conf angapasst werden, und gestartet wird der neue Server mit '/usr/local/apache/bin/apachectl -start'

    Den alten Server stoppst Du einfach in den Systemeineinstellungen unter sharing. Wenn Du dann noch ganz mutig bist, kannst Du das Startskript für den Apache unter /System/Library/StartupItems/Apache so anpassen, dass damit der neue apache gestartet wird.
     
  3. John L.

    John L. Active Member

    Hi hofmeyer,

    Erstmal Danke für Deine Antwort.

    So in der Richtumng hatte ich mir das auch vorgestellt. Apache2 in ein eigenes Verzeichnis und ich kann dann, je nach Lust und Laune, Apache 1.3 oder 2 starten.

    Wenn ich allerdings
    </usr/local/apache2/bin root# apachectl start>
    ausführe,

    startet Apache zwar aber verarbeitet die falsche httpd.conf:
    <Processing config directory: /private/etc/httpd/users/*.conf>
    <Processing config file: /private/etc/httpd/users/John.conf>
    </usr/sbin/apachectl start: httpd started>

    Hab mir die "apachectl" und die "envvars" schon mal angeschaut, aber nirgens ein Eintrag für die httpd.conf. Weißt Du, wo diese Einträge hinterlegt werden? Auch das Ändern des Startscripts bringt nix.

    Das Seltsame an der Geschichte ist allerdings, dass ich in <Systemeinstellungen -> Sharing -> Personal Web Sharing> keinen Webserver gestartet hab. Irgendwie starte ich also Apache 2.0.54 mit der httpd.conf von 1.3.x. Wußte gar nicht, dass das funktioniert. Hab vor kurzem sowas Ähnliches auf nem Windoof PC probiert, da startete der Apache 2 Dienst nicht.

    Hast Du noch ne Idee...?

    THX

    John L.
     
  4. John L.

    John L. Active Member

    *raufhol*

    John L.
     
  5. hofmeyer

    hofmeyer New Member

    Hi,

    Du kannst in apachectl den parameter -f /usr/local/apache/conf/httpd.conf an die Zeile anhängen, wo die Variable HTTPD gesetzt wird. Letztendlich ruft apachectl nämlich nur httpd, also den apache daemon auf, und der kann mit allen möglichen Optionen gestartet werden. Schau Dir dazu mal 'man httpd' an. Evtl mußt Du das ganze in Hochkomma setzen, also "HTTPD=/usr/local/apache/bin/apachectl -f /usr...."

    Friedhelm
     
  6. John L.

    John L. Active Member

    Hab noch was besseres gefunden...

    http://www.serverlogistics.com/apache2.php

    Mit Pref.Pane und allem drum und dran...funzt auch sauber...nur das Pref.PAne muss man mit der Hand in /System/Library/PreferencePanes kopieren

    Gruß & THX

    John L.
     

Diese Seite empfehlen