Uhr in Mail zählt nur bis 12!?

Dieses Thema im Forum "Hardware" wurde erstellt von Mondschaf, 12. November 2002.

  1. Mondschaf

    Mondschaf New Member

    In "Datum und Uhrzeit" ist die 24-Stunden-Anzeige ausgwählt, und in der Menü-Leiste wird's auch so angezeigt. In Mail aber zählt die Zeitangabe nur bis 12 und es steht auch kein pm oder am dahinter, sondern "Uhr", also deutsch. Wie kann ich das in Mail auf 24 Stunden umstellen? Ist sehr irritierend und manchmal auch sogar eminent wichtig.

    Mondschaf
     
  2. white-raven

    white-raven New Member

    So bringst Du Mail dazu, wieder das 24-Stunden Format zu verwenden:
    1. Beende zuerst Mail, falls es geöffnet ist.
    2. Öffne den Ordner "Programme".
    3. Klicke bei gedrückter Control-Taste auf "Mail" und wähle "Paketinhalt zeigen" aus dem Context-Menü.
    4. Öffne Contents | Resources | German.lproj
    5. Suche die Datei "Localizable.strings" und erstelle zuerst eine Sicherheitskopie, falls später etwas schief gehen sollte.
    6. Öffne die Datei in einem Texteditor und suche die Zeile mit dem Eintrag "12HOUR_TIME_FORMAT" = "%1I:%M"; und ersetze sie durch "12HOUR_TIME_FORMAT" = "%H:%M";
    7. Speichere Deine Änderungen und schliesse die Datei.

    stand mal hier so im forum und funktioniert.

    gruß dirk
     
  3. typneun

    typneun New Member

    oder du stellst die menüleistenuhr auf 12 stunden, dann passt in mail wieder mit den 24 stunden. klingt komisch, is aber so ;-))))
     
  4. Mondschaf

    Mondschaf New Member

    @Dirk
    Hat geklappt! Danke! Jetzt ist alles schön übersichtlich. Was so ein kleiner Buchstabe doch ausmacht....

    @typneun:
    Habt Ihr Eure Webcam noch im Büro? Hab' schon länger nicht mehr auf Eure HP geschaut...
    Mondschaf
     
  5. Brainysmurf

    Brainysmurf New Member

    Danke, guter Tipp. Aber ist das nun ein Bug in Mail, oder wie? So etwas sollte man doch eigentlich in den Preferences "regeln" können und nicht in irgendwelchen schwer auffindbaren Textdateien...
     
  6. benjii

    benjii New Member

    Hi,

    schöner tipp, funktioniert bei mir aber leider nicht.

    Statt einer Uhrzeit habe ich jetzt bei meinen Mails die schöne Angabe: "12_HOUR_TIME_FORMAT Uhr" stehen. Außerdem ist die Toolbar jetzt seltsam beschriftet: "TOOLBAR_REPLY" etc. heißen die Buttons jetzt.

    Sieht zwar alles urig aus, trotzdem hätte ich auf Dauer gerne eine "richtige" Uhrzeitangabe in Mail (und zwar im 24-h-Format, so wie in der Menüleiste auch, jawoll!)

    Weiß jemand Rat? Ich habe alles schon mehrfach probiert...

    Grüße,

    benjii
     
  7. morty

    morty New Member

    hallo,

    ersetze nur das 1I durch ein H .... wie oben beschrieben, am besten kopierst du es herüber, bei mir hat es funktioniert, habe es erst vorgestern gemacht.

    Gruß morty
     
  8. Mondschaf

    Mondschaf New Member

    Hast Du denn keine Sicherheitskopie gemacht? ;-)
     
  9. p.i.t.

    p.i.t. Ural-Silber

    @ dirk white raven

    Es hat geklappt, vielen Dank auch von mir!
    Mich würd nur interessieren, warum Du so genau weisst, resp. wie du weisst wo man nachschauen muss wenn so was nicht geht (*STAUN*)
     
  10. knorr

    knorr New Member

    Danke, ich hab mich auch mal bei dem Tip bedient,
    funzt echt supa geil.
     
  11. Brainysmurf

    Brainysmurf New Member

    <<Statt einer Uhrzeit habe ich jetzt bei meinen Mails die schöne Angabe: "12_HOUR_TIME_FORMAT Uhr" stehen. Außerdem ist die Toolbar jetzt seltsam beschriftet: "TOOLBAR_REPLY" etc. heißen die Buttons jetzt.>>

    Dann musst du irgendeine Kleinigkeit falsch gemacht haben (Satzzeichen vergessen, Groß-/Kleinschrift missachtet etc.). Und oberste Pfadfinderweisheit: keine Dtaeioperationen ohne Backups! Und das gilt für alle Systeme! ;-)

    Wer sie braucht, kann von mir die unveränderte Datei (mein Backup) haben:

    http://www.lehrerzimmer.org/software/osxmail/Localizable.strings

    Viel Erfolg!
     
  12. benjii

    benjii New Member

    Hi,

    danke mal an alle für Eure Ratschläge. Natürlich habe ich mir auch eine Sicherheitskopie gemacht - aber ich wollte ja das 24-Stunden-Format.

    Mit dem Backup von brainysmurf hat es jetzt prima geklappt. Vielen Dank, brainy! Klasse Sache! Ich muss tatsächlich was durcheinander gebracht haben.

    Grüße,

    benjii
     
  13. Paparatze

    Paparatze New Member

    Danke, hat prima funktioniert, jetzt hat der Tach wiedda vierähzwansisch Stündscher... .
     
  14. Rotweinfreund

    Rotweinfreund + Jevers Liebhaber

  15. Mondschaf

    Mondschaf New Member

    In "Datum und Uhrzeit" ist die 24-Stunden-Anzeige ausgwählt, und in der Menü-Leiste wird's auch so angezeigt. In Mail aber zählt die Zeitangabe nur bis 12 und es steht auch kein pm oder am dahinter, sondern "Uhr", also deutsch. Wie kann ich das in Mail auf 24 Stunden umstellen? Ist sehr irritierend und manchmal auch sogar eminent wichtig.

    Mondschaf
     
  16. white-raven

    white-raven New Member

    So bringst Du Mail dazu, wieder das 24-Stunden Format zu verwenden:
    1. Beende zuerst Mail, falls es geöffnet ist.
    2. Öffne den Ordner "Programme".
    3. Klicke bei gedrückter Control-Taste auf "Mail" und wähle "Paketinhalt zeigen" aus dem Context-Menü.
    4. Öffne Contents | Resources | German.lproj
    5. Suche die Datei "Localizable.strings" und erstelle zuerst eine Sicherheitskopie, falls später etwas schief gehen sollte.
    6. Öffne die Datei in einem Texteditor und suche die Zeile mit dem Eintrag "12HOUR_TIME_FORMAT" = "%1I:%M"; und ersetze sie durch "12HOUR_TIME_FORMAT" = "%H:%M";
    7. Speichere Deine Änderungen und schliesse die Datei.

    stand mal hier so im forum und funktioniert.

    gruß dirk
     
  17. typneun

    typneun New Member

    oder du stellst die menüleistenuhr auf 12 stunden, dann passt in mail wieder mit den 24 stunden. klingt komisch, is aber so ;-))))
     
  18. Mondschaf

    Mondschaf New Member

    @Dirk
    Hat geklappt! Danke! Jetzt ist alles schön übersichtlich. Was so ein kleiner Buchstabe doch ausmacht....

    @typneun:
    Habt Ihr Eure Webcam noch im Büro? Hab' schon länger nicht mehr auf Eure HP geschaut...
    Mondschaf
     
  19. Brainysmurf

    Brainysmurf New Member

    Danke, guter Tipp. Aber ist das nun ein Bug in Mail, oder wie? So etwas sollte man doch eigentlich in den Preferences "regeln" können und nicht in irgendwelchen schwer auffindbaren Textdateien...
     
  20. benjii

    benjii New Member

    Hi,

    schöner tipp, funktioniert bei mir aber leider nicht.

    Statt einer Uhrzeit habe ich jetzt bei meinen Mails die schöne Angabe: "12_HOUR_TIME_FORMAT Uhr" stehen. Außerdem ist die Toolbar jetzt seltsam beschriftet: "TOOLBAR_REPLY" etc. heißen die Buttons jetzt.

    Sieht zwar alles urig aus, trotzdem hätte ich auf Dauer gerne eine "richtige" Uhrzeitangabe in Mail (und zwar im 24-h-Format, so wie in der Menüleiste auch, jawoll!)

    Weiß jemand Rat? Ich habe alles schon mehrfach probiert...

    Grüße,

    benjii
     

Diese Seite empfehlen