Umlaute in Dreamweaver MX 2004

Dieses Thema im Forum "Software" wurde erstellt von PitsPit, 25. Dezember 2004.

  1. PitsPit

    PitsPit New Member

    Vorab erstmal an alle fröhliche Weinachten:)

    Wer von euch verwendet die obige Software und kann mir bei folgendem Problem weiterhelfen:

    Wenn ich ein reines Textdokument angelegt habe, und den Inhalt in Dreamweaver per "Copy Paste" einfüge, zerbröseln mir regelmäßig die Umlaute wie "ä" "ü" und "ß", sobald ich die Site veröffentliche?

    Hat hierzu jemand eine Idee.

    Vielen Dank,
    Pit
     
  2. RSC

    RSC ahnungslose

    Fügst du den Text direkt in Quellcoode ein oder im Layoutmodus?
     
  3. PitsPit

    PitsPit New Member

    Danke für deine Antwort:)

    Ich füge den Text im Layoutmodus ein.

    Pit
     
  4. RSC

    RSC ahnungslose

    O.K., weitere Frage: welche Kodierung hat dieses HTML-Dokument?
     
  5. RSC

    RSC ahnungslose

    Und welche Kodierung hat dein Browser?

    Ist die Site on-line? Kannste URL zum gucken geben?
     
  6. PitsPit

    PitsPit New Member

    :confused: Kodierung Browser?

    Ich benutze Safari?

    Da ich die Site in Dreamweaver durch Neueingabe bereinigt habe, wirst du jetzt die Fehler nicht mehr erkennen!

    anbei der Link: http://www.pitdorn.de/smalltalk.html

    Pit
     
  7. RSC

    RSC ahnungslose

    ja!

    guck unter Safari>>Darstellung>>Text-Codierung.


    ......

    Deine HTML-Datei Codierung ist für uni-code eingestellt:

    meta http-equiv="Content-Type" content="text/html; charset=utf-8"

    Standart für Westlich-Latin1 ist aber :

    meta http-equiv="Content-Type" content="text/html; charset=iso-8859-1

    es liegt bestimmt daran.....
     
  8. PitsPit

    PitsPit New Member

    Erstmal Danke.

    Verstehe ich das richtig, dass nur bei mir im Browser die falsche Kodierung eingestellt ist?

    Pit
     
  9. RSC

    RSC ahnungslose

    Möglich.
    Aber was ich meine: bei dir in der HTML-Datei ist die falsche Codierung.
     
  10. Ich fürchte das ist ein Bug in Dreamweaver.
    Mir hat es erst kürzlich eine komplette Seite zerbröselt.
    Und zwar habe ich per Copy und Paste quellcode innerhalb von dw copiert. Aus einem Ö wurde ein z.B. ein oUn.

    Im dreamweaver 6.0 war ein Bug der aber mit 6.1 wieder behoben wurde, aber irgendwie lebt der wieder auf.
    Ich habe aber immer wieder mit Apple Codierungsprobleme.
    Es ist zum Kotzen.
     
  11. RSC

    RSC ahnungslose

    Habe nie solche Problemme gehabt ( von Dev-4.0 bis MX). :rolleyes:
     
  12. Wenn Du den 6.0 mal benutzt hast, müsste der Bug bekannt sein.
    Ansonsten importiere mal einen mysqldump (linux) nach osx.
     
  13. Spanni

    Spanni New Member

Diese Seite empfehlen