Umlaute in OpenOffice: Wo einstellen?

Dieses Thema im Forum "Software" wurde erstellt von mtu, 4. November 2003.

  1. mtu

    mtu New Member

    Hallo zusammen

    Habe OpenOffice und möchte nun noch das deutsche "Tastaturlayout" (Umlaute usw) einstellen.

    Weiss jemand wo? Müsste wohl in der X-Umgebung geschehen!

    Danke
    Michael
     
  2. Zettt

    Zettt New Member

    na toll beim durchforsten von tausend foren habe ich auch keine richtige antwort auf dieses problem gefunden. meist einträge bei denen zwar die frage gestellt wurde aber keiner geantwortet hat so wie bei dir.
    da reichen die posts echt "ich will thai bei mir auf der tastatur haben" bis "wie kann ich umlaute bei win2000 einstellen" usw...wie gesagt total sinnloses zeug.
    ich habe das selbe problem! deshalb poste ich das hier einfach mal und hoffe das man das irgendwie lösen kann.
    hast du heraus gefunden wie das geht?
     
  3. Macci

    Macci ausgewandert.

  4. Zettt

    Zettt New Member

    wie in meinem post steht. habe ich das bereits versucht. es gibt da keine sinnvolle bzw überhaupt hilfe.
     
  5. Macci

    Macci ausgewandert.

  6. Macci

    Macci ausgewandert.

  7. Zettt

    Zettt New Member

    das interessante ist ja das der rest...
    also sprich #+-.,;:_'* usw...eben trotzdem richtig auf der tastatur liegen
     
  8. ChrisBrecheis

    ChrisBrecheis New Member

    Hallo Zett,
    welche Version von OpenOffice.org hast du denn und welchen X-Server verwendest du?
    Ich kann mit OOo 1.1.3 (früher auch 1.1.1 und 1.1.2) und Apple X11 ohne Probleme Umlaute und andere Sonderzeichen eingeben.
     
  9. Zettt

    Zettt New Member

    x-server???
    ich denke mal du meinst das x11...das benutze ich.
    sonstige konfiguration ibook g4 mit mac os x.3.5
     
  10. ChrisBrecheis

    ChrisBrecheis New Member

    Ja, Apple X11.app bzw. XDarwin meine ich. OpenOffice.org sollte eigentlich problemlos mit deutschen Umlauten und Sonderzeichen funktionieren, normalerweise muss man da gar nichts einstellen. Bei mir tut es das auch mit X11.app und OS X 10.3.5.

    Ich hätte eine Idee, woran dein Problem liegen könnte: Bei der Version 1.1.2 wurde etwas bei der Behandlung von Sonderzeichen in OpenOffice.org verändert. Falls du vorher eine ältere Version von OpenOffice installiert hattest und die nicht vollständig entfernt hast, dann kann es sein, dass du keine Umlaute eingeben kannst. Die Beschreibung dieses Problems findest du in einem Thread der Mailingliste dev@de.openoffice.org unter http://de.openoffice.org/servlets/ReadMsg?list=dev&msgNo=12075, die Problemlösung unter http://de.openoffice.org/servlets/ReadMsg?list=dev&msgNo=12097.

    Hast du in deinem Homeverzeichnis Dateien bzw. Verzeichnisse names ".gnome", ".gnome2" und ".kde" (mit dem Terminal überprüfen)? Die könnten deine Probleme verursachen.
     
  11. Zettt

    Zettt New Member

    soviel konnte ich inzwischen auch raus bekommen. dank macci. ich habe jetzt aus lauter verzweiflung auch schon eine email an diesen malte welcher der versender oder betreiber der deutschen openoffice seite ist geschrieben. habe auch schon eine antwort erhalten mit verweis auf einen developer der sich mit mac auskennt. weiss nicht wie das ausgeht.
    zu deinen links "blabla serlevt cannot be displayed"
    hab versucht mich zu registrieren. bis jetzt (ca halbe stunde) immer noch keine anmelde-email erhalten. kannst du die problemlösung nicht einfach posten? wäre sehr nett.
     
  12. ChrisBrecheis

    ChrisBrecheis New Member

  13. Zettt

    Zettt New Member

    ich habe das komplette system mit xupport durchsucht und nichts dergleichen entdeckt.
     
  14. ChrisBrecheis

    ChrisBrecheis New Member

    Schade, dann scheint's nicht dasselbe Problem zu sein wie bei dem anderen Benutzer, der keine Umlaute eingeben konnte. Weitere Ideen, woran's liegen könnte habe ich leider nicht.

    Haben deine Nachforschungen bei dem "developer der sich mit mac auskennt" etwas ergeben?
     
  15. Zettt

    Zettt New Member

    ja und zwar das hier:

    > Lösungen können dann folgende sein:
    >
    > 1. Er hat die internationale englische Version der 1.1.2 installiert, die
    > kann unter Panther Probleme mit dem Encoding der Locale machen. Nicht
    > umsonst gibt es ein komplett deutsches Build für Panther von mir. Ich hab
    > den Patch der für die 10.2 gebraucht wird nämlich nicht in meinen Sourcen
    > drin.
    >
    > 2. Er nutzt Xfree86/XDarwin in Version 4.4.0 Dann muß er eine Xmodmap
    > erstellen damit er die Umlaute hat. Ist aber auch kein großer Akt.Soll sich
    > mal direkt bei mir melden, dann erklär ich ihm das.
    >
    > 3. Die Schrift ist defekt. Das war beim letzten Anwender das Problem mit
    > Problemen bei den Umlauten so. Andere Schrift und schon ging es. Er hat dann
    > einfach die Schrift entfernt und nochmal neu installiert und schon hatte er
    > die Umlaute wieder.
    >
    > 4. Er soll schauen ob in seiner .profile oder .bash_profile die Encodings a
    > la lang=de_DE.UFT-8 heißen, sonst gibt es Chaos da OS X von sich aus UTF-8
    > erwartet.
    >
    > 5. Er hat schlicht und ergreifend englisch als Keyboardlayout gewählt. Es
    > gibt wohl bei Apple's X11 die Möglichkeit das Keyboardlayout über ein Menü
    > jeder gewünschten Sprache anzupassen und wenn er das englische
    > Keyboardlayout benutzt kann er keine Umlaute haben :) Da ich aber kein X11
    > hab kann ich ihm nicht sagen, wie und wo er das einzustellen hat.
    >
    > 6. Es gibt auch in X11 die Möglichkeit mit Keyboardlayout folgen oder wie
    > die heißt. Und das macht auch hie und da mal Ärger.
    >
    > 7. Er soll mal schauen ob die Monaco Schrift, dass ist die Systemschrift für
    > Apple's X11, das Terminal und sonst alles wichtige noch funktioniert.

    punkt 1 kann nicht hab die deutsche pkg genommen

    punkt 2 es handelt sich um xfree 4.3.0

    punkt 3 hab ich probiert

    punkt 4 würde mich interessieren wie ich das umsetze. wo sind diese dateien .profile und .bash_profile?

    punkt 5 das weiss ich auch nicht. ist mir aber auch völlig neu

    punkt 6 hab ich probiert

    punkt 7 ist interessant...dort hab ich auch keine umlaute. dem geh ich jetzt mal nach.
     
  16. Zettt

    Zettt New Member

    haha juhu. also punkt 7 hat mich am ehesten interessiert.
    bin also ins x11 terminal und hab dort versucht ö zu schreiben ging nicht. bin ins font book und habe festgestellt das ich sowohl bei monaco als auch bei allen anderen schriften keine umlaute hatte bin dann in die system preferences und hab unter international gemerkt das als hauptsprache english stand aber dann lange nix und dann erst deutsch. also habe ich erstmal alles raus was ich nicht brauch und dort steht jetzt erst englisch dann deutsch. hab dann noch unter formats umgestellt von "custom" auf "germany->germany" und schon gings :)
    kleines manko hat das ganze allerdings trotzdem...unter x11 hab ich immer noch keine umlaute :'(
     

Diese Seite empfehlen