USB Probleme mit Parallels

Dieses Thema im Forum "Software" wurde erstellt von rollerm, 20. Mai 2007.

  1. rollerm

    rollerm New Member

    Hallo,

    ich konnte das Problem zwar schon in diesem Forum finden, doch nirgendwo kam es letztendlich zu einer Lösung. Deshalb hier nochmal:

    Beim einbinden eines USB Gerätes (hier mein Smartcardreader) sagt mit Parallels, dass das Gerät, dass ich in die VM einbinden möchte, bereits von einem anderen Programm benutzt wird. Ich solle das Programm schließen und das Gerät dann neu einbinden.

    Das Problem besteht sowohl bei automatischer, als auch bei manueller Einbindung des Gerätes. Letzteres war der Tip des "Parallels Online Helfers", den ich kontaktiert hatte.

    Das Problem besteht nur bei meinem Kartenleser. Alle anderen Geräte funktionieren. Besser noch! Bis vor zwei Tagen ging sogar der Kartenleser!!! Nur jetzt plötzlich nicht mehr......

    Ich nutze Paralles Build 3188.

    Kennt jemand das Problem und hat vielleicht auch schon eine Lösung?

    Grüße
    Martin
     
  2. rollerm

    rollerm New Member

    ...haben eventuell die anderen, die das Problem hier schon mal gepostet haben eine Lösung?

    Bin völlig ratlos :confused: !

    Grüße
    Martin
     
  3. DominoXML

    DominoXML New Member

    Hi Martin,

    das Problem mit dem Smartcard Reader scheint mir zu sein, daß er schon von OSX eingebunden ist bevor du Parallels startest.

    Damit hat OSX den Zugriff auf das Gerät. Du erkennst es daran, daß für den Reader ein Icon auf dem Schreibtisch liegt.

    Sollte dies der Fall sein mußt du das Gerät erst auswerfen. Dann kann Parallels das Gerät im Normalfall auch einbinden.

    Gruß

    Volker
     
  4. rollerm

    rollerm New Member

    Hi Volker,

    vielen Dank für Deinen Tip. Genau so etwas stelle ich mir auch vor. Nur leider gibt es weder ein Icon auf dem Desktop, welches ich irgendwie auswerfen könnte, noch finde ich sonst irgendwo einen Hinweis auf die Benutzung des Cardreaders unter OS X. Win XP/Parallels will ihn partout nicht akzeptieren.

    Grüße
    Martin
     
  5. DominoXML

    DominoXML New Member

    Hi Martin,

    zunächst mal der Test ohne Parallels.

    Cardreader anstecken - der Reader müsste im Systemprofiler (Apfel-über diesen Mac-weitere Informationen) unter USB auftauchen.

    Ist er hier sichtbar, dann Stecke mal ne Smartcard rein.
    Habe zwar selbst keinen Reader, aber ich vermute OSX behandelt die Karte wie sonstige Wechseldatenträger.

    Ist alles OK müsste wie bei einer eingelegten CD ein Icon auf dem Schreibtisch erscheinen.

    Sollte dies klappen können wir zur Technik des "übergeben" bzw. konfigurieren in Parallels übergehen.

    Wenn nicht, melde Dich nochmal.

    Gruß

    Volker
     
  6. ichnicht

    ichnicht New Member


    Zieh doch den Anschlußstecker aus dem Mac, und steck ihn dann wieder rein.

    ichnicht
     
  7. rollerm

    rollerm New Member

    @Volker

    Der Reader erscheint tatsächlich im Systemprofiler. Das Einstecken der Smartcard zeigt jedoch keinerlei Wirkung. Weder im Profiler, noch auf dem Desktop.

    Vielleicht noch kurz zur Info. Habe es in Parallels schon mit automatischem und auch mit manueller Übergabe des Gerätes probiert. Das Umschalten auf manuelles Einbinden hat leider nicht den gewünschten Effekt gezeigt.
    Dies war der erste Tipp von Parallels.com. Der zweite war, doch den aktuellsten Build zu verwenden. Tue ich auch schon. Jetzt herscht von offizieller Seite her Funkstille...

    Wenn von dort eine Lösung kommt, poste ich das hier auf jeden Fall sofort!!!

    @ ichnicht:

    Danke, bringt leider keinen Effekt. Habe schon alle Variationen ausprobiert.


    Grüße
    Martin
     
  8. DominoXML

    DominoXML New Member

    Hi Martin,

    wenn Parallels nicht läuft und OSX den Cardreader nicht mountet ist hier schon der Hund begraben.

    Parallels kann nur auf Geräte zu greifen, welche dem "Wirtssystem" zur Verfügung stehen.

    Was hängt noch am USB, eventuell ein Hub, ein Drucker oder sonst irgend ein Gerät?

    Wenn ja bitte ziehe mal alle ab. Stecke den Cardreader vielleicht in einen anderen USB - Port und schaue ob er endlich beim einstecken der Karte Mountet.

    Gruß

    Volker
     
  9. rollerm

    rollerm New Member

    Hi Volker,

    ich habe nun alle USB Ports, mit und ohne Hub ausprobiert. Nix geht. Der Cardreader tuts an einem anderen Rechner wunderbar. Also scheint er schon mal nicht der Grund zu sein.

    Was mich nur wundert ist, und das hatte ich vielleicht vergessen zu erwähnen, das die Sache bis vor einer Woche noch geklappt hat. Das "Nicht mehr Erkennen" des Readers kam urplötzlich und vor allem ohne Vorwarnung :)!

    Ein Icon auf dem Desktop von OS X gab es auch zu den guten alten Zeiten nie. Und um die Antwort vieleicht vorweg zu nehmen, ich habe auch keine OS X Software installiert zwischen dem "funtioniert noch" und dem "funktioniert nicht mehr" Zeitpunkt.

    Grüße
    Martin
     
  10. rollerm

    rollerm New Member

    ... jetzt nimmt er auch meinen USB Stick und meine Wechselplatte nicht mehr :angry: :cry: !!!

    Ich glaub, ich werd mir wohl ne Boot Camp Partition basteln. So ein Mist!!!


    Gruß
    Martin
     
  11. DominoXML

    DominoXML New Member

    Hi Martin,

    ich habe durch Zufall das von Dir beschriebene Verhalten (kein Mount unter OSX) aber unter Windows (Parallels) verfügbares Gerät mit einem Handi in meiner Firma nachstellen können. (Wollte es kaum glauben.)

    Ich hoffe Du hast noch etwas Zeit. Ich denke ich kann das jetzt bei mir mal austesten.

    Gruß

    Volker
     
  12. DominoXML

    DominoXML New Member

    Hi Martin,

    nachdem nichts mehr geht folgender Tipp:

    Alle USB- Geräte abstecken.

    In Win (Parallels):

    Start-Einstzellungen-Systemsteuerung-Verwaltung-Computerverwaltung-Gerätemanager-USB-Controller

    Dort mit der rechten Maustaste alle USB-Einträge löschen (Deinstallieren).

    Dann:

    Start-Computer Ausschalten-Neustart

    Nach dem Reboot sollte Windows anfangen automatisch die Geräte neu zu installieren. Jetzt Gerät für Gerät in Betrieb nehmen (anschließen).

    Hoffe es hilft.

    Gruß

    Volker
     
  13. rollerm

    rollerm New Member

    Hi Volker,

    und ich dachte schon, ich bin mittlerweile der einzige, der dieses Problem kennt ;) .

    Win XP hat sich gemäß deines Tips genau so verhalten, wie es sollte. Alles ist jetzt neu installiert. Alleine die Fehlermeldung ist noch die gleiche. Irgend etwas in OS X hält die USB Geräte scheinbar fest.

    Ach ja, jetzt lässt sich die eingebaute iSight Kamera unter Win XP auch nicht mehr installieren.

    Ich glaube, in Parallels ist eine Zeitschaltuhr für USB-Deaktivierungen eingebaut. :meckert:

    Werde auf jeden Fall auch alles Erdenkliche testen. Irgendwie muss das Ding doch zum laufen zu kriegen sein. Es ging doch auch vor einer Woche noch!

    Grüße
    Martin

    P.S.: Habe mal eine Sicherung (von Parallels virtueller HD) von vor 14 Tagen zurückgespielt. Fazit: Keine Veränderung!
     
  14. DominoXML

    DominoXML New Member

    Hi,

    sollte es wirklich so sein, daß OSX die / das Laufwerk im Griff hat sollte folgendes im Terminal Aufschluß geben:

    cd /Volumes
    ls

    Gibt die Liste der von OSX gemounteten Laufwerke.

    Ausgeworfen wird mit:

    "umount -f /Volumes/LAUFWERKSNAME"

    Wichtig:

    Unter UNIX ist die Eingabe case sensitive und Leerzeichen im Namen müssen mit Anführungszeichen umschlossen werden. Bei mir habe ich es schnell mal mit

    umount /Volumes/"Daten 500GB" probiert.

    Wenn das Laufwerk in Benutzung ist läßt sich das Laufwerk nicht auswerfen.

    Es kommt statt dessen:
    "unmount(/Volumes/Daten 500GB): Operation not permitted"

    in diesem Fall hilft ein:

    sudo umount -f /Volumes/"Daten 500GB"

    Nach Passworteingabe deines Admin Accounts wird das umount erzungen.
    Im schlimmsten Fall ist beim Erwingen mit Datenverlust zu Rechnen.

    Zum Überprüfen kannst Du im Terminal folgendes eingeben:

    cd /Volumes/"Daten 500GB"
    ls

    Wird nichts angezeigt ist das Volume wirklich ausgeworfen.

    Dann zur Sicherheit Rechner neu Starten.

    Gruß

    Volker

    P.S. Die Betriebssystempartition sollte aber auf gar keinen Fall ausgeworfen werden.
     
  15. rollerm

    rollerm New Member

    ... Parallels Inc. selbst keine Lösung für das Problem hat, habe ich beschlossen meine eigene Lösung umzusetzen.

    - Datensicherung
    - Parallels HDD wegsichern, dann löschen
    - Boot Camp Partition erstellen
    - XP dorthin installieren
    - gesicherte Daten zurückspielen
    - Boot Camp Partition in Parallels einbinden
    - alles geht wieder!

    Keine Ahnung, warum die USB Geräte von OS X scheinbar festgehalten wurden,
    aber in keinem Forum, wo dieses Problem angesprochen wurde, konnte bisher eine Lösung gefunden werden. Vermute mal, dass der Build 3188 noch USB Nachholbedarf hat. Na ja...

    Trotdem ein geniales Tool, für die paar Windows Programme, die ich noch brauche. Auf meiner neuen Boot Camp Partition werd ich jetzt wohl mal ein Spielchen spielen :)

    Danke noch mal an alle, die versucht haben zu helfen (Special THX an Volker)!!!

    Grüße
    Martin
     
  16. Christian-online

    Christian-online New Member

    Hallo zusammen,
    ich greife das Thema nochmal auf, da ich seit ca. 4 Stunden dasselbe Problem habe:

    Mein USB-Drucker (und auch ein Handy) wird von Parallels plötzlich nicht mehr akzeptiert. Es kommt stets die Meldung, wonach das Gerät bereits von einem anderen Programm benutzt werde und man dieses Programm erst schließen müsse.
    Stimmt aber nicht.
    Habe auch alle möglichen Einstellungen probiert (automatische / manuelle Einbindung), Gerät im OSX von der Druckerliste gelöscht) nichts hilft.

    Bislang hat alles problemlos geklappt. Plötzlich geht nix mehr. Ich habe allerdings heute ein OSX Update installiert. (Sonst war aber alles gleich.)

    Gibt es vielleicht neue Erkenntnisse ?

    Danke schon mal im Voraus!

    Gruß
    Christian

    PS: für mich ist das sehr ärgerlich, weil ich einen Drucker nutze (Xerox DocuPrint P1210), für den es keinen OSX-Treiber gibt. Bin also lahmgelegt.
     
  17. DominoXML

    DominoXML New Member

  18. Christian-online

    Christian-online New Member

    Hallo Volker,

    danke für den Hinweis.

    Tja, hilft uns hier in Deutschland in der Tat noch nicht weiter. Ich hoffe, Parallels bringt bald was. Habe jedenfalls auch den dortigen Support angeschrieben.

    Falls was kommt, poste ich es hier,

    Gruß
    Christian
     
  19. DominoXML

    DominoXML New Member

    Tja Schade,

    aber zu deinem Drucker. Da wirst du wohl keinen nativen Treiber mehr bekommen.

    Versuch es mal hiermit mit dem HP Laserjet 4 Treiber. Dein Drucker sollte damit gehen.

    http://www.linux-foundation.org/en/OpenPrinting/MacOSX/hpijs

    Sollte das gehen nutzt Du unter Windows einfach FreePDF XP und druckst mit OS X aus.

    Übrigens Willkommen im Forum.

    Gruß

    Volker
     
  20. Christian-online

    Christian-online New Member

    Hallo Volker,

    zweifaches Danke !!

    a) fürs Willkommen,

    und b) für den Tipp mit dem Druckertreiber. Ich hatte zwar schon fast alle Treiber von Xerox ausprobiert - aber keinen von HP. Und der geht jetzt tatsächlich.
    Da hast Du mir sehr geholfen !!

    Dann kann ich das USB-Problem bei Parallels fast (...) entspannt sehen.

    Gruß
    Christian
     

Diese Seite empfehlen