usb-unverträglichkeit/mac friert beim au

Dieses Thema im Forum "Software" wurde erstellt von nina, 3. Oktober 2000.

  1. nina

    nina New Member

    so langsam bin ich am Ende aller Weisheit. Habe Mac G4 OS 9.0.4 und 4 Geräte am USB-Hub. Solange ich nur ein USB-Gerät benutzte, gab es keine Probleme. Sobald ich zwei in einer Session benutzen wollte, verweigerte eines den Dienst. Habe mir auf Anraten sämtliche neuen Treiber runtergeladen und installiert, aber es wird eigentlich nur immer schlimmer. Sobald ich den Mac ausschalten will, nachdem ich ein Peripheriegerät verwendet habe, friert die Maus ein. Der Drucker bringt die Kiste gar sofort zum Absturz. Wahrscheinlich habe ich jetzt soviel Mist auf der Festplatte, dass nix mehr geht. Was soll ich tun? Der Tip aus der DOSenwelt lautete: Alles neu installieren. Wie macht man das? Ich kann ja wohl kaum den gesamten Finder in den Papierkorb werfen. Kann mir jemand helfen?

    Nina
     
  2. friedrich

    friedrich New Member

    Hallo Nina,

    Du hast ja wirklich viel Spaß mit Deinem Rechner...

    Ich hab nur 2 USB-Geräte, das läuft prima. Neu installieren heißt: Mit der Start-CD-ROM ein neues System auf dem Rechner zu installieren, entweder das alte überschreibend oder indem Du einen neuen Systemordner anlegst und danach den alten wegwirfst. Letzteres hat den Vorteil, daß Du aus dem alten Systemordner Erweiterungen und Kontrollfelder, die Du nachträglich installiert hast, in den neuen verschieben kannst, um sie nicht erneut installieren zu müssen - denn die sind in der Regel bei einer Neuinstallation weg.
    Teilweise, in bezug auf die USB-Treiber, ist das ja hier gewollt, aber ATM/ATR/etc. müßten dann auch neu von CD/aus dem Netz installiert werden.

    Ob das Sinn macht? Das ist viel Arbeit (rechne mit einem Tag Arbeit, bis alles wieder läuft wie früher) und löst das Problem vielleicht nicht.

    Vielleicht hat ja jemand einen Tip, der die Neuinstallation überflüssig macht...

    Liebe Grüße,
    Ole
     
  3. Lars

    Lars New Member

    Bevor Du Dein System mit allem drum und dran plattmachst und zeitaufwendig alles neu installierst  versuch es mit einem anderen Hub, leih Dir bei Bekannten eines oder gib es zurück und kauf ein anderes. Solche Sachen dürfen mit den soliden Geräten, die Du hast (ich erinnere mich an ein älteres Posting: Stylus, Snapscan, Omninet und LaCie-Brenner, oder?), nicht vorkommen.

    Ich hab ein Hub von Dr. Bott. Das blinzelt nur kurz, wenn ich den Drucker einschalte und hält sich ansonsten zurück.

    Mal noch ne ganz dumme Frage: Dein Hub ist mit seinem Netzteil verbunden und bekommt Strom, oder?
     
  4. nina

    nina New Member

    mein hub ist von texas instruments (der system profiler hats verraten) und wenn ich das entsorge und alles wechselweise an der tastatur einstöpsele, nutzt das auch nix. hab ich alles schon ausprobiert. absturz, wie gehabt.
    und das hub kriegt auch strom, keine bange. das ding leuchtet wie´n weihnachtsbaum.
     
  5. Heiko

    Heiko New Member

    Hallo Nina,
    mit USB hab ich auch schon ähnliche Probleme gehabt, habe ebenfalls ein HUB von TI (laut SystemProfiler). Ich habe das Problem dadurch gelöst, daß ich die angeschlossenen Geräte mit eigener Stromversorgung betreibe und das HUB OHNE eigene Stromversorgung, d.h. per "BUS-POWER". Die Vorgehensweise war allerdings etwas kniffelig: zunächst habe ich den Rechner nur mit angeschlossener Tastatur + Maus gestartet, dann einen Neustart mit löschen der PR und neuanlegen der Schreibtischdatei gemacht. Dann habe ich das HUB angeschlossen (wie gesagt, OHNE eigene Stromversorgung!) und im Profiler nachgesehen, ob es erkannt wurde: Bingo! Dansch Neustart, im Profiler nachgesehen, ob es erkannt wurde, wenn ja, Drucker anschließen, im Profiler nachsehen, Neustart usw., und so weieter mit jedem Gerät nacheinander, bis alle 4 erkannt sind und auch wieder erkannt werden! Die Ursache des Problems liegt warscheinlich darin, das der Mac bzw. das OS beim Start den USB-Bus scannt und dabei Einschaltsignale sendet, die in der USB-Spezifikation eigentlich nicht vortgesehen sind. Da verschiedene Geräte darauf nicht vorgesehen sind, wie offensichtlich das HUB von TI, gibt beim Start Probleme. Beobachte mal die Lampen am HUB: ohne eigen Stromversorgung ist alles aus, wenn der Mac aus ist, beim Start geht eine an, wieder aus, wieder an und bleibt dann an: Mac hat HUB erkannt. Wenn jedoch das HUB eine eigene Stromversorgung hat, ist ein Lämpchen auch an, wenn der Mac ausgeschaltet ist. Wenn man dann startet, versucht der Mac etwas einzuschalten, was bereits eingeschaltet ist, und schon gibts ein Problem... Entweder hängt er sich beim Starten auf (meist OS 9), oder, auch sehr beliebt, er erkennt die am HUB angeschlossenen Geräte nicht zuverlässig (meist OS 8.6). Habe viel probiert, Update auf 9.0.4 hat auch nicht geholfen, jetzt läuft bei mir 8.6 i.d.R sehr stabil (wenn man mal von der Demo-Version Freehand 9 absieht!). Viel Glück!
     
  6. nina

    nina New Member

    heieiei, das klingt ja äußerst kompliziert. was bitte ist ein neustart mit löschen der PR? Public Relations?? und wie legt man eine schreibtischdatei neu an?
    und nochmal grundsätzlich: der mac erkennt den hub, und wenn die jeweiligen geräte angeschaltet sind, erkennt er die auch - was nicht heißt, dass er mit ihnen zusammenarbeitet. und ohne hub stürzt die kiste ja auch ab, das ist ja das blöde. Aber ich werde es ausprobieren, sobald ich weiß, was du mit PR meinst :))
     
  7. Heiko

    Heiko New Member

    Hallo Nina,
    PR- löschen bedeutet, das Parameter - RAM zu löschen, und zwar beim Systemstart. Das funktioniert folgendemaßen: Mac einschalten und dabei gleichzeitig APFEL, ALT, P und R drücken. Halte die Tasten LANGE gedrückt, mindestens solange, bis der Startgong 5x ertönt ist. Danach mußt du evtl. deine Einstellungen für Mausgeschwindigkeit und Tastatur-Ansprechverhalten neu einstellen. Danach wie vorher beschrieben Schritt für Schritt die Geräte einzeln anschließen und zwischendurch neu starten + kontrollieren!
    PS.: Wann hast du denn das letzte Mal die Schreibtischdatei neu aufgebaut? (Beim Start nach dem Laden der Systemerweiterungen APFEL und ALT gedrückt halten)
     
  8. nina

    nina New Member

    aha. davon habe ich laie ja noch nie gehört. das ist ja die reinste flossenakrobatik. und was ist auf dem parameter-ram gespeichert außer den einstellungen für maus und tastatur?

    und zum P.S. Ich habe noch nie die Schreibtischdatei neu aufgebaut - wozu soll das denn gut sein?
     
  9. friedrich

    friedrich New Member

    Im Parameter-RAM ist nicht sehr viel, einige Grundeinstellungen halt.

    Und die Schreibtischdatei speichert die Info darüber welche Datei welches Icon bekommt resp. zu welchem Programm sie zugeordnet wird.

    Durch das Neuanlegen ändert sich nicht viel, das PRAM wird halt nur wieder in den Originalzustand versetzt, und die Schreibtischdatei wird neu erstellt, d.h. etwaige Fehler darin behoben, die sich im Laufe der Zeit einschleichen.

    Die beiden Tips sind Evergreens, wenn irgendwas irgendwie nicht funktioniert - ob sie helfen, ist fraglich, aber versuchen kann mans immer. Hat man das zumindest ausgeschlossen.

    Liebe Grüße,
    Ole
     
  10. Heiko

    Heiko New Member

    s ganz gut.
    Zu deinen Fragen: Im PRAM werden, grob gesagt, grundlegende Hardwareeinstellungen gespeichert, und zwar permanent, auch wenn der Rechner nicht ans Stromnetz angeschlossen ist. (Um die Daten zu speichern, sitzt im Mac eine kleine Batterie, die normalerweise recht lange hält.) Das ganze dient dazu, das der Rechner beim Start seine Hardwarekomponenten nicht erst suchen muß, sondern sofort die Konfiguration vor dem Ausschalten wieder herstellt. U.a. wird dort auch gespeichert, welches STARTVOLUME er nutzen soll, hab' ich eben vergessen dir zu sagen, mußt du im Kontrollfeld Startvolume neu markieren!!!!
    Kurz gesagt dient das PRAM dazu, den Start zu beschleunigen und nicht erst alles neu abchecken zu müssen! Bei Problemen mit der Hardware ist es aber manchmal ganz gut, wenn der Rechner beim Start alles neu durchcheckt, dazu löscht man das PRAM.
    So ähnlich liegt der Fall auch bei der Schreibtischdatei: Um überhaupt etwas wiederzufinden gibt es die unsichtbare Schreibtischdatei:
    1.: Was man normalerweise nicht sieht: Alles, was auf der Festplatte gespeichert ist, hat sozusagen eine Adresse oder "Hausnummer". Solange eine Datei inhaltlich nicht verändert wird, bleibt sie dort unter dieser "Hausnummer".
    2.: Was man sieht: Wenn eine Datei gespeichert wird, erscheint sie als Icon auf dem Schreibtisch, entweder direkt oder innerhalb der SICHTBAREN Ordnerstruktur auf der Festplatte. Diese sichtbare Ordnerstruktur hat jedoch nichts mit der eigentlichen Strucktur auf der Festplatte zu tun, sie dient lediglich dazu, schnell und bequem mit dem Rechner zu arbeiten.
    Die Verknüpfung der "Hausnummer" mit der sichtbaren Ordnerstruktur wird in der Schreibtischdatei gespeichert. Wenn du eine Datei innerhalb der sichtbaren Ordnerstruktur an einen anderen Platz legst, werden in der Schreibtischdatei die "Umzugsdaten" gespeichert, z.b. "Umzug von A nach B", bei 2. mal z.B. "Umzug von B nach C" und beim 3. mal "Umzug von C nach D". Mit jedem Umzug sammeln sich mehr Informationen, die meistens nicht mehr benötigt werden. Beim neuanlegen der Schreibtischdatei werden die unnötigen Umzugsdaten gelöscht und die Datei kann schneller gefunden werden.
    Das neuanlegen sollte man mindestens 1x im Monat machen, je nach Arbeitsintensität auch häufiger, sonst wird das Öffnen einer Datei oder eines Ordners im Laufe der Zeit immer langsamer.
     
  11. nina

    nina New Member

    diverse abstürze später.... also, PRAM und schreibtischdatei gelöscht, aber der Hub ist eigentlich nur ein nachrangiges Problem... denn schon nach dem ersten Schritt (anschalten, Hub dran, nachschauen, neustart) blieb die Kiste wieder hängen. Mac hat Hub erkannt, und Hub spielte auch ohne Stromversorgung Weihnachtsbaum (5 leuchtende Lämpchen) aber der Neustart fiel aus zwecks is nich. Momentaner Stand der Dinge ist, dass die Kiste nur ordnungsgemäß runterfährt, wenn ich nur ein usb-Gerät eingestöpselt habe und benutze und ja nix ein-und ausstecke, keine zwei Geräte anschalte und bloß nicht im Systemprofiler nachgucke (ob mit oder ohne Hub)...
    Ich habe so das Gefühl, dass es immer schlimmer wird, denn früher konnte ich zumindest rumstöpseln und versuchen, zwei Geräte zu benutzen. Da kam dann halt ne Fehlermeldung, aber ich konnte die Kiste noch ausmachen. So gesund können doch diese ganzen Abstürze nicht sein, oder? Nicht, das das Ding vollends den Geist aufgibt. So langsam mach ich mir echt Sorgen. Oder habt ihr noch ein paar Insidertipps für mich auf Lager?

    Nina
     
  12. friedrich

    friedrich New Member

    Hast Du mal mit Erste Hilfe und/oder Norton DiscDoctor Deinen Rechner gecheckt? Tu das!
    Hast Du mal mit ATM alle Schriften geprüft?

    Wenn in den Dateiverzeichnissen etc. was im Argen ist oder eine Schrift kaputt ist, führt das gern zu sinnlosen, unkontrollierbaren und vor allem immer schlimmer werdenden Abstürzen.

    Liebe Grüße,
    Ole
     
  13. nina

    nina New Member

    Norton Disc Doctor hab ich nicht, und die Erste Hilfe checkt den Rechner automatisch, sobald er nach dem Absturz wieder hochfährt (zumindest kommt da so´ne Meldung): Von ATM hab ich auch nur die Variante, die die Schriften glättet, nicht das Verwaltungsprogramm. (warst das nicht auch du damals...?)Außerdem weiß ich nicht, wie man kaputte Schriften checkt.
    Aber ich glaube langsam echt, dass ich vielleicht doch alles neu aufspielen sollte. Gestern nacht verabschiedete sich die Kiste auch mit Absturz, obwohl ich "nur" im Internet war. Heute früh habe ich den gesamten Finder auf CD gebrannt, und - oh Wunder - Ausschalten ohne Absturz.
    Aber wie installiert man neu? Mit der G4-CD, schätze ich mal. Aber woher weiß Rechner, dass er neu installieren muss und dass er von der CD hochstarten soll und nicht ganz normal von der Festplatte? Ich bräuchte ne detaillierte Anweisung. Bin da etwas panisch, weil ich doch keine Ahnung habe von dem unbekannten Wesen RECHNER. ;-))
     
  14. Heiko

    Heiko New Member

    Hallo Nina, keine Panik!
    Als erstes leg mal die System-CD, die mit dem Rechner geliefert wurde, ins Laufwerk! Dann stöpsel außer Tastatur + Maus alles an externen Geräten ab. Dann über Menü Spezial Neustart anklicken und sofort die Taste "c" auf der Tastatur drücken und gedrückt halten bis die Meldung kommt "System startet". Der Schreibtischhintergrund hat jetzt warscheinlich ein anderes Muster als sonst, dauert alles auch etwas länger, das kommt daher, das das System jetzt von der CD gestartet wurde. Das ist notwendig, weil Erste Hilfe die Festplatte, wenn von ihr aus gestartet wurde, nicht reparieren kann.
    Auf der System-CD (das Fenster sollte jetzt bereits geöffnet sein) findest du den Ordner "Dienstprogramme", darin befindet sich das Programm "Erste Hilfe". Starte das Programm, wähle die Festplatte aus und klick auf "überprüfen". Im Programmfenster kannst Du jetzt sehen, was geprüft wird zum Schluß sollte ein "Laufwerk xy ist ok" kommen. Wenn dabei die Meldung "Laufwerk xy muß repariert werden" kommen sollte, mußt du auf reparieren klicken.
    Damit wäre erst einmal WARSCHEINLICH, daß auf der Festplatte alles ok ist (leider übersieht Erste Hilfe manchmal etwas, deshalb gibts auch noch Norten Disk Doktor, der leider etwas kostet).
    Wenn alles ok oder repariert ist, mußt du nun im Apfelmenü die Kontrollfelder anklicken, dann das Kontrollfeld Startvolume öffnen, deine Festplatte auswählen und wieder einen Neustart auslösen (diesmal ohne "c"). Während des Neustarts am besten nochmal die "Fingerakrobatik" PRAM löschen.
    Was ist dabei rausgekommen?
    PS.: ist im Rechner selbst irgendetwas zusätzlich installiert worden (Arbeitsspeicher, Laufwerke, PCI-Karte)????
    Hast du viele Programme installiert und viele eigene Datei gespeichert?
     
  15. nina

    nina New Member

    Hallo Heiko, das mit der ersten Hilfe hab ich schon ausprobiert, die sagt, dass alles okay ist. Ich glaube auch nicht, dass meine Festplatte ne Macke hat, sondern dass ich einfach zuviel Mist drauf habe (laut SystemProfiler 193 Systemerweiterungen und 262 Programme). Ich frag mich auch, wo die alle herkommen...;-) Hab in der Anfangszeit viel mit Shareware von den Macwelt CDs und irgendwelchen Try out-Versionen, die nach 30 Tagen absterben, herumexperimentiert. Jetzt gammeln da irgendwelche nutzlosen Reste auf meinem Rechner rum, die sich vermutlich beißen. ich würds ja gern runterschmeißen, weiß aber nicht, was wichtig ist und was nicht. Deshalb die Idee mit der Neuinstallation, sprich den Computer in den Ausgangszustand zurücksetzen und nur die Schriften, Treiber und Programme installieren, die ich wirklich brauche. Die Mac Hilfe bietet mir jetzt die Versionen "Neuinstallation Software" oder "neuen Systemordner anlegen". Welche würdest du mir empfehlen? Ist damit auch wirklich aller alter Mist gelöscht?
     
  16. friedrich

    friedrich New Member

    Hallo Nina,

    jaja, wir kennen uns... aber welche Programme Du hast und welche nicht, erinnere ich nicht wirklich.

    Nun denn, Du hast ja den Kompletten Systemordner auf CD gesichert, jetzt kann nicht mehr viel passieren. Zur Neuinstallation empfehle ich »Neuen Systemordner anlegen«, dann ist der jungfräulich. Nach der Installation hast Du 2 Systemordner - schmeiß den alten weg und starte neu: Jetzt läuft der Rechner auf dem neu aufgespielten System und Du mußt oder kannst erstens alle möglichen Dinge neu konfigurieren (Maus, Schreibtischhintergrund etc. also alles, was Du angepaßt hast) und zweitens Schriften, Treiber etc. neu aufspielen - am besten von den Original-CDs, wenn es aus dem Internet kam, eben wieder von der Sicherungs-CD.

    Probier aber ganz am Anfang, ob sich Dein USB-Problem gelöst hat.

    Wenn Du richtige Probleme hast zwischendurch, aber nicht ins Netz kommst, um nach Hilfe zu schreien, kannst Du mich gern anrufen: (040) 42 31 42 13 oder (0179) 522 70 51.

    Liebe Grüße,
    Ole
     
  17. jack

    jack New Member

    Hallo Nina!

    Was hast du denn für eine Drucker? Ich habe riesige Probleme mit einem OKIpage 8 iM gehabt! Dabei fiel ständig der USBport aus - es wurde sogar die Platine in meinem iMac ausgewechselt weil der Verdacht bestand, dass ein Fehler an dem USB port die Ursache sei. Zuletzt war es aber nur der Drucker (was ich erst nach ewig langem ausprobieren herausbekam!!)
    Gruß Jack
     
  18. nina

    nina New Member

    ich hab nen Epson 740, der spinnt schon ab und an, aber ich glaube, das ist das erwähnte usb-problem und nicht der drucker selbst. wenn ich ihn allein benutze, verrichtet er brav seinen dienst.
    naja, ich mach mich jetzt mal dran an meinen neuen systemordner...
    und tschüss!
     
  19. nina

    nina New Member

    Hallo, ich lebe noch. und der Rechner auch. Es war wohl tatsächlich der Hub, der alles durcheinanderbrachte. Habe einen neuen Systemordner aufgespielt und alle Treiber neu und wenn ich nur zwei Geräte (Omninet am Rechner und den Rest an der Tastatur) anschließe, geht alles glatt. Mit Hub - Streik. Muss mir halt immer vorm Einschalten überlegen, was ich tun will. Lästig zwar, aber immer noch besser als Abstürzen. Euch allen auf jeden Fall ganz liebe Grüße und danke danke

    Nina
     

Diese Seite empfehlen