Vernetzung PC mit G4 über Router

Dieses Thema im Forum "Software" wurde erstellt von NikiBuhn, 17. Juli 2002.

  1. NikiBuhn

    NikiBuhn New Member

    Hallo,
    meine Haare stehen mir vom vielen Raufen zu Berge und in meinem Kopf schwirren nur noch Wörter wie TCP/IP, SMB, PCMACLAN, IP Adressen, etc. rum. Vielleicht schafft es ja jemand dieses Chaos zu entwirren - ich wäre zutiefst dankbar.

    Es geht eigentlich darum, dass ich einen Windows Rechner mit Windows 2000 Professional sowie einen G4 mit OSX über einen SMC Barricade 7004ABR Router miteinander vernetzen möchte. Nun wurde mir gesagt, dass dies über TCP/IP möglich sein soll???! Trotz diverser Versuche, habe ich aber keine Verbindung zwischen den beiden Systemen herstellen können und konnte auch keine Antwort in den diversen Foren finden, die ich durchstöbert habe. Kennt jemand die Lösung bzw. gibt es eine?

    Oder kommt man nicht drum rum, sich eine Software wie PCMACLAN oder Dave zu kaufen?

    Für Eure Hilfe schon mal besten Dank.
    Niki
     
  2. Kafi

    Kafi New Member

    Also, Du brauchst jedenfalls weder DAVE noch PCMacLAN, weil
    1. soweit ich weiß, hat Win2000 das Appletalk-protokoll integriert

    und

    2. Kann OS X ja mittlerweile das Samba-Protokoll.

    Daraus ergeben sich 2 Möglichkeiten
    1. Win2000 -> Apple Talk aktivieren -> Ordner freigeben (keine Ahnung, wie das bei Win2000 geht) -> Bei OS X in der Spaltendarstellung ganz an den Anfang scollen, Netwerk -> Da sollte der dann sein
    Aber: Ich habe mal irgendwo gelesen, dass OS X Appletalk auch nur noch wegen der Drucker hat. Inwieweit Apple das in 10.1 geändert hat, könnte mich ja mal irgendwer aufklären ;-)

    2. Win2000 -> Ordner freigeben (möglichst unter 8 Buchstaben) ->Hostnamen des Rechners rausfinde...

    OS X: Finder -> Gehe zu -> mit Server verbinden ... dann
    smb://<hostname des winrechners>/<Ordner-Name>

    und voilà. so sollte es gehen

    es gibt auch noch tools, smb-netze zu browsen....hier könnte jemand die namen schreiben... ;-)
     
  3. MacGhost

    MacGhost Active Member

    Hi,

    Win2000 Server kann nur AT Freigaben mache (SfM), die Pro Version hat zwar das Protokoll AppleTalk kann aber nichts mit anfangen.
    Da setzten dann Dave und Cops Talk an.

    Joern
     
  4. MacGhost

    MacGhost Active Member

    Moin,

    wenn Du OS X und Win2k miteinander vernetzen willst dann ist das recht einfach.
    Stell den Router am besten auf DHCP und die beiden Systeme auch, dann ersparst Du Dir die Konfiguration wenn Du Glück hast.
    Aber nun kommt ein Hinweis den Du unbedingt beachten solltest:
    - keine Rechnernamen mit Umlauten, Sonderzeichen oder Leerzeichen verwenden (möglichst nicht länger als 15 Zeichen)

    - Windowsfreigaben auch ohne Umlaute, Sonderzeichen oder Leerzeichen. (hier kannst Du mehr Zeichen verwenden)

    Dann vom Mac aus (der kann z.Z. nur Client sein) mit Apfel+k (oder gehe zu mit Server verbinden...) , dann kommt ein Dialogfeld wo Du Klicken kannst (klappt scheinbar nur bei AT Netzen) und unten eine Adresse eintragen.
    cifs://rechnername/sharename
    oder
    smb://rechnername/sharename

    Ansonsten kannst Du es auch mit der IP Adresse versuchen.
    Die bekommst Du unter Win2k heraus indem Du eine DOS Eingabeaufforderung öffnest und dort den Befehl ipconfig eingibst.

    Joern

    PS: Schau doch mal unter
    http://forum.macwelt.de/cgi-bin/mac_forum/topic_show.pl?id=7357
    Da steht auch noch einiges drin.
     
  5. logan5

    logan5 New Member

    nutze nebenbei win2k pro (englische version) und versuche auch schon recht lange, osx mit win2k via smb zu verbinden, scheitert bei mir bis jetzt, habe viel zeug gelesen, haben den O-Ton gedacht rauszuhören, dass man für smb einen WINS Server im LAN installiert haben muss, und das unterstützt nur die server version von 2k, liege ich da falsch? Bin alle Verfahren die im Forum beschrieben durchgegangen, aber keines fruchtete. nutze zone alarm auf der Dose habe aber die IP von OSX freigegeben unter zone alarm funktioniert aber trotzdem nicht, kann mir noch wer helfen?
     
  6. MacGhost

    MacGhost Active Member

    Hi,

    geht auch ohne WINS Server, nur ist da die Kontaktaufnahme wesentlich erleichtert.
    Stellt mal die ZoneAlarm ab und versuche es mit

    cifs:// anstatt smb://
    ansonsten Sharity ist zu empfehlen oder SMBrowse, aber das letzte rennt auch nur richtig wenn ein WINS Server im Netz ist.
    Ach schau mal ob unter Win auch die Browserdienste gestartet werden.

    Joern
     
  7. logan5

    logan5 New Member

    zone alarm deaktiviert funzt leider immer noch nicht, wo finde ich unter 2k die sache mit den browserdiensten? meine freigegebenes Volume unter 2k heisst areaB als sharing name ist G$ eingetragen, welchen der beiden Namen verwende ich in der cifs Pfadangabe?... Werden Verbindungen einzelner Ordner nicht gemacht, wenn nur eine von vielen Dateien den Namenskoventionen ( leerzeichen, sonderzeichen, etc,) nicht entspricht.... danke für deine (eure) Hilfe, der Router ist ein Vigor2200E, falls das noch wichtig ist...

    SMB Browse funzt garnicht bei mir... das habe ich schon aufgegeben, besteht denn die Möglichkeit zur Not unter 2k einen WINS Server einzurichten, habe von Dosen viel zu wenig Ahnung....

    danke noch einmal
     
  8. MacGhost

    MacGhost Active Member

    Hi,

    also das areaB ist der Datenträgername und nicht zu gebrauchen für Dein Vorhaben.
    Das G$ ist eine Freigabe die unter Win NT Systemen Standard ist und eine versteckte Adminfreigabe ist, da beginnt aber schon das Problem, denn das $ ist für Windows eine Funktion (verstecktes Share) und für den mac ein reguläres Zeichen.
    Gibt einfach mal einen Ordner auf der Festplatte frei, z.B. erstell den Ordner Test und gibt ihn als Test frei.
    dann vom Mac aus mit
    cifs://servername/Test oder smb://servername/Test verbinden.

    Einen WINS Server kannst Du nur auf einem NT/2K Server einrichten, nicht auf der Workstation/Pro. Variante die als Server dienen soll.
    Gab es zwar bei NT eine Trick mit der Registry, aber das ist ein anderes Thema.

    Unter Start -> Einstellungen -> Systemsteuerung -> Verwaltung gibt es den Punkt Dienste in der deutschen Version (wenn ich das noch richtig mir gemerkt habe).
    Dort ist der Punkt Browserdient der muß gestartet sein, das NT/W2K sich nach außen publiziert. Im Normalfall wird das gestartet, aber wenn Du z.B. mit Firewalls und Sharingtools (eDonkey macht so etwas) experimentiert hast, dann kann es sein das dieser Dienste nicht mehr gestartet wird.
    Der Vigor ist Klasse, meine nächste Anschaffung. Geht denn ein ping von dem PC zum Mac und umgekehrt ?

    Joern
     
  9. logan5

    logan5 New Member

    super vielen Dank funktioniert jetzt... jetzt ist mir einiges klarer... Hätte mal die ipfw vorher flushen sollen, vergesse ich immer, dann kann ja auch nichts reinkommen, hätte sie aus sicherheitstechnishcen Gründen trotzdem gerne an, weiss wer die passende Regel die Verbindung soll zum Klient 192.168.1.10 führen... Zone alarm kann anbleiben, wenn man unter advance security den lokalen Rechner einträgt...

    cuv

    logan
     
  10. mac67

    mac67 New Member

    hi,
    ähmmmm! Zusätzliche Software??ß Für was das denn!
    Er hat doch OS X!!!!

    cifs://IP ADRESSE/FREIGABE

    natürlich nicht vergessen den Ordner auf der dose freizugeben und den benutzer anzulegen!

    tschö!!!
     
  11. MacGhost

    MacGhost Active Member

    Hi,

    da steht wohl nichts von zusätzlicher Software , nur in dem gelinkten Thread, denn der bezieht sich sich auf beide Systemarchitekturen von Apple.
     
  12. NikiBuhn

    NikiBuhn New Member

    Hi Joern,

    besten Dank für Deine ausführliche Antwort. Habe auch schon die Computernamen geändert - waren natürlich Leerzeichen drinne!. Über die DHCP findet der Mac auch den PC (PING erfolgreich). Wenn ich mich jetzt jedoch über den Mac einwählen will, sagt er mir immer, dass keine Dateidienste vorhanden sind, egal ob ich über die IP Adresse, cifs oder smb gehe.

    Was habe ich auf dem PC noch vergessen freizugeben oder zu installieren? Die Laufwerke und ein Ornder habe ich freigegeben.

    Gruss,
    Niki
     
  13. MacGhost

    MacGhost Active Member

    Hi Niki,

    da bin ich aus der Ferne überfragt.
    Außer das Du vielleicht noch kontrollieren kannst ob in den Einstellungen der Netzwerkkarte die Datei und Druckerfreigabe aktiviert ist (weiß gar nicht mehr ob das unter W2K auch noch war).
    Ansonsten kann ich wiegeschrieben nichts mehr zu sagen und schauen auch nicht, da der letzte PC nun ein fast leeres Gerippe ist (war vorher W2K drauf).
    Ansonsten gibt es in den Sicherheitseinstellungen(Policiies) noch einen Punkt wo man diese Funktion beschränken kann (sichtbar aber kein Zugriff, also ein Dummydienst in dem Moment).

    Joern
     
  14. NikiBuhn

    NikiBuhn New Member

    Hallo Joern,

    manchmal ist man ja wirklich mit Blindheit geschlagen. Nachdem ich nun immer wieder mal rumgetüftelt habe, hat es nun endlich geklappt. Über den Befehl smb://rechnername/sharename(sprich freigegebenen Ordner)kann ich mit dem Mac auf den PC zugreifen. Alles was Du geschrieben hattest war völlig korrekt. Der Fehler lag in meiner Anmeldung. Die Domain gab er automatisch vor, wollte aber noch den User und das Passwort wissen (vom PC). Nun frag mich wieso, aber ich habe immer den falschen User angegeben (bei Windows 2000 hast Du ja zum einen den Administrator, dann noch Anwender und ggf. eingetragene Benutzer), tja und ich wählte den falschen! - sag ja Blindheit!!!

    Der Mac ist dann auch etwas fies - wie ich nun gelesen habe, erscheint die Meldung keine Dateidienste gefunden, wohl fast immer "egal" was man verkehrt eingegeben hat! Es hatte jedenfalls nichts mit den Diensten zu tun, sondern ausschliesslich mit meiner falschen Eingabe - soll man erstmal drauf kommen.

    Also nochmal herzlichen Dank. Bin echt happy, dass es nun geklappt hat!

    Gruss,
    Niki
     
  15. zeko

    zeko New Member

    Gibts bei WinME auch ne Chance über SMB?
     
  16. MacGhost

    MacGhost Active Member

    Moin Niki,

    das ist ja Klasse das es doch noch geklappt hat.
    Das ein falscher Eintrag zu solch Fehlermeldung führt wußte ich allerdings auch nicht, da ich mich immer richtig angemeldet habe.
    Aber gut zu wissen, aber vielleicht wird das ja mit X.2 anders ;-)

    Joern
     

Diese Seite empfehlen