Virtual PC 5: Internetzugang einrichten

Dieses Thema im Forum "Software" wurde erstellt von atimme, 5. September 2004.

  1. atimme

    atimme New Member

    Ich möchte mit Virtual PC 5 und Windows 95 eine Verbindung zum Internet herstellen. Wenn ich unter Windows den Internet Explorer starte, wird der Assistent für den Internetzugang gestartet. Welche Einstellungen muss ich hier vornehmen, um die Mac-Internetverbindung mitbenutzen zu können?
    Ich erhalte immer die Fehlermeldung, dass kein Modem gefunden wurde.
     
  2. macKnall

    macKnall Halbtagsphilosoph

    Putz alle Kleinweichteile von der Platte und fahr mit Mac pur!
     
  3. atimme

    atimme New Member

    Das würde ich ja gerne, aber ich bin darauf angewiesen, Spezialprogramme unter Windows zu nutzen, für die ich ein Update brauche.

    Laut Anleitung von Virtual PC soll das ganz einfach und problemlos sein, aber ich habe schon verschiedene Konfigurationen ausprobiert und weiß einfach nicht woran es liegt.
     
  4. macKnall

    macKnall Halbtagsphilosoph

    Dann lass es doch einfach! Die Verwendung von Windoof ist eine nicht entschuldbare Kulturlosigkeit.

    ©1991 MacKnall
     
  5. faustino18

    faustino18 New Member

    Kannste die Updates nicht einfach auf dem mac ziehen und dann rüber damit?
    Wär ja auch einfach, aber eigentlich sollte das Netz ja gehen. :confused:

    !Ziehs mitm Mac!

    Patrick
     
  6. atimme

    atimme New Member

    Ich brauche aber auch ein Windows-Update und dazu muss man erst eine Datei runterladen, die wird dann unter Windows ausgeführt und holt sich weitere Dateien aus dem Internet. Daher muss ich direkt unter Windows ins Netz.
    Das soll aber durchaus ohne Probleme möglich sein. Laut VPC-Dokumentation muss man einfach nur unter MacOS eine Internetverbindung herstellen und dann könnte man auch unter VPC auf das Internet zugreifen. Bloß wie man diesen Assistenten für den Internetzugang unter Windows konfigurieren muss wird da verschwiegen.
     
  7. Karloff

    Karloff New Member

    Also es geht ganz einfach,wenn man weis wie...
    Meine Ex hatte da auch Probleme, ich aber gar nicht, war aber ganz merkwürdig und nicht nachvollziehbar, halt Windows.
    Wir hatten das irgendwie mal gelöst, ist aber länger her...
    Wenn du hier mal alle Schritte mit den Scheiss Ansagen dokumentieren kannst könnt ich eventuell weiterhelfen.
     
  8. lamariposa

    lamariposa New Member

    Wenn Virtual PC geöffnet ist, in der Menüleiste unter "Edit" auf "Windows 95-Settings" klicken
    In dem aufgehenden Fenster muß unter "Networking" (links) "Shared Networking" aktiviert sein.
    Dazu "Networking" durch anklicken öffnen und "Enable Networking" und "Shared Networking" markieren. Anschließend logischerweise mit "OK" bestätigen und "Windows 95" neustarten - nicht Virtual PC!! (Ist eigentlich auch logisch).
    Danach sollte es gehen. Falls nicht, könntest du noch VPC beenden, die Internetverbindung vom MacOS öffnen und erst anschließend VPC starten und darin den Browser öffnen. So geht es zumindest bei mir.

    Willi
     
  9. atimme

    atimme New Member

    Hallo Willi,

    unter Bearbeiten:Einstellungen ist unter „Netzwerk“ bereits „Freigegebenes Netzwerk“ aktiviert.
    Windows 95 neu zu starten habe ich schon versucht.
    Auch wenn ich erst die Internetverbindung unter MacOS starte und dann VPC funktioniert es nicht.


    Hallo Karloff,

    ich bin folgendermaßen vorgegangen:
    • Netzwerkeinstellungen unter VPC waren schon voreingestellt (s._o.)

    • Beim ersten Start von Internet_Explorer_5 öffnet sich der „Assistent für den Internetzugang“ mit folgenden Möglichkeiten. Die gewählte Einstellung habe ich jeweils mit (•) gekennzeichnet:

    ( ) Anmelden und diesen Computer für ein neues Internetkonto konfigurieren. (Die Verbindung zwischen DFÜ-Netzwerk und Modem besteht.)
    ( ) Bestehendes Internetkonto auf diesen Computer übertragen. (Die Verbindung zwischen DFÜ-Netzwerk und Modem besteht.)
    (•) Manuelle einrichtung der Internetverbindung oder Verbindung über ein lokales Netzwerk (LAN) herstellen.

    ( ) Verbindung über Telefonleitung oder Modem
    (•) Internetzugang über ein lokales Netzwerk (LAN)

    [x] Automatische Suche des Proxyservers (empfohlen)
    [ ] automatisches Konfigurationsskript verwenden
    [ ] Manuelle Proxyserver

    Assistent für den Internetzugang ist beendet.


    • Internet Explorer geöffnet, www-Adresse eingegeben:
    „Die Seite kann nicht angezeigt werden.“


    Ich vermute, dass bei den Interneteinstellungen irgendwo der Fehler liegt.
     
  10. lamariposa

    lamariposa New Member

    Unter Windows 95 muß folgendes eingestellt, bzw. vorhanden sein:

    "Start" - "Einstellungen" - "Systemsteuerung":

    Dort:

    1.)
    unter "Netzwerk", dann den Reiter "Konfiguration":

    Dort muß der "Intel 2104-basierter Ethernet Controller" (bzw. der "DEC 2104") installiert sein,
    ohne den geht es nicht. Wird aber vorhanden sein - ansonsten installieren ("Hinzufügen", "Netzwerkkarte", dann aussuchen und mit "OK" bestätigen).

    2.)
    Unter "Internetoptionen", dann den Reiter "Verbindungen":

    Dort sollte unter "DFÜ und VPN Einstellungen", sowie "LAN Einstellungen" nichts eingetragen, bzw. abgehakt/aktiviert sein. Sollte dort etwas vorhanden, bzw. aktiviert sein, "Entfernen", bzw. deaktivieren.

    So läuft es bei mir problemlos.

    Nach dem Start des IE sollte jetzt direkt eine Verbindung zum Internet bestehen - vorher im "MAC" aktiviert - und der "Assistent für den Internet-Zugang" sollte auch nicht mehr in Erscheinung treten.

    Willi
     
  11. atimme

    atimme New Member

    Ich habe bei mir nur „PCI Ethernet DECchip 21041 Based Adapter“ in der Liste. Ist das das Gleiche?
    Jedenfalls funktionierts auch mit diesen Einstellungen nicht!
     
  12. lamariposa

    lamariposa New Member

    Ich habe bei mir nur „PCI Ethernet DECchip 21041 Based Adapter“ in der Liste. Ist das das Gleiche?

    Vermutlich ja, kannst aber auch in der "Virtual PC Hilfe" (Ist bei mir allerdings auf englisch, weiß nicht, wie die Bezeichnungen auf deutsch lauten) nachschauen: "Help Topics" - "Specifying PC Settings" - "Networking" und dort bei "PC Network Software Configuration" nachlesen.
    Danach ist dein Controller sogar der richtige, meiner funktioniert aber auch.

    Ebenfalls unter "Konfiguration" gibt es "TCP/IP" Protokolle. Dort muß "IP-Adresse automatisch beziehen" aktiviert sein (Auf "TCP/IP" klicken, dann "Eigenschaften" - "IP-Adresse")

    Bei mir gibt es übrigens 2 TCP/IP-Protololle (spielt aber, glaube ich, keine Rolle):
    TCP/IP - DFÜ-Adapter
    TCP/IP - Intel 2104-basierter Ethernet Controller (sollte bei dir entsprechend deinem Controller benannt sein)

    Willi
     
  13. atimme

    atimme New Member

    Ich habe alles so eingestellt, wie du es beschrieben hast.
    Trotzdem erscheint im Internet Explorer unten in der Statusleiste kurzfristig die folgende Meldung:
    „Download von Site: res://C:\WINDOWS\SYSTEM\SHDOCLC.DLL/dnserror.htm“
    Kann jemand etwas mit dieser Meldung anfangen?
     
  14. lamariposa

    lamariposa New Member

    Schon mal bei Google versucht? Da gibt es etliche Antworten zu diesem Problem - teils auch in englisch, scheinen aber die besseren zu sein - wenn du folgendes eingibst (inkl. Anführungsstriche!!):

    "res://C:\WINDOWS\SYSTEM\SHDOCLC.DLL/dnserror.htm"

    Sind alles Windows-User, ist aber auch ein Windows-Problem!

    Oder funktioniert es ansonsten??

    Willi

     
  15. lamariposa

    lamariposa New Member

  16. atimme

    atimme New Member

    Ich hab es aufgegeben, die Internetverbindung des Macs mitzubenutzen.
    Stattdessen habe ich eine weniger elegante Methode verwendet, die aber funktioniert:
    Ich habe meinen internen Modem an den COM_1_Anschluss der virtuellen Maschine „angeschlossen“ und mich mit dem Windows Verbindungsassistenten ins Netz eingewählt. Fertig, und es klappt endlich!

    Trotzdem vielen Dank für eure Tipps!
     

Diese Seite empfehlen