Virtual PC und USB

Dieses Thema im Forum "Software" wurde erstellt von ogama, 26. Dezember 2004.

  1. ogama

    ogama New Member

    Hallo,

    ich habe auf meinem iMac unter OSX 10.3.6 Virtual PC 6.1 installiert (mit Windows 2000 Professional als Betriebssystem).
    Wenn Windows 2000 läuft und ich ein USB-Gerät (Drucker, Scanner) anschließe, dann aktiviere ich in den Virtual PC USB-Einstellungen mit einem Häkchen das entsprechende USB-Gerät (welches in der Liste auch angezeigt wird).
    Wenn ich die USB-Einstellungen wieder aufrufe, ist das Gerät wieder deaktiviert. D.h. es läßt sich einfach nicht aktivieren. Dies wiederum bedeutet, dass ich mit Virtual PC und Windows 2000 nicht auf die entsprechenden USB-Geräte zugreifen kann.

    Wie kann ich dauerhaft mit dem Häkchen die USB-Geräte aktivieren?

    Gruß
    Uwe
     
  2. macfiete

    macfiete New Member

    Hallo Uwe.

    Ich hab zwar VPC 7 mit XP Pro, aber ich muss die USB-Geräte auch extra aktivieren.
    Die Hinweise im Einstellungsfeld sagen, dass die in der Liste aktivierten Geräte nur für den aktuellen PC genutzt werden können und nicht mehr dem Mac oder weiteren virtuellen PCs zur Verfügung stehen. Während Tastatur, Maus und andere nicht aufgeführte Geräte von allen aktivierten Rechnern gemeinsam genutzt werden.
    Deshalb wird es wohl nicht möglich sein ein USB-Gerät generell beim Start des PC zu aktivieren, selbst wenn es wie mein Karten-Programmierer garnicht am Mac läuft.

    Gruss

    Fiete
     
  3. ogama

    ogama New Member

    Hallo Fiete,

    Vielen Dank für die schnelle Antwort.

    Mit dauerhaft aktivieren meinte ich, überhaupt aktivieren. Die Häkchen bleiben nicht gesetzt, d.h. ich kann die USB-Geräte erst gar nicht aktivieren.

    Prozedere:
    a) Windows 2000 läuft im Vordergrund
    b) ich schließe den Scanner an
    c) ich öffne die USB-Einstellungen und sehe in der Geräteliste den Scanner! Ich setze das Häkchen (aktiviere das Gerät) und schließe die Einstellungen mit OK
    d) Windows 2000 gibt eine Fehlermeldung, dass das Gerät nicht angeschlossen ist
    e) ich öffne die USB-Einstellungen und das Häkchen ist weg (snief)

    (Den Scanner kann ich eh nur unter Windows nutzen, da es keinen Mac-Treiber gibt!)

    Also, jedes mal, wenn ich die USB-Einstellungen aufrufe, sind die Häkchen wieder weg! Warum?

    Gruß
    Uwe
     
  4. D_Stahl

    D_Stahl Active Member


    Schau mal nach Universaltreibern für Deinen Scanner (www.versiontracker.com)

    Hast Du schon mal VueScan probiert?
     
  5. Napfekarl

    Napfekarl Napfkuchen-Erfinder

    Wenn das die Wurzel des Übels ist: Verrätst Du uns den Hersteller und den Typ? Vielleicht funktioniert er ja ganz ohne Treiber mit dem Programm "Digitale Bilder"?

    Ciao
    Napfekarl
     
  6. ogama

    ogama New Member

    Hallo zusammen,

    es geht nicht um den Scanner an sich oder um die Treiber.

    Es geht darum, das USB-Geräte, welche ich unter Virtual-PC und Windows 2000 anschließe, in der Liste unter den USB-Einstellungen aufgeführt werden, aber nicht aktiviert werden können, da die Häkchen, die ich in den Checkboxen setze, nicht angenommen werden.

    Wenn ich die USB-Einstellungen unter Virtual-PC wieder aufrufe, sind die Häkchen wieder weg.

    Ich kann die Treiber aber nur installieren, wenn das betreffende Gerät unter Virtual-PC aktiviert ist!

    Und genau das ist das Problem!

    Gruß
    Uwe
     
  7. WoSoft

    WoSoft Debugger

    habe nur VPC7 und da ist es so, dass ein USB-Gerät zuerst vom Mac erkannt werden muss.
    Wenn ich beispielsweise einen USB-Stick bei aktivem XP einstecke, erscheint der erst auf dem Mac-Desktop. Dann krallt sich XP den Stick mit dem Ergebnis, dass der Mac eine Fehlermeldung bringt in der Art "Gerät wurde ohne anständige Abmeldung entfernt".
    Danach kommt dann unter XP die Meldung "Neues USB-Gerät erkannt" und "Treiber wurde installiert". Bei anderen Geräten kommt auch die Meldung "Neues USB-Gerät erkannt" aber dann die Meldung "Soll Windows nach einem Treiber suchen oder soll der von Diskette/CD geladen werden". In diesem Fall muss man die Treiber-CD einlegen.
     
  8. CosmicAlien

    CosmicAlien New Member

    VPC mag einfach nicht jeden USB Port am Mac.

    Den USB2.0 Port an meinem PowerBook mag VPC nicht und kein Gerät läßt sich (wie beschrieben) aktivieren.
    Das scheint wohl am internem USB Bus zu liegen, da haben die Windows Treiber Probleme, bzw. VPC.

    Den USB 1.0 Port an meinem Display kann ich nutzen, dann aber nur 1.0 langsam.
     
  9. WoSoft

    WoSoft Debugger

    könnte auch an Windows 2000 liegen. Dessen USB-Support ist nicht so augereift, wie der von XP.
     

Diese Seite empfehlen