Web-Sharing lässt sich nicht aktivieren

Dieses Thema im Forum "Hardware" wurde erstellt von Macfan, 15. Dezember 2002.

  1. Macfan

    Macfan New Member

    Moin, moin,

    Genauer gesagt, ich kann auf den Start-Button klicken, soviel ich will, nichts passiert, Internet Sharing bleibt deaktiviert. Was ist da los?

    Gruß

    Thorsten
     
  2. hakru

    hakru New Member

    Gib' doch mal folgenden Befehl in ein Terminalfenster ein:

    apachectl configtest

    ... was kriegst Du als Antwort?

    hakru
     
  3. Macfan

    Macfan New Member

    Ich bin zum esrten Mal im Terminal gewesen und hab Deinen Befehl eingegeben.
    Die Antwort

    Processing config directory: /private/etc/httpd/users

    Processing config file: /private/etc/httpd/users/thorstenalbers.conf

    [Sun Dec 15 15:22:31 2002] [alert] httpd: Could not determine the server's fully qualified domain name, using 127.0.0.1 for ServerName
    Syntax OK

    Gruß
     
  4. hakru

    hakru New Member

    Soweit gut. Dann versuch' doch mal, Websharing "von Hand" im Terminal zu starten. Du musst dazu als Admin-User angemeldet sein. Dann im Terminal den Befehl

    sudo apachectl start

    eingeben. Dann wirst Du nach einem Passwort gefragt -> Dein Admin-Passwort eingeben ... was passiert?

    hakru
     
  5. Macfan

    Macfan New Member

    Also, nach sudo apachectl start kommt jetzt:

    Processing config directory: /private/etc/httpd/users
    Processing config file: /private/etc/httpd/users/thorstenalbers.conf
    [Sun Dec 15 15:48:58 2002] [alert] httpd: Could not determine the server's fully qualified domain name, using 127.0.0.1 for ServerName
    /usr/sbin/apachectl start: httpd started

    Gruß
     
  6. hakru

    hakru New Member

    "... aber eingeben kann ich nix..."

    Während einer Passwort-Eingabe im Terminal werden die eingegebenen Buchstaben NICHT angezeigt, und der Cursor bewegt sich auch nicht weiter - soll es für Kiebize, die Dir über die Schulter schauen, schwerer machen, dein Passwort zu ergattern ...

    Du musst also "blind" das Admin-Passwort tippen und dann die RETURN-Taste. Wenn Du dich vertippst, kannst Du mit der Löschtaste löschen, aber auch hier wirst Du nix sehen. Also einfach nochmal probieren ... die ersten Schritte im Terminal sind ungewohnt, aber Du machst das schon!

    hakru
     
  7. Macfan

    Macfan New Member

    Hab ich auch schon gemerkt, siehe oben. Hüstel

    Gruß
     
  8. hakru

    hakru New Member

    httpd' (so heist der "Websharing-Service" im Terminal, wird auch "apache" genannt) startet ... mal sehen ob er auch "tut" ...

    In deinem Homeordner hat OSX neben "Bilder, Dokumente, Movies etc." auch einen Ordner für Websites - "Sites" - angelegt. Darin liegen .html Dateien - die Du Dir jetzt über den eingeschalteten httpd im Browser zeigen lassen kannst. Im Browser also mal folgende URL eingeben:

    http://localhost/~username/index.html

    1. die "Tilde" - so heisst das "~"-Zeichen, kriegst Du mit ALT-n
    2. als username musst Du deinen username eintragen ;-)
    3. index.html sollte sich in deinem Sites-Ordner befinden, ansonsten halt dort eine andere .html-Datei nehmen

    hakru
     
  9. Macfan

    Macfan New Member

    Jau, soweit bin ich jetzt.

    Gruß
     
  10. hakru

    hakru New Member

    Okay, dein Webserver funktioniert also...

    Warum sich der nicht per "Personal Websharing aktivieren" einschalten lässt --- könnte was mit internen "Schreib-/Lese-Rechten" zu tun haben, da beim "Anklicken" der Checkbox intern Einträge in Konfigurationsdateien gemacht werden müssen. Welche OS-Verson hast Du denn?

    Hast Du das ganze schon mal nach Neustart versucht? Mach doch mal jetzt mit laufendem httpd einfach einen ganz normalen Neustart ...

    hakru
     
  11. Macfan

    Macfan New Member

    Nach dem Neustart musste ich wieder in den Terminal und apache starten, weil er die http://localhost/~username/index.html datei nach dem Neustart nicht mehr anzeigen konnte. Web-Sharing lässt sich aber immer noch nicht installieren.

    Gruß
     
  12. hakru

    hakru New Member

    Du hast jetzt nicht gesagt, welche OSX-Version Du hasst ... ich würde aber mal die Rechte überprüfen/reparieren lassen.

    Am einfachsten ist das, wenn Du ne OSX10.2.x CD hast-
    kannst Du davon starten, und dann die DiskUtility aufrufen - ZUERST die Disk überprüfen lassen, und DANN erst die Rechte checken/reparieren lassen

    hakru
     
  13. Macfan

    Macfan New Member

    Ich habe 10.2.2 und vor allem die Installations-CD irgendwie in meinem Chaos verbaselt. Kann ich mit ner 10er CD zurücksetzen?

    Gruß

    Thorsten
     
  14. mats

    mats New Member

    @ hakru: Hatte unter 10.1 auch mal dieses Problem. Es lag daran, dass die SystemPreferences den entsprechenden Eintrag in der /etc/hostconfig-Datei nicht machen konnten.
    Der Dienst wurde zwar aktiviert, es gab aber kein Hinweis darauf im GUI. Nach dem Neustart war der entsprechende Dienst jeweils wieder deaktiviert (da ja nicht auf -YES- gesetzt).

    Ich hab dann dazumal einfach die hostconfig-Datei händisch geändert. Nach einem kleinen Systemupdate war dann alles wieder gut.
    (liegt wahrscheinlich tatsächlich an den Rechten)
     
  15. hakru

    hakru New Member

    Auf der 10.1 oder 10.0 CD ist die Funktion "Repair Privileges" - soweit ich weiss - noch nicht in die "Erste Hilfe" integriert, aber man kann bei "www.versiontracker.com" dieses Tool als "Apple Repair Privileges vers.1.1" runterladen ...

    Das mögliche Problem: vermutlich soll/muss man zum Reparieren der Rechte von einem anderen Volume starten, damit nicht im Startvolume repariert werden muss, also bräuchte man eine startfähige CD mit dem Tool drauf, aber vielleicht geht das Tool ja auch vom Startvolume aus ... kann ich aber nicht sagen ...

    Ich schau' mich nochmal um bei den apple-Foren, ob ich da was zu Deinem Problem finde ...

    hakru
     
  16. Macfan

    Macfan New Member

    Habe jetzt das Passwort mit Hilfe der 10.1. CD zurückgesetzt. Jetzt brauche ich zwar nicht mehr in den Terminal, apache startet von selbst, aber der start-button vom internet-sharing reagiert immer noch nicht.

    Gruß und Danke

    Thorsten
     
  17. hakru

    hakru New Member

    @macfan
    ohne Rechte-Reparatur wird das wohl mit dem nicht-reagierenden Button im GUI so bleiben, aber damit muss man dann halt leben ... Du kannst mit "sudo apachectl start" bzw. "sudo apachectl stop" den Webserver im Terminal steuern, mehr info dazu im Terminal mit "man apachectl" ...

    Wenn Du den Webserver auf Dauerbetrieb schalten willst, so dass er auch nach Neustarts gleich hochfährt, wäre der Vorschlag von "mats" gut, einen Eintrag in /etc/hostconfig zu ändern ...

    @mats
    Guter Vorschlag! Ich weiss halt immer nie, zu "wieviel Terminal" man den Leuten raten soll...

    hakru
     
  18. hakru

    hakru New Member

    Das "Festplatten-Dienstprogramm" für 10.2.2 kann offenbar die Rechte NUR auf einem OSX Startvolume reparieren - so steht's geschrieben, wenn man das Programm einfach mal aufruft ... ist also gerade andersrum als ich dachte. Dann sollte ja das repair-tool einsetzbar sein ...

    aber: vor dem Reparieren der Rechte erst die Erste Hilfe mal laufen lassen - falls nötig von der System-CD - damit die Reparatur sich nicht mit möglichen Diskproblemen rumschlagen muss ...

    ... und Geduld ist auch angesagt, die Prozedur dauert ...

    hakru
     

Diese Seite empfehlen