Webserver Apache +PHP

Dieses Thema im Forum "Hardware" wurde erstellt von rogersom, 15. Dezember 2001.

  1. rogersom

    rogersom New Member

    hallo

    ich habe folgende zwei probleme:

    1.problem
    wenn ich websharing aktiviert habe funktioniert der webserver soweit, aber nur solange ich eine verbindung ins internet habe.
    möchte aber local entwickeln und testen, daher möchte ich, dass es auch ohne internetverbindung funktioniert.

    2.problem
    eigentlich ist das php bei os x 10.1 schon dabei aber noch nicht frei geschaltet.
    ich habe dann auch versucht das httpd.conf file mit dem Pico zu ändern
    (war mit root angemeldet) im terminal habe ich dazu folgendes eingegeben sudo pico /etc/httpd.conf das einzige was erschien war der Pico, aber das file öffnete sich nicht.

    was mache ich falsch (bin leider noch anfänger)

    wer kann mir weiterhelfen, wäre sehr dankbar

    also vielen dank schon im voraus

    roger
     
  2. hakru

    hakru New Member

    löschen kannst. Aufpassen, dass du wirklich den überflüssigen File und nicht den echten Konfigfile vernichtest! Also vorher mit "more /etc/httpd.conf" bzw. "more /etc/httpd/httpd.conf" checken, wer hier was ist ...

    Für die Aktivierung der apache-module hast Du ja wohl 'ne Anleitung, hier ist jedenfalls eine (http://www.macosxhints.com/article.php?story=20010928171047621). Eigentlich musst Du nur an den "4 richtigen" Stellen in /etc/httpd/httpd.conf die "#"-Zeichen am Zeilenanfang wegmachen, damit die entsprechenden Anweisungen auch ausgeführt werden. Geänderten File abspeichern, Apache neu starten, fertig.

    hakru
     
  3. charly68

    charly68 Gast

    saug dir mal die apple x server admin anleitung runter, da steht wirklich alles drin.
     
  4. sevenm

    sevenm New Member

    De Pfad stimmt glaube ich nicht, es sollte sudo pico /etc/httpd/httpd.conf sein.

    Seven
     
  5. rogersom

    rogersom New Member

    hallo

    ich habe folgende zwei probleme:

    1.problem
    wenn ich websharing aktiviert habe funktioniert der webserver soweit, aber nur solange ich eine verbindung ins internet habe.
    möchte aber local entwickeln und testen, daher möchte ich, dass es auch ohne internetverbindung funktioniert.

    2.problem
    eigentlich ist das php bei os x 10.1 schon dabei aber noch nicht frei geschaltet.
    ich habe dann auch versucht das httpd.conf file mit dem Pico zu ändern
    (war mit root angemeldet) im terminal habe ich dazu folgendes eingegeben sudo pico /etc/httpd.conf das einzige was erschien war der Pico, aber das file öffnete sich nicht.

    was mache ich falsch (bin leider noch anfänger)

    wer kann mir weiterhelfen, wäre sehr dankbar

    also vielen dank schon im voraus

    roger
     
  6. hakru

    hakru New Member

    löschen kannst. Aufpassen, dass du wirklich den überflüssigen File und nicht den echten Konfigfile vernichtest! Also vorher mit "more /etc/httpd.conf" bzw. "more /etc/httpd/httpd.conf" checken, wer hier was ist ...

    Für die Aktivierung der apache-module hast Du ja wohl 'ne Anleitung, hier ist jedenfalls eine (http://www.macosxhints.com/article.php?story=20010928171047621). Eigentlich musst Du nur an den "4 richtigen" Stellen in /etc/httpd/httpd.conf die "#"-Zeichen am Zeilenanfang wegmachen, damit die entsprechenden Anweisungen auch ausgeführt werden. Geänderten File abspeichern, Apache neu starten, fertig.

    hakru
     
  7. charly68

    charly68 Gast

    saug dir mal die apple x server admin anleitung runter, da steht wirklich alles drin.
     
  8. sevenm

    sevenm New Member

    De Pfad stimmt glaube ich nicht, es sollte sudo pico /etc/httpd/httpd.conf sein.

    Seven
     
  9. rogersom

    rogersom New Member

    hallo

    ich habe folgende zwei probleme:

    1.problem
    wenn ich websharing aktiviert habe funktioniert der webserver soweit, aber nur solange ich eine verbindung ins internet habe.
    möchte aber local entwickeln und testen, daher möchte ich, dass es auch ohne internetverbindung funktioniert.

    2.problem
    eigentlich ist das php bei os x 10.1 schon dabei aber noch nicht frei geschaltet.
    ich habe dann auch versucht das httpd.conf file mit dem Pico zu ändern
    (war mit root angemeldet) im terminal habe ich dazu folgendes eingegeben sudo pico /etc/httpd.conf das einzige was erschien war der Pico, aber das file öffnete sich nicht.

    was mache ich falsch (bin leider noch anfänger)

    wer kann mir weiterhelfen, wäre sehr dankbar

    also vielen dank schon im voraus

    roger
     
  10. hakru

    hakru New Member

    löschen kannst. Aufpassen, dass du wirklich den überflüssigen File und nicht den echten Konfigfile vernichtest! Also vorher mit "more /etc/httpd.conf" bzw. "more /etc/httpd/httpd.conf" checken, wer hier was ist ...

    Für die Aktivierung der apache-module hast Du ja wohl 'ne Anleitung, hier ist jedenfalls eine (http://www.macosxhints.com/article.php?story=20010928171047621). Eigentlich musst Du nur an den "4 richtigen" Stellen in /etc/httpd/httpd.conf die "#"-Zeichen am Zeilenanfang wegmachen, damit die entsprechenden Anweisungen auch ausgeführt werden. Geänderten File abspeichern, Apache neu starten, fertig.

    hakru
     
  11. charly68

    charly68 Gast

    saug dir mal die apple x server admin anleitung runter, da steht wirklich alles drin.
     
  12. rogersom

    rogersom New Member

    hallo

    ich habe folgende zwei probleme:

    1.problem
    wenn ich websharing aktiviert habe funktioniert der webserver soweit, aber nur solange ich eine verbindung ins internet habe.
    möchte aber local entwickeln und testen, daher möchte ich, dass es auch ohne internetverbindung funktioniert.

    2.problem
    eigentlich ist das php bei os x 10.1 schon dabei aber noch nicht frei geschaltet.
    ich habe dann auch versucht das httpd.conf file mit dem Pico zu ändern
    (war mit root angemeldet) im terminal habe ich dazu folgendes eingegeben sudo pico /etc/httpd.conf das einzige was erschien war der Pico, aber das file öffnete sich nicht.

    was mache ich falsch (bin leider noch anfänger)

    wer kann mir weiterhelfen, wäre sehr dankbar

    also vielen dank schon im voraus

    roger
     
  13. hakru

    hakru New Member

    löschen kannst. Aufpassen, dass du wirklich den überflüssigen File und nicht den echten Konfigfile vernichtest! Also vorher mit "more /etc/httpd.conf" bzw. "more /etc/httpd/httpd.conf" checken, wer hier was ist ...

    Für die Aktivierung der apache-module hast Du ja wohl 'ne Anleitung, hier ist jedenfalls eine (http://www.macosxhints.com/article.php?story=20010928171047621). Eigentlich musst Du nur an den "4 richtigen" Stellen in /etc/httpd/httpd.conf die "#"-Zeichen am Zeilenanfang wegmachen, damit die entsprechenden Anweisungen auch ausgeführt werden. Geänderten File abspeichern, Apache neu starten, fertig.

    hakru
     
  14. charly68

    charly68 Gast

    saug dir mal die apple x server admin anleitung runter, da steht wirklich alles drin.
     
  15. sevenm

    sevenm New Member

    De Pfad stimmt glaube ich nicht, es sollte sudo pico /etc/httpd/httpd.conf sein.

    Seven
     
  16. rogersom

    rogersom New Member

    hallo

    ich habe folgende zwei probleme:

    1.problem
    wenn ich websharing aktiviert habe funktioniert der webserver soweit, aber nur solange ich eine verbindung ins internet habe.
    möchte aber local entwickeln und testen, daher möchte ich, dass es auch ohne internetverbindung funktioniert.

    2.problem
    eigentlich ist das php bei os x 10.1 schon dabei aber noch nicht frei geschaltet.
    ich habe dann auch versucht das httpd.conf file mit dem Pico zu ändern
    (war mit root angemeldet) im terminal habe ich dazu folgendes eingegeben sudo pico /etc/httpd.conf das einzige was erschien war der Pico, aber das file öffnete sich nicht.

    was mache ich falsch (bin leider noch anfänger)

    wer kann mir weiterhelfen, wäre sehr dankbar

    also vielen dank schon im voraus

    roger
     
  17. hakru

    hakru New Member

    löschen kannst. Aufpassen, dass du wirklich den überflüssigen File und nicht den echten Konfigfile vernichtest! Also vorher mit "more /etc/httpd.conf" bzw. "more /etc/httpd/httpd.conf" checken, wer hier was ist ...

    Für die Aktivierung der apache-module hast Du ja wohl 'ne Anleitung, hier ist jedenfalls eine (http://www.macosxhints.com/article.php?story=20010928171047621). Eigentlich musst Du nur an den "4 richtigen" Stellen in /etc/httpd/httpd.conf die "#"-Zeichen am Zeilenanfang wegmachen, damit die entsprechenden Anweisungen auch ausgeführt werden. Geänderten File abspeichern, Apache neu starten, fertig.

    hakru
     
  18. charly68

    charly68 Gast

    saug dir mal die apple x server admin anleitung runter, da steht wirklich alles drin.
     
  19. sevenm

    sevenm New Member

    De Pfad stimmt glaube ich nicht, es sollte sudo pico /etc/httpd/httpd.conf sein.

    Seven
     
  20. rogersom

    rogersom New Member

    hallo

    ich habe folgende zwei probleme:

    1.problem
    wenn ich websharing aktiviert habe funktioniert der webserver soweit, aber nur solange ich eine verbindung ins internet habe.
    möchte aber local entwickeln und testen, daher möchte ich, dass es auch ohne internetverbindung funktioniert.

    2.problem
    eigentlich ist das php bei os x 10.1 schon dabei aber noch nicht frei geschaltet.
    ich habe dann auch versucht das httpd.conf file mit dem Pico zu ändern
    (war mit root angemeldet) im terminal habe ich dazu folgendes eingegeben sudo pico /etc/httpd.conf das einzige was erschien war der Pico, aber das file öffnete sich nicht.

    was mache ich falsch (bin leider noch anfänger)

    wer kann mir weiterhelfen, wäre sehr dankbar

    also vielen dank schon im voraus

    roger
     

Diese Seite empfehlen