WebServer

Dieses Thema im Forum "Hardware" wurde erstellt von ddauer, 20. Februar 2002.

  1. ddauer

    ddauer New Member

    Hallo!

    Ich will einen Verzeichnisschutz unter OS X erstellen. Jetzt habe ich in das Verzeichnis /Library/WebServer/Documents/Test/ eine .htpasswd erstellt und ein Passwort crypten lassen, dann eine .htaccess mit dem Inhalt:

    AuthUserFile /Library/WebServer/Documents/Test/.htpasswd
    AuthName "Authorization"
    AuthType Basic
    <Limit GET POST>
    require valid-user
    </Limit>

    wenn ich jetzt aber das verzeichnis aufrufe, dann kommt das hier:
    Internal Server Error
    The server encountered an internal error or misconfiguration and was unable to complete your request.

    Please contact the server administrator, ddauer@mac.com and inform them of the time the error occurred, and anything you might have done that may have caused the error.

    More information about this error may be available in the server error log.

    ------------------------------------------------------------------------
    Apache/1.3.22 Server at 127.0.0.1 Port 80

    und in der error.log von httpd steht dann folgendes:

    [Wed Feb 20 17:30:07 2002] [alert] [client 123.123.123.123] /Library/WebServer/Documents/Test/.htaccess: AuthUserFile takes 1-2 arguments, text file containing user IDs and passwords

    was soll das? in der .htpasswd steht einfach admin: und das Pass halt.

    wer kann helfen??
    in der httpd.conf habe ich nur

    # This controls which options the .htaccess files in directories can
    # override. Can also be "All", or any combination of "Options", "FileInfo",
    # "AuthConfig", and "Limit"
    #
    AllowOverride All

    #
    # Controls who can get stuff from this server.
    #

    verändert.

    david
     
  2. hakru

    hakru New Member

  3. ddauer

    ddauer New Member

    *haare-raus-rauf* ich bin blöd!!!! der fehler war nur, dass die datei mit Mac Line Breaks versehen war. aber die muss man für Unix einstellen. mit bbedit ganz einfach. dann einfach im Terminal mv htaccess .htaccess
    eingeben, weil mal die datei ja anders nicht abspeichern kann, dann gehts!!!
    dave
     

Diese Seite empfehlen